Closed Bug 1051793 Opened 6 years ago Closed 6 years ago

[CMAS] Plug in real CMAS input to the CMAS application

Categories

(Firefox OS Graveyard :: Gaia::Network Alerts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

RESOLVED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: julienw, Assigned: steveck)

References

Details

(Whiteboard: [p=3])

Attachments

(2 files)

No description provided.
When this bug is completed, we should have a working application that can handle CMAS request from the network.
Depends on: 1051792
Blocks: 1051795
Target Milestone: --- → 2.1 S3 (29aug)
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
Assignee: nobody → schung
Status: NEW → ASSIGNED
Whiteboard: [p=3]
Something to check here: that we receive the system message when the attention screen is opened. Because of bug 818000 maybe the system message will be ignored if the attention screen is opened and has no system message handler.
Depends on: 1055994
Attached file Link to github
Hi Oleg, it's WIP patch because unit test part is not ready yet, but all functionality should work. Since the emulator is our only way for developing/testing here, you will need to build an emulator build and run ./run-emulator.sh. I'll attach the command for sending the fake cellbroadcast command and you could have a try first. Please feel free to ask if you face any problem while making the emulator build or any concern about the patch, thanks!
Attachment #8478170 - Flags: feedback?(azasypkin)
Confirmed with EM/EPM, and this can be landed before FL.
Comment on attachment 8478170 [details] [review]
Link to github

Looks good to me! Just few tiny nits on Github.

Thanks!
Attachment #8478170 - Flags: feedback?(azasypkin) → feedback+
Comment on attachment 8478170 [details] [review]
Link to github

Hi Oleg, patch updated with more unit test fixed and your suggestion addressed, thanks for the early feedback.
Attachment #8478170 - Flags: review?(azasypkin)
Comment on attachment 8478170 [details] [review]
Link to github

Okay, looks great! I've left several minor nits on Github. 

I've also noticed some strange behaviour - when I try to remove "Emergency Alert" notification from notification tray with right swipe, notification tray is automatically closed once notification is removed, it doesn't happen with other notifications (eg. sms or missed call notifications);

Thanks!
Attachment #8478170 - Flags: review?(azasypkin) → review+
Thanks for the detailed review!

In master: d6d2515bd3cc460bfd6c79b2b53bc1d6c18a39ba
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Gaia::SMS → Gaia::Network Alerts
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.