Closed Bug 1052466 Opened 5 years ago Closed 5 years ago

[10.10] Update titlebar/toolbar to use transparency on OS X Yosemite

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX
Firefox 36

People

(Reporter: Gijs, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

The titlebar and toolbar on Yosemite will want to use the blur/transparency that are provided by NSVisualEffectview, and we'll be wanting to use that, in turn, to "fit in" more on OS X 10.10.

Note also that the "fallback" / nontransparent color is different from 10.9, too.
Depends on: 1052522
Depends on: 1053073
Depends on: 1053176
Blocks: 1053073
No longer depends on: 1053073
Blocks: 1052522
No longer depends on: 1052522
This looks nice if you flip it on. And it automatically falls back to the right color for us if you turn off transparency in Accessibility settings. Is there anything special (beyond maybe lwt?) I need to take into account to write a real patch?

There's also a nice dark mode that would be fun to use for private windows. Are the plans for that? https://dl.dropboxusercontent.com/u/72157/Titlebar.png
Attached patch PatchSplinter Review
i.e. Is this all you need?
Attachment #8507484 - Flags: review?(jaws)
Comment on attachment 8507484 [details] [diff] [review]
Patch

Review of attachment 8507484 [details] [diff] [review]:
-----------------------------------------------------------------

This breaks the titlebar/tabbar vs. navbar border. To fix that, needs to also update the border hsl color added in bug 1065429. .4 opacity looks better to my untrained and tired eyes. Want to update the patch with that? :-)

Markus, does this make sense and/or do you think we should expect dragons somewhere? :-)
Attachment #8507484 - Flags: review?(mstange)
Attachment #8507484 - Flags: review?(jaws)
Attachment #8507484 - Flags: feedback+
Comment on attachment 8507484 [details] [diff] [review]
Patch

We should have eradicated most dragons by now (the sidebar was a good testing ground for that), but I'd prefer if we don't land this until font subpixel antialiasing is fixed. I only need one more review from jrmuizel in bug 1055622 before I can land those patches.
Attachment #8507484 - Flags: review?(mstange) → review+
(In reply to Markus Stange [:mstange] from comment #4)
> Comment on attachment 8507484 [details] [diff] [review]
> Patch
> 
> We should have eradicated most dragons by now (the sidebar was a good
> testing ground for that), but I'd prefer if we don't land this until font
> subpixel antialiasing is fixed. I only need one more review from jrmuizel in
> bug 1055622 before I can land those patches.

This can land now, right?
Flags: needinfo?(mstange)
Correct!
Flags: needinfo?(mstange)
remote:   https://hg.mozilla.org/integration/fx-team/rev/6bb4109d3f5e
Assignee: nobody → wjohnston
Status: NEW → ASSIGNED
Component: Widget: Cocoa → Theme
Product: Core → Firefox
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/6bb4109d3f5e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
The way the transparency was added looks more how Windows 7 used transparency compared to Yosemite...
After trying to get used to this for the past few weeks, I still don't really like it. The original idea was to use both kinds of vibrancy (behind-window and in-window) in the Firefox UI: in-window vibrancy for the toolbar and the active tab, and behind-window vibrancy for the tab bar background. This would have shown that this style was a conscious decision on our side and not caused by platform limitations. But now that we've decided to drop in-window vibrancy (bug 1050804), we only have behind-window vibrancy, and we're using it in a place where it doesn't belong. Can we go back to the opaque toolbar style again? We'll still be using behind-window vibrancy for sidebars, which are the right places to use the effect.
Flags: needinfo?(philipp)
(In reply to Markus Stange [:mstange] from comment #10)
> After trying to get used to this for the past few weeks, I still don't
> really like it. The original idea was to use both kinds of vibrancy
> (behind-window and in-window) in the Firefox UI: in-window vibrancy for the
> toolbar and the active tab, and behind-window vibrancy for the tab bar
> background. This would have shown that this style was a conscious decision
> on our side and not caused by platform limitations. But now that we've
> decided to drop in-window vibrancy (bug 1050804), we only have behind-window
> vibrancy, and we're using it in a place where it doesn't belong. Can we go
> back to the opaque toolbar style again? We'll still be using behind-window
> vibrancy for sidebars, which are the right places to use the effect.

Well, the kind of toolbar/titlebar combo that Firefox uses isn't used by any other OS X app that I'm aware of. I think that what we are doing right now is in the spirit of the Yosemite design, even though it doesn't follow platform conventions to the letter.

But since this is mostly a visual design decision, I'll defer to Michael…
Flags: needinfo?(philipp) → needinfo?(mmaslaney)
Depends on: 1152288
Assignee: wjohnston → nobody
This change has now been reverted in bug 1161565. No out-of-place vibrancy any more! :)
Flags: needinfo?(mmaslaney)
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.