Move additions to C*FLAGS into moz.build and do not link against the static RTL

RESOLVED FIXED in Thunderbird 34.0

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Tracking

Trunk
Thunderbird 34.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird34 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Created attachment 8472001 [details] [diff] [review]
browsercomps and flags

Port the following fixes to comm-central
Bug 1042878 - move MOZ_CAIRO_CFLAGS et al additions to C*FLAGS into moz.build
Bug 939557 - browsercomps.dll failed to build with lots of mismatches detected
Bug 937900 - Don't link browsercomps.dll against the static RTL
Attachment #8472001 - Flags: review?(Pidgeot18)
Comment on attachment 8472001 [details] [diff] [review]
browsercomps and flags

Review of attachment 8472001 [details] [diff] [review]:
-----------------------------------------------------------------

r- for one very important reason.

I've not fully tested all the ramifications of the patch beyond starting work on a simple MAPI test app.

::: mailnews/mapi/mapiDll/Makefile.in
@@ -11,5 @@
>  include $(DEPTH)/config/autoconf.mk
>  
> -# Statically link against the CRT, so that we don't go hunting around for it
> -# and not find it when we're loaded into explorer.exe or similar
> -USE_STATIC_LIBS = 1

This removal is almost certainly wrong. After looking into the rational for why USE_STATIC_LIBS was removed in bug 939577, that criteria probably doesn't apply to the MAPI DLL at all.
Attachment #8472001 - Flags: review?(Pidgeot18) → review-
(Assignee)

Updated

4 years ago
Depends on: 1054536
(Assignee)

Comment 2

4 years ago
Created attachment 8474269 [details] [diff] [review]
*_CFLAGS and remove USE_STATIC_LIB except for mapi [Checked in: Comment 3]

Without the mapi changes, requires patch from bug 1054536 too
Attachment #8472001 - Attachment is obsolete: true
Attachment #8474269 - Flags: review?(Pidgeot18)
(Assignee)

Updated

4 years ago
Summary: Port Bug 1042878, Bug 939557 and Bug 937900 to comm-central → Move additions to C*FLAGS into moz.build and do not link against the static RTL
Attachment #8474269 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 3

4 years ago
Comment on attachment 8474269 [details] [diff] [review]
*_CFLAGS and remove USE_STATIC_LIB except for mapi [Checked in: Comment 3]

http://hg.mozilla.org/comm-central/rev/9281c70c7224
Attachment #8474269 - Attachment description: *_CFLAGS and remove USE_STATIC_LIB except for mapi → *_CFLAGS and remove USE_STATIC_LIB except for mapi [Checked in: Comment 3]
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
BTW: You forgot to remove
     'unicharutil_external_s',
from /suite/build/moz.build. Will track this problem in Bug 1081519.

Updated

4 years ago
Depends on: 1081519

Updated

4 years ago
Duplicate of this bug: 1047597
status-thunderbird34: --- → fixed
You need to log in before you can comment on or make changes to this bug.