Closed Bug 1081519 Opened 5 years ago Closed 5 years ago

Linking SeaMonkey currently fails with: "error LNK2038: mismatch detected for 'RuntimeLibrary': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsSuiteModule.obj

Categories

(SeaMonkey :: Build Config, defect, blocker)

x86_64
Windows 8
defect
Not set
blocker

Tracking

(seamonkey2.32 fixed)

RESOLVED FIXED
seamonkey2.33
Tracking Status
seamonkey2.32 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(1 file)

When I currently try to link SeaMonkey on Windows with VS2012 I get this error when the build process tries to link suite.dll:
Executing: link -NOLOGO -DLL -OUT:suite.dll -PDB:suite.pdb -SUBSYSTEM:WINDOWS,5.
01 -MACHINE:X86 @c:\mozilla\tree-hg\objdirs\obj-seamonkey\suite\build\tmp2cjarx.
list module.res -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH -DEBUG -DEBUG
TYPE:CV -DEBUG -OPT:REF -IMPLIB:fake.lib ../../xpcom/glue/xpcomglue_s.lib ../../
memory/mozalloc/mozalloc.lib ../../config/external/nss/nss3.lib ../../toolkit/li
brary/xul.lib ../../js/src/mozjs.lib -LIBPATH:../../dist/lib -NODEFAULTLIB:msvcr
t -NODEFAULTLIB:msvcprt -DEFAULTLIB:mozcrt kernel32.lib user32.lib gdi32.lib win
mm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib ole32.lib version.lib u
uid.lib shell32.lib
c:\mozilla\tree-hg\objdirs\obj-seamonkey\suite\build\tmp2cjarx.list:
    nsSuiteModule.obj
    ..\feeds\src\nsFeedSniffer.obj
    ..\profile\nsSuiteDirectoryProvider.obj
    ..\profile\migration\src\nsNetscapeProfileMigratorBase.obj
    ..\profile\migration\src\nsSuiteProfileMigratorUtils.obj
    ..\profile\migration\src\nsThunderbirdProfileMigrator.obj
    ..\shell\src\nsWindowsShellService.obj
    ..\..\intl\unicharutil\util\Unified_cpp_unicharutil_util0.obj

Unified_cpp_unicharutil_util0.obj : error LNK2038: mismatch detected for 'Runtim
eLibrary': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in n
sSuiteModule.obj
   Creating library fake.lib and object fake.exp
suite.dll : fatal error LNK1319: 1 mismatches detected
Older bug on similar issue, maybe related: Bug 926083
And also see Bug 829850 on this.
Attached patch PatchSplinter Review
Ian: This removes some lib import that was forgotten to be removed in Bug 1052943 when the patch from Bug 939557 was ported to SeaMonkey. This patch fixes the build in VS2012.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #8503687 - Flags: review?(iann_bugzilla)
Component: General → Build Config
Attachment #8503687 - Flags: review?(iann_bugzilla) → review+
Blocks: 1052943
Duplicate of this bug: 1081881
(In reply to Frank Wein [:mcsmurf] from comment #4)
> Pushed to trunk: https://hg.mozilla.org/comm-central/rev/42ccebafcb89
Does this need to be pushed to comm-aurora and comm-beta?
Flags: needinfo?(bugzilla)
Target Milestone: --- → seamonkey2.33
(In reply to Philip Chee from comment #6)
> (In reply to Frank Wein [:mcsmurf] from comment #4)
>> Pushed to trunk: https://hg.mozilla.org/comm-central/rev/42ccebafcb89
> Does this need to be pushed to comm-aurora and comm-beta?
I guess not.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Flags: needinfo?(bugzilla)
Resolution: FIXED → ---
Comment on attachment 8503687 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1052943
User impact if declined: SeaMonkey does not build with VS 2012
Testing completed (on m-c, etc.): works fine on comm-central
Risk to taking this patch (and alternatives if risky): Low risk, build change only
String changes made by this patch: none
Attachment #8503687 - Flags: approval-comm-aurora?
Comment on attachment 8503687 [details] [diff] [review]
Patch

a=me comm-aurora.
Attachment #8503687 - Flags: approval-comm-aurora? → approval-comm-aurora+
FWIW: IIRC, and unless it has changed recently, according to Mozilla doctrine RESOLVED FIXED means fixed-on-trunk; porting to the branches is done afterwards (and, now that Bugzilla has them, followed by the "status-<product>-<version>" flags).
SeaMonkey 2.31 (beta) is not affected by this as far as I see this (VS 2012 builds fine). Why? Not sure, looks like something else in mozilla-* changed as well in SeaMonkey 2.32/Gecko 35.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.