Closed Bug 1053712 Opened 8 years ago Closed 7 years ago

[Flatfish] Youtube shows desktop content on tablet (http://m.youtube.com)

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: yifan, Assigned: karlcow)

References

()

Details

(Whiteboard: [mobile-compat-form][flatfish] [country-all] [serversniff] [sitewait])

Site: http://m.youtube.com/
Youtube shows desktop content on tablet

:: Steps To Reproduce

In mobile browser
1. Navigate to http://m.youtube.com

Or
1. open marketplace app
2. install youtube app
3. open youtube app

:: Expected Result

Mobile youtube website

:: Actual Result

Desktop youtube website

:: Additional Information

Software Version: Gaia      e15286a812a206fb4385341cde5350cd5ce9917c Gecko     51ac93f62dfaba70de71610bbc14e0b62d7e0525 BuildID   20140714014330 Version   33.0a1
Device Information: [flatfish][tablet]
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Software Version: 
Gaia      e15286a812a206fb4385341cde5350cd5ce9917c 
Gecko     51ac93f62dfaba70de71610bbc14e0b62d7e0525 
BuildID   20140714014330 
Version   33.0a1
Device Information: [flatfish][tablet]
Summary: Youtube shows desktop content on tablet → Youtube shows desktop content on tablet (http://m.youtube.com)
Whiteboard: [mobile-compat-form] → [mobile-compat-form][flatfish]
Duplicate of this bug: 1021432
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Confirmed. It's also the case for the redirection.
When faking the Galaxy Tab UA on Firefox Desktop, we receive the mobile version.
Note that Firefox Android on Tablet is receiving the mobile version.

Summary:
Galaxy Android Tab2:  www->m    m->m
Firefox Android Tab:  www->m    m->m
Firefox OS Tab:       www->www  m->www

The User-Agent string for Firefox OS on Tablet is documented at:
https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Firefox_OS

I will contact Google about it.
This should be easily solved.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
See Also: → 827636
Whiteboard: [mobile-compat-form][flatfish] → [mobile-compat-form][flatfish] [country-all] [serversniff] [contactready]
Contacted Google today about it.
Whiteboard: [mobile-compat-form][flatfish] [country-all] [serversniff] [contactready] → [mobile-compat-form][flatfish] [country-all] [serversniff] [sitewait]
Summary: Youtube shows desktop content on tablet (http://m.youtube.com) → [Flatfish] Youtube shows desktop content on tablet (http://m.youtube.com)
still the same. 
Though do we still have an active dev for Flatfish and others?
I'm not fond of sending a reminder to Google about something not high priority. There are more important issues.
(In reply to Karl Dubost :karlcow from comment #5)
> still the same. 
> Though do we still have an active dev for Flatfish and others?
> I'm not fond of sending a reminder to Google about something not high
> priority. There are more important issues.

Unfortunately, there have been some shifts. Flatfish is no longer a priority however, it may be in the future.
let's close as INVALID. and if a Firefox OS Tablet is becoming a project again. We will reopen.
Thanks.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.