Closed Bug 1054482 Opened 8 years ago Closed 8 years ago

e10s test addons time out on linux

Categories

(Add-on SDK Graveyard :: General, defect, P2)

defect

Tracking

(e10s+)

RESOLVED FIXED
mozilla37
Tracking Status
e10s + ---

People

(Reporter: zombie, Assigned: zombie)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

looks like windowPromise never resolves, either the 'load' event never fires, or it fires before the event listener is attached..
Attachment #8473864 - Flags: review?(dtownsend+bugmail)
Comment on attachment 8473864 [details] [review]
Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/1589

r+ with comments addressed
Attachment #8473864 - Flags: review?(dtownsend+bugmail) → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/6ed493601e867d610200cf77f6e2964a28567f39
bug 1054482 - use WindowTracker instead of load event

https://github.com/mozilla/addon-sdk/commit/ec3c95b2a436742d763acf4bdd2f35ef70a2936a
Merge pull request #1589 from zombie/1054482-e10s-linux

bug 1054482 - use WindowTracker instead of load event, r=@Mossop
Assignee: nobody → tomica+amo
Status: NEW → ASSIGNED
Attachment #8474873 - Flags: review?(dtownsend+bugmail)
first try didn't fix the issue.. disabling on linux for now.
Attachment #8474873 - Flags: review?(dtownsend+bugmail) → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/2587eea75e14b8905b88f3a5d5dfca68eff8c067
bug 1054482 - disable e10s test addons on linux

https://github.com/mozilla/addon-sdk/commit/afe8f6b84e8aeedc080f0ddbb979b232610b9c5e
Merge pull request #1592 from zombie/1054482-e10s-linux

bug 1054482 - disable e10s test addons on linux, r=@Mossop
Attachment #8474910 - Flags: review? → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/98544fd5eeb07f3c4d2cb2c4bed2554bf70ff170
bug 1054482 - don't try to open an e10s window on linux

https://github.com/mozilla/addon-sdk/commit/a1e8037f2b7448f41a1dd5781f5db4e2f050b72a
Merge pull request #1593 from zombie/1054482-e10s-linux

bug 1054482 - don't try to open an e10s window on linux, r=@jsantell
Something landed in here, can we close this bug or is there more to do here?
Flags: needinfo?(tomica+amo)
no, we only disabled those tests to get our tests back to a green/enabled on m-c.  

this is (probably) still an issue.

i spoke with Mossop today, and we may end up going back to .autostart for testing e10s addons, which may fix this.
Flags: needinfo?(tomica+amo)
Keywords: leave-open
Duplicate of this bug: 1053913
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/1ad12b309a8e51edafa19641ac9b476508f3ceff
Bug 1054482 when skipping e10s test add-ons, provide at least one test a=me
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/d00fa42432e97ee6122f7a8742aa219bd2dde96a
Bug 1054482 when skipping e10s test add-ons, provide at least one test (part 2: needs to start with 'test') a=me
revert to using .autostart for e10s test addons.

Dave, i understand this basically undoes your changes required for mochitestification, but at least unblocks me from waiting on that, plus e10s test addons are already skip-if at the moment.

and at least "some testing now" seems more valuable to me than "all the testing" some time in the future..
Attachment #8541952 - Flags: review?(dtownsend)
(In reply to Tomislav Jovanovic [:zombie] from comment #10) 
> i spoke with Mossop today, and we may end up going back to .autostart for
> testing e10s addons, which may fix this.

heh, apparently, we already talked about this. i vaguely remember an idea of adding a third job to jetpack mochitests that would run only e10s test addons (after we switch to mochitests), so this all works out.
Attachment #8541952 - Flags: review?(dtownsend) → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/b9d261d67ffd2e095f09a3b5bc16ef4383d48a03
bug 1054482 - revert to using remote.autostart for e10s-tabs test addon

https://github.com/mozilla/addon-sdk/commit/32a349ffb5f5729a62307ca804277320f936f15f
Merge pull request #1778 from zombie/1054482-enable-on-linux

bug 1054482 - enable e10s-tabs test addon on linux, r=@Mossop
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: leave-open
Target Milestone: --- → mozilla37
Blocks: e10s-sdk, 1033838
You need to log in before you can comment on or make changes to this bug.