TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync, port mozconfig.cache and client.mk changes from m-c to c-c

RESOLVED FIXED in Thunderbird 34.0

Status

MailNews Core
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

({regression})

Trunk
Thunderbird 34.0
regression

Thunderbird Tracking Flags

(thunderbird33 fixed, thunderbird34 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Since the landing of Bug 1042432 on m-c tbpl for TB on c-c now gets messages similar to:
TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync
TEST-INFO | check-sync-dirs.py | file(s) found in:               /builds/slave/tb-try-c-cen-lx-00000000000000/build/build
TEST-INFO | check-sync-dirs.py | differ from their originals in: /builds/slave/tb-try-c-cen-lx-00000000000000/build/mozilla/build
TEST-INFO | check-sync-dirs.py | differing file:                 ./mozconfig.cache
In general, the files in '/builds/slave/tb-try-c-cen-
lx-00000000000000/build/build' should always be exact copies of originals
in '/builds/slave/tb-try-c-cen-lx-00000000000000/build/mozilla/build'.  A
change made to one should also be made to the other.  See 'check-sync-
dirs.py' for more details.
make: *** [check-sync-dirs] Error 1
make: Target `check' not remade because of errors.
State Changed: unlock buildroot
program finished with exit code 2
elapsedTime=307.814954
TinderboxPrint: check<br/>4617/0
Unknown Error: command finished with exit code: 2
(Assignee)

Updated

3 years ago
Component: Backend → Build Config
Keywords: regression
(Assignee)

Comment 1

3 years ago
Created attachment 8474209 [details] [diff] [review]
Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]

Patch contains the port of the following changes from m-c:
Bug 1042432 - Change how UPLOAD_EXTRA_FILES is passed down from mozconfig.cache to the build system
Bug 991976 - Only fail creating .mozconfig.mk once

Try server test - https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=dcee6c02227f
Attachment #8474209 - Flags: review?(Pidgeot18)
(Assignee)

Updated

3 years ago
Summary: Port |Bug 1042432 - Change how UPLOAD_EXTRA_FILES is passed down from mozconfig.cache to the build system| and |Bug 991976 - Only fail creating .mozconfig.mk once| to comm-central → TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync
(Assignee)

Updated

3 years ago
Summary: TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync → TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync, port mozconfig.cache and client.mk changes from m-c to c-c
I understand the first bug, but why the second?
(Assignee)

Comment 3

3 years ago
(In reply to Joshua Cranmer [:jcranmer] from comment #2)
> I understand the first bug, but why the second?

It was just an easy drive by, not required to fix the issue though.
Attachment #8474209 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 4

3 years ago
Comment on attachment 8474209 [details] [diff] [review]
Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]

https://hg.mozilla.org/comm-central/rev/aee44e448ceb
to fix bustage for B builds.
Attachment #8474209 - Attachment description: Port changes to mozconfig.cache and client.mk → Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0

Updated

3 years ago
Duplicate of this bug: 1056436

Comment 6

3 years ago
Comment on attachment 8474209 [details] [diff] [review]
Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #8474209 - Flags: approval-comm-aurora?

Comment 7

3 years ago
(In reply to Edmund Wong (:ewong) from comment #6)
> Comment on attachment 8474209 [details] [diff] [review]
> Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]
> 
> [Approval Request Comment]
> Regression caused by (bug #): 
> User impact if declined:   check failing on aurora.
> Testing completed (on c-c, etc.): 
> Risk to taking this patch (and alternatives if risky):
Comment on attachment 8474209 [details] [diff] [review]
Port changes to mozconfig.cache and client.mk [Checked in: Comment 4]

I already did this and forgot to update the bug:

https://hg.mozilla.org/releases/comm-aurora/rev/48c029bc97bf
Attachment #8474209 - Flags: approval-comm-aurora? → approval-comm-aurora+
status-thunderbird33: --- → fixed
status-thunderbird34: --- → fixed
You need to log in before you can comment on or make changes to this bug.