Moving mail between IMAP folders occurs on event handling thread -> GUI block

RESOLVED DUPLICATE of bug 778907

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 778907
4 years ago
4 years ago

People

(Reporter: krichter722, Unassigned)

Tracking

({perf})

31 Branch
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

Moved > 1000 mails from one IMAP folder to an empty other.


Actual results:

GUI blocks for > 1 minute


Expected results:

task should be moved to a separate thread being monitorable and avoiding the GUI block. It would be nice to integrate it with my enhancement proposal https://bugzilla.mozilla.org/show_bug.cgi?id=1051901 (I add a dependency which is not mandatory, but makes a lot of sense in my opinion).
(Reporter)

Updated

4 years ago
Depends on: 1051901
OS: Linux → All
Hardware: x86_64 → All

Comment 1

4 years ago
As you hinted, these aren't dependent.

There are other possibilities, but your issue is probably bug 846123 or bug 778907
No longer depends on: 1051901
Keywords: perf
OS: All → Linux
Whiteboard: [dupeme]
(Reporter)

Comment 2

4 years ago
The development in https://bugzilla.mozilla.org/show_bug.cgi?id=778907 looks promising, time to assign a version :)
(Reporter)

Comment 3

4 years ago
You can mark this as duplicate of bug 778907.
(Reporter)

Comment 4

4 years ago
Ah, it's down there... We desperately need an editing function (Bug 1054968)!!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778907
You need to log in before you can comment on or make changes to this bug.