The view more link in the share panel doesn't work in e10s

RESOLVED DUPLICATE of bug 1047603

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1047603
4 years ago
4 years ago

People

(Reporter: Ehsan, Assigned: mconley)

Tracking

(Depends on: 1 bug)

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify ?

Firefox Tracking Flags

(e10sm6+)

Details

(Reporter)

Description

4 years ago
It just opens a blank tab.
I'm assuming this is the share panel.
Summary: The view more link on the social API toolbar button doesn't work in e10s → The view more link in the share panel doesn't work in e10s
(Reporter)

Comment 2

4 years ago
Yes.

Updated

4 years ago
Assignee: nobody → dtownsend+bugmail
Blocks: 997462
tracking-e10s: ? → +
Priority: -- → P3
bug 1014332 was backed out, will have to reland
Depends on: 1014332
Flags: firefox-backlog+

Updated

4 years ago
Status: NEW → ASSIGNED
Flags: qe-verify?
Note: this should end up being fixed by changes in bug 1014332
Move old M2 P3 bugs to M4 (because tracking-e10s=m5+ flag doesn't exist yet).
tracking-e10s: + → m4+
Assignee: dtownsend+bugmail → nobody
Status: ASSIGNED → NEW
my comment #4 is bunk.

I'm believe that this is a dup of bug 1047603, but am not entirely clear yet.  For certain, social iframes are not remote (bug 1074553) and will hit bug 1047603 in several cases.
Depends on: 1074553, 1047603
No longer depends on: 1014332
Assignee: nobody → mconley
The "View More" link is now in chrome rather than remote content, so it should work fine (once bug 915547 and bug 1053973 are fixed).
(Assignee)

Comment 8

4 years ago
The Share button doesn't open in e10s windows, so I'm not sure how to reproduce this bug.

Shane - am I to understand that you believe this bug will be fixed once bug 915547 and bug 1053973 are fixed?
Flags: needinfo?(mixedpuppy)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #8)
> The Share button doesn't open in e10s windows, so I'm not sure how to
> reproduce this bug.
> 
> Shane - am I to understand that you believe this bug will be fixed once bug
> 915547 and bug 1053973 are fixed?

no, that we'll be able to verify the bug no longer occurs once those are fixed.  

The view more link used to be in content, but is now in xul, so it should not run into the problem (bug 1047603) any longer.
Flags: needinfo?(mixedpuppy)
(Assignee)

Comment 10

4 years ago
I'm afraid this bug is still reproducible with bug 915547 and bug 1053973 fixed.

I'll take a look at this in a few days.
heh.  well, clicking view crashes my latest nightly build.  However, event switching to a "nightly start" tab that was left around crashes nightly.
(Assignee)

Updated

4 years ago
tracking-e10s: m4+ → m6+
Flags: needinfo?(mconley)
(Assignee)

Comment 12

4 years ago
I poked at this - this is bug 1047603.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1047603
You need to log in before you can comment on or make changes to this bug.