Closed Bug 1055709 Opened 8 years ago Closed 8 years ago

e10s: Automatic redirects to HTTPS don't work

Categories

(Core :: Networking, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 946739

People

(Reporter: sstangl, Unassigned)

References

()

Details

Without e10s, visiting "http://www.cmubash.org" automatically redirects to "https://www.cmubash.org".

With e10s, visiting "http://www.cmubash.org" displays a document with the text content "Found: The document has moved here (https://cmubash.org)".
This is an HTTP 302.  Looks like it's not getting processed for some reason and showing the response body instead?
Component: General → Networking
Blocks: old-e10s-m2
Priority: -- → P1
Sean: do you have any networking-releated add-ons installed, such as HTTPS Everywhere or RequestPolicy? I can't reproduce this bug with a clean profile. There are known issues (bug 946739) with HTTPS Everywhere breaking redirects.
Flags: needinfo?(sstangl)
See Also: → 946739
Disabling HTTPS Everywhere allows the redirects to work, so it's probably a dup of Bug 945739.
Flags: needinfo?(sstangl)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946739
You need to log in before you can comment on or make changes to this bug.