https-everywhere and requestpolicy (0.5.28 and 1.0beta) breaks browser.tabs.remote

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
6 months ago

People

(Reporter: shawnlandden, Assigned: cpeterson)

Tracking

({addon-compat})

Trunk
x86_64
Linux
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm4+)

Details

(Whiteboard: [testday-20131206])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131205030207

Steps to reproduce:

turn on  browser.tabs.remote restart FF

debian sid with nightly on amd64



Actual results:

no content in tabs, or xml error


Expected results:

multi-process ff

Comment 1

5 years ago
Same build, confirmed.

Web pages don't show up, URL disappears.

about:home says there is  XML Parsing Error: undefined entity  in  <title>&abouthome.pageTitle;</title>

about:newtab and about:config work.
Blocks: 516752
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Whiteboard: [testday-20131206]

Updated

5 years ago
status-firefox28: --- → affected
tracking-firefox28: --- → ?
Component: Untriaged → IPC
Product: Firefox → Core
Target Milestone: --- → mozilla28

Comment 2

5 years ago
Why is this nommed for tracking? It's not a config we're shipping at all.
Flags: needinfo?(twalker)
ok, clearing.
tracking-firefox28: ? → ---
Flags: needinfo?(twalker)
Is this Australis specific?

Comment 5

5 years ago
WFM now with the same build:
2013-12-05-03-02-07-mozilla-central-firefox-28.0a1.en-US.linux-x86_64
2013-12-05-03-02-07-mozilla-central-firefox-28.0a1.ru.linux-x86_64

But broke with the profile I used then.
Worked in safe mode.
Broke with all extensions disabled and RequestPolicy 1.0b enabled.
Worked with RequestPolicy 1.0b also disabled.
Broke with all non-RequestPolicy extensions enabled. ???

Broke when I installed RequestPolicy 1.0x on a new profile and then enabled .remote (couldn't install with .remote enabled).
Still broken with the same profile in 2013-12-08-03-02-04-mozilla-central-firefox-28.0a1.en-US.linux-x86_64.
(Reporter)

Comment 6

5 years ago
I can confirm that last comment. If I start nightly in a new profile then browser.tabs.remote works, even with Australis. (commenting from it right now) 

Adblock-plus and https-everywhere also work with browser.tabs.remote.
(Reporter)

Comment 7

5 years ago
Scratch part of that last comment. The offending add-on is https-everywhere; while adblock-plus, cslite, refcontrol, greasemonkey, and stylish work with browser.tabs.remote. Now I can use my original profile.
(Reporter)

Updated

5 years ago
Summary: browser.tabs.remote broken → https-everywhere breaks browser.tabs.remote

Comment 8

5 years ago
Confirmed: HTTPS Everywhere and RequestPolicy 0.5.28 each do it, too.
Summary: https-everywhere breaks browser.tabs.remote → Each of https-everywhere and requestpolicy (0.5.28 and 1.0beta) breaks browser.tabs.remote
(Reporter)

Updated

5 years ago
Summary: Each of https-everywhere and requestpolicy (0.5.28 and 1.0beta) breaks browser.tabs.remote → https-everywhere and requestpolicy (0.5.28 and 1.0beta) breaks browser.tabs.remote
(Reporter)

Comment 9

5 years ago
While "both" could be used here to make a complete sentence, and you correctly used "breaks" with each, each is superfluous and awkward without a generic pronoun, like "Each add-on that W, such as X and Y, breaks X."
(Reporter)

Updated

5 years ago
Blocks: 905436
No longer blocks: 516752
(Assignee)

Comment 10

5 years ago
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
Blocks: 997462
(Assignee)

Updated

4 years ago
Blocks: 1014986
(Assignee)

Updated

4 years ago
No longer blocks: 905436

Updated

4 years ago
Component: IPC → DOM: Content Processes
Target Milestone: mozilla28 → ---
(Assignee)

Updated

4 years ago
See Also: → bug 1055709
(Assignee)

Updated

4 years ago
See Also: → bug 1055711
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1055711
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1055709
Duplicate of this bug: 1066249

Updated

4 years ago
Duplicate of this bug: 1066249
(Assignee)

Comment 15

4 years ago
This bug is receiving a lot of dupes. We might want to address this bug sooner than planned.

btw, HTTPS Everywhere devs have already fixed most of their e10s bugs upstream.
tracking-e10s: + → m4+
Blocks: 905436
No longer blocks: 997462
status-firefox28: affected → ---
Keywords: addon-compat
Version: 28 Branch → Trunk
Assignee: nobody → cpeterson
(Assignee)

Comment 16

4 years ago
I can't reproduce the blank pages described in comment 0, so I'm closing this bug WFM.

I can still reproduce "HTTPS Everywhere breaks HTTP redirects" bug 997808 and a RequestPolicy UI bug, but those are unrelated to this bug report.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.