perma-red on Gaia-Try for apps/keyboard/test/marionette/uninstallation_test.js

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Input Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rudyl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

example failure here,
https://tbpl.mozilla.org/php/getParsedLog.php?id=46329195&tree=Gaia-Try

Seems caused by Gecko interface change, I'll disable the tests first.
Created attachment 8475779 [details] [review]
Disable the test
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/0be5eba0cd837e6a0c89e9071cdd431e78384b1d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Depends on: 1056011
See Also: → bug 1056156
Yeah, https://mxr.mozilla.org/gaia/source/apps/system/test/marionette/lib/app_install.js#103 is broken. You need to pass a real DOMApplication object, not some fake js object.
Reverted the disabling for a proper fix: https://github.com/mozilla-b2g/gaia/commit/3584b2723412ed3299c6761f465885d80651c87e

Working on the fix now in bug 1056156.
You need to log in before you can comment on or make changes to this bug.