Closed Bug 1056156 Opened 5 years ago Closed 5 years ago

Perma failing test, TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/verticalhome/test/marionette/app_unrecoverable_error_test.js | Vertical Home - App unrecoverable error remove an app that was in an unrecoverable state

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S3 (29aug)

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Started failing this morning.

https://tbpl.mozilla.org/php/getParsedLog.php?id=46359538&tree=B2g-Inbound

1) Vertical Home - App unrecoverable error remove an app that was in an unrecoverable state:
07:40:26     INFO -    Error: timeout exceeded!
07:40:26     INFO -        at Object.Client.waitForSync (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:682:16)
07:40:26     INFO -        at Object.Client.waitFor (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:650:60)
07:40:26     INFO -        at Object.MarionetteHelper.waitForElementToDisappear (/builds/slave/test/gaia/node_modules/marionette-helper/index.js:181:17)
07:40:26     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/verticalhome/test/marionette/app_unrecoverable_error_test.js:72:19)
07:40:26     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:223:21)
07:40:26     INFO -        at Test.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
07:40:26     INFO -        at Runner.runTest (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:373:10)
07:40:26     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:451:12
07:40:26     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:298:14)
07:40:26     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:308:7
07:40:26     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:246:23)
07:40:26     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:270:7
07:40:26     INFO -        at done (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:185:5)
07:40:26     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:228:7)
07:40:26     INFO -        at Hook.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
07:40:26     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:258:10)
07:40:26     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:270:7
07:40:26     INFO -        at done (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:185:5)
07:40:26     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:199:9
07:40:26     INFO -        at /builds/slave/test/gaia/apps/verticalhome/test/marionette/app_unrecoverable_error_test.js:22:7
07:40:26     INFO -        at ChildProcess.<anonymous> (/builds/slave/test/gaia/apps/verticalhome/test/marionette/server/parent.js:183:5)
07:40:26     INFO -        at ChildProcess.EventEmitter.emit (events.js:98:17)
07:40:26     INFO -        at handleMessage (child_process.js:318:10)
07:40:26     INFO -        at Pipe.channel.onread (child_process.js:345:11)
Appears to have started failing once bug 899322 landed.

This also started failing at the same time, but may be fixed now?

2) Show Keyboard App after uninstallation "before each" hook:
11:50:12     INFO -    JavaScriptError: (17) TypeError: Argument 1 of DOMApplicationsManager.uninstall does not implement interface DOMApplication.
11:50:12     INFO -    Remote Stack:
11:50:12     INFO -    execute_script @undefined, line undefined
11:50:12     INFO -    inline javascript, line 63
11:50:12     INFO -    src: "      window.wrappedJSObject.navigator.mozApps.mgmt.uninstall({"
Blocks: 899322
See Also: → 1055972
See Also: → 1056011
It appears we have bug 1056011 to track the keyboard change. I'm taking off now but will dig into this further in a bit.
Blocks: 960072
Blocks: 1035939
No longer blocks: 960072
Appears to be due to our test helper here: https://mxr.mozilla.org/gaia/source/apps/system/test/marionette/lib/app_install.js#99

Let's fix this, and reopen the tree.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S3 (29aug)
Duplicate of this bug: 1056011
Possible related errors to the homescreen failure:

[marionette error] resource://gre/modules/Webapps.jsm:88 A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Date: Wed Aug 20 2014 10:13:45 GMT-0700 (PDT)
Full Message: TypeError: root is null
Depends on: 1056226
Comment on attachment 8476034 [details] [review]
Pull request - Update AppInstall library to use real mozapp object

Fabrice - could you give this a review when you have a chance? Thanks!
Attachment #8476034 - Flags: review?(fabrice)
Comment on attachment 8476034 [details] [review]
Pull request - Update AppInstall library to use real mozapp object

uber-minor nit on github.
Attachment #8476034 - Flags: review?(fabrice) → review+
Updated commit and landed: https://github.com/mozilla-b2g/gaia/commit/c141b0b879f95a7febbd49b8e15c13354bce8adf
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.