Closed Bug 105672 Opened 23 years ago Closed 16 years ago

Need a 48x48 application icon for Windows

Categories

(SeaMonkey :: Themes, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

Details

Attachments

(11 files, 1 obsolete file)

It would make sense, with the impending release of Windows XP, to provide an 
icon in the 48x48 size so that Windows can display its large icons view 
without having to stretch the existing 32x32 icon.  The scaling doesn't look 
all that nice.
Summary: Need a 48x48 icon → Need a 48x48 application icon
No dupes found. Marking NEW.

-> Themes, but punt as needed
Assignee: asa → hewitt
Status: UNCONFIRMED → NEW
Component: Browser-General → Themes
Ever confirmed: true
QA Contact: doronr → pmac
Summary: Need a 48x48 application icon → Need a 48x48 application icon for Windows XP
Related to bug 43647?

Adding block: bug 73712.
Over to Marlon, ye olde Icon Master
Assignee: hewitt → marlon
arrg...aye am shoppe keeper here! what needs ya new?  needn't pester me till the
crows come home, lad.  lest thee splidgets in a bind?
I've attached a new mozilla icon, based on the mozilla.org favicon and the big
SVG picture of Mozilla. It include images at 16x16, 32x32, 48x48 and 72x72
resolution, with both 8- and 24-bit colour, optimized for a one bit
transparency. I know XP supports 8-bit alpha, but this icon looks good on all
systems, including XP at 48 pixel resolution.

This would be nice as the mozilla.org favicon, too, since it includes multiple
resolutions.
That attachment should be called mozilla.ico if you want to download it - I'm
not sure what to set the mime-type to in order for it to display without saving
it as a .ico file.
Blocks: icons
Attachment #58751 - Attachment mime type: application/octet-stream → image/x-icon
Attached image big seamonkey icon
This is basically the current blue seamonkey icon, scaled and cleaned up for
48x48, 64x64 and 72x72px (16x16 and 32x32 are unchanged). This will allow this
bug to be resolved fixed, without needing to get permission to use the red
lizard (which is bug 28028). When (if?) it is decided to use the red lizard,
the other icon (attachment 58751 [details]) can be used.
Chris, would you create a 128x128 version as well, for Mac OS X? We should get
all platforms using the same icon.
Which one, the lizard or the seamonkey? Also, what format do the *nix icons use?
id like to see the red lizard used Cross Platform (some Linux dist's use it
Mandrake i think) adding a vote to this bug.  

In case you were not already aware the Seamonkey icon is almost invisible
against the default cyan/turquoise desktop color for win9x.  
Typically *nix uses PNG icons, gnome likes scalable icons up to as large as 
anyone cares to make.

Basically it looks like MacOS X needs up to 128x128, Windows wants 48x48, and 
Linux up to 48x48 is probably adequate.  I like the red lizard icon over the 
seamonkey icon, by the way.
64x64, 48x48, 32x32, 24x24, 16x16 pixels at 32-, 24-, 8-, 4- & 1-bit icons.
the 32-bit fit very well with WindowsXP's alpha blending
Francesco, be sure to create a 128x128 and SVG version as well.
I've no ptoblems on making the 128x128 one. but... what do you mean for an SVG
version?

Francesco
If you're unfamiliar with SVG, just attach a version in some vector format (not
bitmap).
uhmmm... ok, I'll try to vectorialize 'em in FreeHand (thanks god I'got a Wacom
tablet!). I think I can save in WMF or EMF.

however, where can I find a program (for Linux too, if necessary) to export in SVG?

thanx

Francesco
that's it! I made a vectorial (emf) version of the seamonkey logo as requested.
I think many people could do better but... remember it's just a draft! you can
see it in ACDsee or MS Word/Excel/etc, StarOffice and so on (as an usual
ClipArt). 

I'll work on the 128x128 .ico and .png versions now ;-)
please make me know if you like it. again, don't you know a program (for
Windows or Linux) able to export it in SVG format? you can contact me in
private e-mail too.

bye all
Francesco <fdefrancesco@iol.it>
brand new 128x128 icon, as requested.
you can use the .html file contained in the archive to see the png.

enjoy!

Francesco <fdefrancesco@iol.it>
Very nice job on your Mozilla icon, Francesco. It's my favorite thus far (and
many, many have been made).

Many SVG-implementing applications are listed at
[http://www.w3.org/Graphics/SVG/SVG-Implementations.htm8].

You also might be interested in my overview document of Mozilla's icon suite and
other appearance details at
[http://greg.tcp.com/mozilla/ui/Outside/introduction.html]. I'm rather of the
mind that Mozilla's whole icon suite and splash screen should be designed as a
whole.
Yep...very nice icon indeed. Keep up the great work!
*** Bug 117271 has been marked as a duplicate of this bug. ***
Whatever gets decided, please note (similar to comment # 10) that the current
seamonkey icon vanishes on a standard Windows NT 50% gray (I think it's called
that) background.  If possible, can the icon be made with its own defined
background so this won't happen regardless of the desktop background in use? I
think the current icon's background is somehow transparent, is why this happens now.
in reply to comment #20 (and #10): icons in my icon set feature a white border
and a bright-to-dark fading (and an alpha shadow, too), therefore I think they
may fit well in any background.
I can however build red lizard icons, if you like.

bye all

Francesco
sorry... I meant comment #22 (and comment #10)
yet another reply to comment #22: I tried my icon on Windows 98 & 2000 and I
actually realized there is some problem on seeing it on the microsoftish default
greenblue background: but I think just brighting the border should make a
noticeable difference. so I'll work on this now.

p.s.: I swear that in a few days I'll post the final SVG version!

bye all
Francesco
Attached image SVG version
hello folks! here is my first SVG version of the Mozilla icon as requested.
please notice the MIME type is image/svg+xml according to the W3C standard
(http://www.w3.org/TR/SVG/intro.html#MIMEType). you can save it as usual by
renaming "attachment.cgi" as "something.svg" in the 'Save As" dialog.
I'll wait for your comments. thank you!

Francesco De Francesco
You may want to take a look at my Mac OS X Mozilla icon set. I think they 
might look good under Windows XP too. I'd be happy to work with a 
Windows XP user with graphics experience who can help me to convert 
the icons into the right format.

You can find them here: 
http://www.theparallax.net/sd/proposals/Mozilla-Icons.jpg
in reply to comment #27:
hey! they're simply great!!

Francesco
I can make WinXP icons.  Provide links to them in PNG or PSD format and I'll
convert them.
I can convert them too. I'm already working on the JPEG but having a PSD or PNG
version would really make it simple

thanks
Francesco
Wow, those are very nice icons.  If you convert to PNG, make sure to do so 
with an alpha layer.  WindowsXP's icon format supports an alpha layer which 
would work well with those icons.  Don't forget, however, to make a version of 
each icon that has no alpha layer, so that users of other versions of Windows 
can still view the icons correctly.
Yeah, I found a shot of a different (equally really nice) mac os x mozilla icon
in jpg format that I converted to a WinXP icon to the best of my ability.  it
came out... not too bad.  I wish I could remember the author's name.  The
resolutions go from 16x16 up to 128x128.
I made an SVG version of the icons described by Simon Dorner in comment #27;
they support full alpha blending and so on. I'll start working on the .ico
format now!

bye all
Francesco
sorry... PNG, not SVG :-)

Francesco
I'm still working on a lot of the details. I would wait with the conversion 
efforts until they're finished. The image I posted was just to describe the 
basic design direction I've taken. I've posted a more detailed description 
of what I've done and what I will do in this comment: 
http://bugzilla.mozilla.org/show_bug.cgi?id=58228#c62 . There's still a lot 
of work to do for me until they're ready. The final icon set will be a lot more 
polished, "lickable" and complete. I will publish it in about a week and a 
half and I will send anybody who's interested the layered .psd source files. 
Just drop me an email.
The icon set is now updated, more polished and complete, contains 
descriptions and licensing information: 
http://www.theparallax.org/sd/proposals/mozilla/icons.html - I've saved 
them as png's with an alpha channel so you can use them without 
manually reconstructing the transparency information. (That must have 
been a lot of work, Francesco...)
Theres still a long way to go until they're ready.
in reply to comment #36: your icon set is great! i'm not at home right now, but 
I'll start working in the next days. I think I'll be able to post a Windows 
version on thursday/friday.

btw... they're too nice to be used under Windows!

see ya later
Francesco
Most of the my time here, I'm just watching bugs, occasionally making
suggestions as I have done by posting this bug, so I'm not to knowledgeable on
how bugs actually get dealt with in terms of making it into the build.

Is anyone in the development processing watching this bug, or is it just up to
the creative people here to come up with something and then just hope they like
what's been done?
*** Bug 152396 has been marked as a duplicate of this bug. ***
Out of all the bugs in bugzilla this has got to be the easyest to fix.
Give me the icons source file and I'll make the icon
Note this doesn't k=just effect Windows XP 
I did a seamonkey icon without knowing existance of this bug until yesterday.

Icons formats:
16x16x4b, 16x16x8b, 32x32x4b, 32x32x8b, 48x48x4b, 48x48x8b, 48x48x32b, 72x72x8b,
72x72x32b, 128x128x32b as a separate PNG

Simon Dorner icons are very cool.
Attached file another seamonkey icon
I'm going to dupe this to bug 73712, as it's a windows icon issue.  Please make
your comments there.  If you have mac icons/issues, those should be posted in
bug 157829 and linux ones to bug 157830.

thanks.

*** This bug has been marked as a duplicate of 73712 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Can someone with the proper authority reopen this?
yep
Status: RESOLVED → REOPENED
OS: Windows 2000 → Windows XP
Resolution: DUPLICATE → ---
No offence but This has got to be the easy easyiest bug to fix still not fixed
the atachments are there and they look OK so why is this not fixed yet?
Well, since the blue seamonkey icon is no longer the default, I'm not sure that
they'd want to put it back.  Anyone have a good high res red dino head icon? 
The first attachment would work, except it doesn't look very good in 48x48.
Attached image Linux 48x48 PNG icon converted to Win32 (obsolete) —
I just converted the Linux default icon over to Windows.  16x16, 32x32, 48x48,
and 64x64 resolutions are included.  16, 32, and 48 are each in 16 color, true
color, and alpha blended, 64 is only in alpha blended (I don't think other
color depths are needed as only WinXP supports icons that big).  If this icon
is checked in, then at least two major platforms will be using the same default
icon.
Updated version: Contains 128x128x32 format, and I tried to clean up the
jaggies on 32x32
Attachment #92278 - Attachment is obsolete: true
Keep in mind there are already icons checked in (for Windows) which are in the 
nightly builds.  It would be best to supply the 48x48 pixel version of that 
icon, and check that in, rather than backing out some of the changes from bug 
73712 to use a different icon entirely.
Blocks: 164421
Windows 98+ can have 48x48 Icons
Summary: Need a 48x48 application icon for Windows XP → Need a 48x48 application icon for Windows
I tried to make it look as much like the current icon as I could, but I'm not
all that much of an artist so it isn't perfect.  If anyone thinks they can
improve it, feel free.
FYI, the grayrest icon set has been updated to include 48x48 icons.

http://www.deskmod.com/core.mod?show=showskin&skin_id=9673

Also one is 24-bit colour, somewhat excessive :-(
A long time ago I did the icon for the Mac OS X version of Mozilla (the
translucent blue 'M' in current use). I've offered to create a full icon suite
based on this for Mac and Windows, but get no reply. I'm trying again in the
hope that someone spots this. Sigh...
Paul, see bug 88393.
I think This is a bug that DESPERATELY needs fixing espeasialy for Mac OS Docks
and MobyDock ETC
We may fix this for SeaMonkey in bug 321927, let's see...
Depends on: 321927
is this still relevent today? Vista now has massive icons and the app suite as refered to in this bug no longer exists in the same manner.

Perhaps reassign as seamonkey?
Attachment #90763 - Attachment mime type: application/octet-stream → application/zip
On Leopard, 512x512.

On Vista, 256x256.
Product: Core → SeaMonkey
Assignee: marlon.bishop → nobody
Status: REOPENED → NEW
QA Contact: pmac → themes
As filed, this bug is no longer relevant, as both SM and Fx have 48x48 Windows icons.  If there is a need for even larger ones, a new bug should be filed for it, esp. since this bug dates to before the suite-browser split.
Status: NEW → RESOLVED
Closed: 22 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: