Closed Bug 1057251 Opened 7 years ago Closed 6 years ago

Object.keys(window) raises NS_ERROR_FACTORY_NOT_REGISTERED for a chrome window

Categories

(Thunderbird :: General, defect)

31 Branch
x86_64
All
defect
Not set
normal

Tracking

(thunderbird34 affected, thunderbird35 affected, thunderbird36 affected, thunderbird_esr24 unaffected, thunderbird_esr31 affected)

RESOLVED DUPLICATE of bug 1081190
Tracking Status
thunderbird34 --- affected
thunderbird35 --- affected
thunderbird36 --- affected
thunderbird_esr24 --- unaffected
thunderbird_esr31 --- affected

People

(Reporter: yuki, Unassigned)

References

Details

(Keywords: regression)

When I try to list all properties of a chrome window (messenger, message composer and so on), NS_ERROR_FACTORY_NOT_REGISTERED is raised and I cannot get the result. All following cases report the error.

 * Object.keys(window)
 * Object.getOwnPropertyNames(window)
 * for (var prop in window) {}

The error doesn't appear on Firefox 31. I can confirm this only on Thunderbird 31.

Steps to reproduce:
1. Ctrl-Shift-J to open an error console.
2. Type "Object.keys(window)" into the "code:" input field.
3. Click the "Evaluate" button.

Actual result:
The console says (*Because I've confirmed this with ja locale, the message can different from en-US):
    Error: NS_ERROR_FACTORY_NOT_REGISTERED: 
    Source file: javascript:%20Object.keys(window)
    Line: 1

Expected result:
The list of properties is shown.
I also saw exception by following statement in Tb 31.0 and Tb 31.1.1.
>  * for (var prop in window) {}

bug 1035751, bug 1043303, bug 1047599 are for same NS_ERROR_FACTORY_NOT_REGISTERED, but all is report for Android.
Is bug 1081190 the same as this bug?
Search result for "open bug, comment contains FACTORY_NOT_REGISTERED && updated with 3 months".
> https://bugzilla.mozilla.org/buglist.cgi?list_id=11345954&resolution=---&chfieldto=Now&query_format=advanced&chfieldfrom=3m&longdesc=FACTORY_NOT_REGISTERED&longdesc_type=allwordssubstr
Bug 1051002 was for NS_ERROR_FACTORY_NOT_REGISTERED by for(let .. in window.navigator) in SeaMonkey.
FYI.
Problem occurs in trunk nightly too.
> Thunderbird 35.0a1 Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Thunderbird/35.0a1
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/thunderbird-35.0a1.en-US.win32.zip
Whiteboard: [reression window wanted]
FYI.
First Thunderbird 31.0a1 build in trunk nightly. (No zip build for Win... Installer build only for Win... sigh...)
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/03/2014-03-19-03-02-02-comm-central/
Whiteboard: [reression window wanted]
Keywords: regression
In case it's worth mentioning how this bug is affecting someone...

My extension[1] has unit tests that run in a tab (a browser tab in Firefox, a contentTab in Thunderbird). The tests use Mocha+Chai, which use have code that iterate over object keys. 

So: I'm unable to run my extension unit tests on Thunderbird because of this bug.

1: https://addons.mozilla.org/en-US/thunderbird/addon/markdown-here/
(In reply to pritchard.adam from comment #6)
> So: I'm unable to run my extension unit tests on Thunderbird because of this bug.

Me too.
My extension for Thunderbird tries to manipulate Chrome Window object using "for(var prop in window)". Due to exception of this bug, any my function replies on "for(var prop in window)" can't work any more...
Google search result for "mdn FACTORY_NOT_REGISTERED".
> https://www.google.com/?gws_rd=ssl#q=mdn+FACTORY_NOT_REGISTERED+
MDN document about "platform/xpcom".
> https://developer.mozilla.org/en-US/Add-ons/SDK/Low-Level_APIs/platform_xpcom

After swtch from thunderbird-30.0a1 to thunderbird-31.0a1(and after switch from seamonkey-2.30a1 to seamonkey-2.31a1 too) in trunk nightly build, many build failures are seen in trunk nigtly builds.
What was broken around thunderbird-31.0a1/eamonkey-2.31a1?
(In reply to WADA from comment #9)
> ...
> After swtch from thunderbird-30.0a1 to thunderbird-31.0a1(and after switch
> from seamonkey-2.30a1 to seamonkey-2.31a1 too) in trunk nightly build, many
> build failures are seen in trunk nigtly builds.
> What was broken around thunderbird-31.0a1/eamonkey-2.31a1?

question for reporter?
Flags: needinfo?(yuki)
What is the question? What should I report additionally?
Do you mean that I should make it clear that the regression window?
(In reply to Wayne Mery (:wsmwk) from comment #10)
> question for reporter?

No. That's question to developers who are responsible about quality of software called Thunderbird/SeaMonkey..
jcranmer, standard8 see question, comment 9
Flags: needinfo?(yuki)
Flags: needinfo?(standard8)
Flags: needinfo?(Pidgeot18)
I would recommend getting the regression range down as small as possible.

Also does for (var prop in window) {} work for some props to begin with, or just fail completely? i.e. can you determine which prop is at fault?

Maybe using the browser debugger in Thunderbird might help narrow this down.
Flags: needinfo?(standard8)
Regression window
Good:
https://hg.mozilla.org/mozilla-central/rev/e4843f4f08a7
https://hg.mozilla.org/comm-central/rev/b0b68d22439b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Thunderbird/32.0a1 ID:20140515030204
Bad:
https://hg.mozilla.org/mozilla-central/rev/58c5a3427997
https://hg.mozilla.org/comm-central/rev/db700c5b26b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Thunderbird/32.0a1 ID:20140516030204

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e4843f4f08a7&tochange=58c5a3427997
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=b0b68d22439b&tochange=db700c5b26b6


In local build:
Last Good: a2f0668d2d9c
First Bad: 26bac45c96b9

Triggered by:
	26bac45c96b9	Blair McBride — Bug 926712 - Use WebIDL to expose InstallTrigger, r=Mossop,bholley
This sounds like Thunderbird isn't including the right blobs for the installtrigger component - IIRC I saw this error while working on bug 926712 on b2g and android when I hadn't updated the build package manifests.
Given the regression range, I'm almost sure this is a dup of bug 1081190.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081190
Flags: needinfo?(Pidgeot18)
You need to log in before you can comment on or make changes to this bug.