[10.10] OS X fullscreen much less responsive than windowed

VERIFIED FIXED in mozilla34

Status

()

VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: robin, Assigned: mstange)

Tracking

(Blocks: 1 bug, {regression})

34 Branch
mozilla34
x86
Mac OS X
regression
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8477868 [details]
unresponsive_fullscreen.mp4

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140823030201

Steps to reproduce:

Put Firefox into fullscreen mode (clicked the green button in the titlebar on Yosemite public preview 2).


Actual results:

Awful responsiveness. Page redraws when scrolling are in low single-digit frames per second. Focusing the awesomebar takes 1/3rd of a second. This slowdown is pervasive through the application.


Expected results:

Same responsiveness as in windowed mode. This isn’t a resolution issue as it’s a night-and-day difference between windowed with as big a window as possible and fullscreen.

I’m using a 2012 Macbook Air (11"), OS X Yosemite public preview 2, latest Firefox nightly. Please see the attached screencast for a demo.
(Reporter)

Comment 1

4 years ago
Forgot to mention: I typically run in fullscreen on this machine, but only use it a few times a week. I don’t remember it being particularly bad the last time I used it so it’s presumably either a bug that’s been introduced in the last few days into the Gecko codebase, or (more likely imo) a problem with Yosemite public preview 2 that I installed this morning. Also, I’m getting a lot of frankly suspiscious errors in the console:

23/08/2014 17:01:54.464 firefox[1546]: CGContextTranslateCTM: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.
23/08/2014 17:01:54.514 firefox[1546]: CGContextScaleCTM: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.
23/08/2014 17:01:54.562 firefox[1546]: CGContextSetInterpolationQuality: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.

Comment 2

4 years ago
I was waiting to see if this would get posted because I've been experiencing it too.  I tried downloading a copy of the current firefox release and it doesn't happen - it's just a nightly thing.  I think I first noticed it within the last week or two so it's a fairly recent change that caused it.  fyi I'm also running a dev preview of Yosemite so I don't know if it's an issue only with this os or not...
(Reporter)

Comment 3

4 years ago
Tested on my work iMac (10.9.4, 27" mid-2010) and no problems there, so presumably it’s a Yosemite issue.
Summary: OS X fullscreen much less responsive than windowed → [10.10] OS X fullscreen much less responsive than windowed

Comment 4

4 years ago
(In reply to Jordan from comment #2)
> I was waiting to see if this would get posted because I've been experiencing
> it too.  I tried downloading a copy of the current firefox release and it
> doesn't happen - it's just a nightly thing.  I think I first noticed it
> within the last week or two so it's a fairly recent change that caused it. 
> fyi I'm also running a dev preview of Yosemite so I don't know if it's an
> issue only with this os or not...

Can you or Robin run mozregression to help narrow this down?

http://mozilla.github.io/mozregression/
Blocks: 1040250
Component: Untriaged → Untriaged
Flags: needinfo?(robin)
Flags: needinfo?(jordanleemiller)
Product: Firefox → Core
(Reporter)

Comment 5

4 years ago
I don’t have my Macbook with me, but I’ll give that a go tonight. Thanks for the link.
Flags: needinfo?(robin)
People who see this bug:

Please try to find one or testcases where it is grossly obvious.  This is very important, especially in trying to find a regression range.  For each testcase give very detailed STR.
(Reporter)

Comment 7

4 years ago
Is it not obvious from the video I attached? It’s absolutely painful to use in fullscreen on my machine, and the STR is clicking the fullscreen button.

Anyway, I’ll try to get a regression date for you tonight.
Videos are a *terrible* way to show performance problems -- they always add their own artifacts.  Detailed STR (with comments) are *much* better.

Furthermore, when I tried to repro the bug using the implied STR from your video, I didn't see it at all.

I tried scrolling this page up and down, first in a regular window and then "zoomed" to fullscreen.  (I used the two-finger scroll up/down gesture on my MacBook Pro's trackpad.)  I couldn't see any difference at all in performance.

I tested in FF 31 and FF 32b9.  I tested on Yosemite DP6 (the latest DP, build 14A329f).

I *did* see the "invalid context" error (in the Console app) a bunch of times, and then only in fullscreen mode.  (I also checked in Safari and don't see this error there.)  That at least gives us something to hang on to.  Shortly I'll open another bug on that.

(Note that if you're running FF from Terminal, FF's performance will be slowed down when large numbers of *any* error message get displayed there.)
(Reporter)

Comment 9

4 years ago
OK, it working in beta gives us something to go on at least :) I’ll try there first, then bisect my way back up to current. (I’m not running from the terminal btw, was looking in OS X’s Console.)
I've opened bug 1058713.

Robin, I doubt you'll be able to find a regression range -- I expect all versions of Firefox are equally effected/unaffected.  But in any case please do try to find one.

It'll be even better if you can still test on Yosemite DP5 (build 14A314h).  (You appear to be using Yosemite DP6, build 14A329f.)  I can only reproduce the "invalid context 0x0" errors on DP6 (not on DP5).  So if the errors are associated with the performance problems you see, they should be worse on DP6 than they are on DP5.
(Reporter)

Comment 11

4 years ago
I’m on Public Preview 2 (14A329r). Don’t have an Apple developer account, sorry. Starting bisecting now.
> I’m on Public Preview 2 (14A329r)

That sounds very close to DP6 (14A329f).  So it's probably safe to presume that they are identical.
(Reporter)

Comment 14

4 years ago
I meant, of course, 2014-01-04. Sorry!

Comment 16

4 years ago
I wonder if the corner radius here https://hg.mozilla.org/mozilla-central/rev/3e7eb1a98175#l1.21 is 0 and that triggers the warnings... I don't see how that'd trigger slowness unless some of the code deals badly with a 0 in there... don't know enough about cocoa code to tell offhand, but that'd surprise me.
I'm going to pursue the warnings in bug 1058713, when I can (maybe not for a while).

I may *never* have time for this bug, as I can't reproduce it.
(Reporter)

Comment 18

4 years ago
OK, well hopefully whatever fix you come up with for bug #1058713 will fix this issue. Thanks for helping me dig further into it.

Comment 19

4 years ago
(In reply to Robin Whittleton from comment #13)
> 2014-01-03 is good:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/01/2014-01-03-03-
> 02-03-mozilla-central/firefox-29.0a1.en-US.mac.dmg
> 
> 2014-01-14 is bad:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/01/2014-01-04-03-
> 02-04-mozilla-central/firefox-29.0a1.en-US.mac.dmg
> 
> You’re probably faster at working out what was checked in at that point that
> might have caused this.

I don't have a lot to add other than I can confirm that this is where the change in performance happens for me too.
Is the regression range in comment #13 also for the "invalid context 0x0" errors?  In other words, do you also first see those errors with the 2014-01-04 mozilla-central nightly, and not in the 2014-01-03 mozilla-central nightly?
(Reporter)

Comment 21

4 years ago
Confirmed. The invalid context 0x0 errors start appearing in the 2014-01-04 build, aren’t present in 2014-01-03.
Thanks for that info, Robin!  That makes it more likely that we'll be able to fix this bug by fixing bug 1058713.

Comment 23

4 years ago
Per bug 1058713 comment #10, this was fixed by bug 1058713, which just landed on trunk. \o/
(probably just too late for today's nightly, but tomorrow's should be OK)
Assignee: nobody → mstange
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Flags: qe-verify+
QA Contact: catalin.varga
Verified as fixed using:

FF 34.Debug
Build Id:20141027160023
OS: Mac Os X 10.10
Status: RESOLVED → VERIFIED

Updated

4 years ago
Duplicate of this bug: 1095526
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.