Closed Bug 1058784 Opened 7 years ago Closed 7 years ago

[User Story] Loading a Top Site of History entry from the Browser start page should load existing window with same URL

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1055761
tracking-b2g backlog

People

(Reporter: pdol, Unassigned)

References

Details

(Keywords: polish, Whiteboard: systemsfe)

User Story

As a user, when I click on a Top Site or History entry from the Browser start page and I have a window in my windows stack that matches the same URL, I want the existing window to load instead of loading a new one, in order to avoid duplicates in the task manager.

Acceptance Criteria:
1. Loading a Top Site or History entry launches a new window when no window in the window stack matches the selected URL.
2. Loading a Top Site or History entry launches the existing window in the window stack when it matches the selected URL.
3. If more than one window in the window stack matches the selected URL, the most recent one is loaded.
4. Interaction matches UX spec.
No description provided.
Keywords: polish
Whiteboard: systemsfe
Same bug as bug 1045894, but fixed in bug 1055761.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
See Also: → 1045894
Duplicate of bug: 1055761
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.