Closed Bug 945259 (browser-chrome-mvp) Opened 6 years ago Closed 6 years ago

System Browser Chrome MVP Meta Bug

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog)

VERIFIED FIXED
2.1 S3 (29aug)
tracking-b2g backlog

People

(Reporter: pdol, Unassigned)

References

Details

(Whiteboard: [systemsfe], system-browser[tako][2.1-feature-qa+])

User Story

UX Interaction spec:
https://mozilla.box.com/s/2tix674298wtc4e4hewh

Visual Specs:
Spec:
https://mozilla.box.com/s/oedme1y7u6m3s6lxvk0a

Flow:
Site Loading
https://mozilla.box.com/s/g2of03hha34htbc4keep

App Loading
https://mozilla.box.com/s/8e3eed15f1656f8kbfb4

Motion:
App Loading 
https://mozilla.box.com/s/3wvt1n5jxsbry9pu1p1v

Site Loading
https://mozilla.box.com/s/sn2m5espkyupeyldpq91

Image assets:
https://mozilla.box.com/s/xleyd4fnpl5e2gvo2bxr



Context Menu:
Flows:
Long press media (images, videos, etc)
https://mozilla.box.com/s/sz3ldekcunmcgh4zbm6c

Long press links
https://mozilla.box.com/s/6z0k17nj0uxj3kko7o3z

Spec:
https://mozilla.box.com/s/3k2tf256ezqmhaemxvbj
Options Menu (aka Overflow Menu)

Flow:
https://mozilla.box.com/s/r36n5hqu8ji0rppo2e1j

Spec:
https://mozilla.box.com/s/urudcnxj6ub4ov95ltx7

Image assets (for context/options menus)
https://mozilla.box.com/s/zkdtnyb7ilurzwzrs4qk
This is the meta bug for the integration of the Browser into the System.
I really think we should create bz component for this. The meta bug is going to get really large quickly otherwise. I'll go file a bug for one.
(In reply to Jason Smith [:jsmith] from comment #1)
> I really think we should create bz component for this. The meta bug is going
> to get really large quickly otherwise. I'll go file a bug for one.

Filed https://bugzilla.mozilla.org/show_bug.cgi?id=945272 for this.
Depends on: 938177
Depends on: 938288
Depends on: 938173
I'm going to WONTFIX this bug in favor of moving to the bz component created.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
(In reply to Jason Smith [:jsmith] from comment #3)
> I'm going to WONTFIX this bug in favor of moving to the bz component created.

Awesome, thanks for getting this in place.

If you don't mind, I'm going to repurpose this to track the MVP for the System Browser then. (the idea being we don't ship the system browser until we have the MVP ready)
Status: RESOLVED → REOPENED
Component: Gaia::System → Gaia::System::Browser Chrome
Resolution: WONTFIX → ---
Summary: System Browser Meta Bug → System Browser MVP Meta Bug
(In reply to Peter Dolanjski [:pdol] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > I'm going to WONTFIX this bug in favor of moving to the bz component created.
> 
> Awesome, thanks for getting this in place.
> 
> If you don't mind, I'm going to repurpose this to track the MVP for the
> System Browser then. (the idea being we don't ship the system browser until
> we have the MVP ready)

Okay. Makes sense.
Depends on: 945827
Version 0.4 of the Rocket Bar UX spec available on Box at: https://mozilla.box.com/s/8va7n4g4exhrp0l1xu5b
Depends on: 948320
Blocks: 898075
Depends on: 966901
Alias: system-browser-mvp
Depends on: 966137
Depends on: 966897
Depends on: 967447
Depends on: 967454
Depends on: 967480
Depends on: 968178
Depends on: 968186
Depends on: 971268
No longer depends on: 968186
No longer depends on: 971268
Depends on: 975096
Whiteboard: ft:systems-fe, system-browser → [systemsfe], system-browser
No longer depends on: 967480
Depends on: 962610
Depends on: 962612
Depends on: 894678
User Story: (updated)
User Story: (updated)
Depends on: 1026031
Depends on: 1039935
Depends on: 1042049
Depends on: 1042050
Adding owner since Kevin is leading this team and setting for targeted milestone SP3
Assignee: nobody → kgrandon
feature-b2g: --- → 2.1
Whiteboard: [systemsfe], system-browser → [systemsfe], system-browser[tako]
Target Milestone: --- → 2.1 S3 (29aug)
Depends on: 1043931
Depends on: 1043959
QA Whiteboard: [2.1-feature-qa+]
User Story: (updated)
Hi Kevin,

This doesn't look like it's been implemented to the visual spec yet.
Thought I would list out visual issues so when you get to it everything is clear.

RB Collasped State:
1. Input field width needs to be updated (it's been reduced in the latest spec)
2. Input text should be italic 
3. The ellipses are too close to the edge of the input field, can we add 5rem padding to the right?

RB Expanded State:
1. Input Text should be italic
2. Div line should be #000000 at 5% opacity

Details can be found in the spec on box:
https://mozilla.box.com/s/oedme1y7u6m3s6lxvk0a

Let me know if you have any questions, thanks!
Flags: needinfo?(kgrandon)
(In reply to Eric Pang [:epang] from comment #8)
> Hi Kevin,
> 
> This doesn't look like it's been implemented to the visual spec yet.
> Thought I would list out visual issues so when you get to it everything is
> clear.
> 
> RB Collasped State:
> 1. Input field width needs to be updated (it's been reduced in the latest
> spec)
> 2. Input text should be italic 
> 3. The ellipses are too close to the edge of the input field, can we add
> 5rem padding to the right?
> 
> RB Expanded State:
> 1. Input Text should be italic
> 2. Div line should be #000000 at 5% opacity
> 
> Details can be found in the spec on box:
> https://mozilla.box.com/s/oedme1y7u6m3s6lxvk0a
> 
> Let me know if you have any questions, thanks!

Hey Kevin, forgot to mention a few things.

1.  Is it possible to have a white screen when a web page is loading (it's currently black)?

2. Should the loading page come in as a new sheet?
https://mozilla.box.com/s/g2of03hha34htbc4keep

3.  Can we update the progress bar?  I'm hoping we can update to what's in the spec with css.
Should a new bug be open for this?

Thanks!
(In reply to Eric Pang [:epang] from comment #9)
> (In reply to Eric Pang [:epang] from comment #8)
> > Hi Kevin,
> > 
> > This doesn't look like it's been implemented to the visual spec yet.
> > Thought I would list out visual issues so when you get to it everything is
> > clear.
> > 
> > RB Collasped State:
> > 1. Input field width needs to be updated (it's been reduced in the latest
> > spec)
> > 2. Input text should be italic 
> > 3. The ellipses are too close to the edge of the input field, can we add
> > 5rem padding to the right?
> > 
> > RB Expanded State:
> > 1. Input Text should be italic
> > 2. Div line should be #000000 at 5% opacity
> > 
> > Details can be found in the spec on box:
> > https://mozilla.box.com/s/oedme1y7u6m3s6lxvk0a
> > 
> > Let me know if you have any questions, thanks!
> 
> Hey Kevin, forgot to mention a few things.
> 
> 1.  Is it possible to have a white screen when a web page is loading (it's
> currently black)?
> 
> 2. Should the loading page come in as a new sheet?
> https://mozilla.box.com/s/g2of03hha34htbc4keep
> 
> 3.  Can we update the progress bar?  I'm hoping we can update to what's in
> the spec with css.
> Should a new bug be open for this?

Sure, these all seem like they should be doable - lots of things in flux right now. Go ahead and open a few new bugs and we'll get them sorted out. Thanks!
Flags: needinfo?(kgrandon)
(In reply to Eric Pang [:epang] from comment #9)
> Should a new bug be open for this?

Also let's go ahead and block this bug with any new bugs opened. Thanks!
Flags: in-moztrap?(nhirata.bugzilla)
QA Contact: nhirata.bugzilla
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: [systemsfe], system-browser[tako] → [systemsfe], system-browser[tako][2.1-feature-qa+]
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap?(mozillamarcia.knous)
QA Contact: nhirata.bugzilla → mozillamarcia.knous
Depends on: 1052481
Depends on: 1052492
Depends on: 1052497
Depends on: 1052503
No longer depends on: 1052481
No longer depends on: 1052492
Duplicate of this bug: browser-in-system
Depends on: 1053318
No longer depends on: 941253
No longer depends on: 1052503
Depends on: 1053758
Since this is a meta bug, I'm removing the feature flag as the individual child feature are already flagged.
blocking-b2g: --- → backlog
feature-b2g: 2.1 → ---
Depends on: 1052492
Depends on: 1038726
Depends on: 1054215
Depends on: 1054238
Depends on: 1054447
Depends on: 1054455
Depends on: 1054457
No longer depends on: 1054447
No longer depends on: 1054215
No longer depends on: 1052492
No longer depends on: 1052497
No longer depends on: 1053758
No longer depends on: 1054457
No longer blocks: rocketbar-search-mvp
No longer depends on: 945827
No longer depends on: 938177
Alias: system-browser-mvp → browser-chrome-mvp
Summary: System Browser MVP Meta Bug → System Browser Chrome MVP Meta Bug
No longer depends on: 938288
No longer depends on: 941270
No longer depends on: 962610
No longer depends on: 962612
No longer depends on: 1043959
Depends on: 1054556
Depends on: 1054672
Depends on: 1052481
Depends on: 1041371
Depends on: 1041372
Depends on: 1041373
Depends on: 1041376
No longer depends on: 1052481
Depends on: 1050868
Depends on: 1052488
Depends on: 1052481
Depends on: 1053747
Depends on: 1052492
No longer depends on: 1050868
No longer depends on: 1052481
No longer depends on: 1053747
No longer depends on: 1052492
No longer depends on: 1054556
No longer depends on: 941238
Depends on: 1057396
No longer depends on: 941214
Depends on: 941214
Depends on: 1054466
No longer depends on: 1054455
Depends on: 1056770
Depends on: 1053758
Depends on: 1056778
Depends on: 1052492
Depends on: 1052481
Depends on: 1050868
Depends on: 1054778
Depends on: 1058707
Depends on: 1058096
Depends on: 1052503
Depends on: 1058784
No longer depends on: 1056770
No longer depends on: 1054778
Ben - Is this feature completely landed at this point? If it is, can we close this out? If not, what's left here? Just want to know if we're fully feature landed or not with the System Browser.
Flags: needinfo?(bfrancis)
QA Whiteboard: [2.1-feature-slip?]
Assignee: kgrandon → nobody
No longer depends on: 1056778
All the bugs marked with the "feature" keyword are landed, yes. The remaining dependencies are marked as "polish".

As to whether we keep this bug open, I don't know whether our MVP meta bugs are tracking "feature landed" or "feature complete".

If it makes you happy you can mark this bug as RESOLVED FIXED and move the dependencies over to bug 1055065 like was done with bug 946452.
Flags: needinfo?(bfrancis)
(In reply to Ben Francis [:benfrancis] from comment #15)
> All the bugs marked with the "feature" keyword are landed, yes. The
> remaining dependencies are marked as "polish".
> 
> As to whether we keep this bug open, I don't know whether our MVP meta bugs
> are tracking "feature landed" or "feature complete".
> 
> If it makes you happy you can mark this bug as RESOLVED FIXED and move the
> dependencies over to bug 1055065 like was done with bug 946452.

Okay, that would be helpful - that gives an indication to our test team in our bug queries that the feature is fully landed, so they know they can now test the feature as a whole. I'll move the remaining bugs over to the other tracking bug.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
No longer depends on: 1050868
No longer depends on: 1053758
QA Whiteboard: [2.1-feature-slip?]
QA Whiteboard: [needs-verification]
Spec Sheet being referred to: https://mozilla.app.box.com/s/2tix674298wtc4e4hewh/1/1399872384/16451967037/1

The user is able to do the following as expected:

- User can freely expand or collapse the Rocketbar without issue when in the browser
- The screen is dimmed and a keyboard appears when the user taps in the Rocketbar (Portrait/Landscape)
- Search suggestions are updated as the user types
- User is able to transition through active Rocketbar web pages using edge gestures
- User can pull down status bar from in a full screen app (Portrait/Landscape) in order to access the Rocketbar
- Scrolling vertically through Rocketbar search results works as expected
- When opening a Rocketbar search, the loading screen is shown with the expanded Rocketbar
- Entering a URL into the Rocketbar will take the user to the appropriate page
- Tapping on links within a webpage takes the user to the correct link
- When long tapping a link, the proper menu with the correct buttons is displayed 
- User is able to properly open a New Window
- When swiping between web pages, the rocket bar does not change size, unless the page is refreshed and was collapsed before refresh
- User can opt in or out of Search Suggestions as expected
- Downloading/Saving media files from the browser functions properly
- User is shown back/forwards buttons at proper time, and buttons function properly
- Rocketbar text is highlighted when in edit state

However I cannot verify this bug as fixed for Flame 2.1 based on the following issues:

1) Rocketbar does not appear in task manager as shown in the spec sheet
2) App name is not shown above the page as shown in the spec sheet
3) Swiping down from the top or of the screen while Rocketbar is active does not call the task manager as shown in the spec sheet
4) Task Manager button is unresponsive - https://bugzilla.mozilla.org/show_bug.cgi?id=1064975
5) Top sites, or History are not shown on first launch of the Browser app - https://bugzilla.mozilla.org/show_bug.cgi?id=1067573
6) Tapping on Show Windows, and then closing a page will leave the user on a blank white screen - https://bugzilla.mozilla.org/show_bug.cgi?id=1067649
7) Icons are not showing on the home screen properly (Showing Rocketship Icons) - https://bugzilla.mozilla.org/show_bug.cgi?id=1059470


Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140915000203
Gaia: 944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko: 7546fedad918
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

====================================================================================

In Flame 2.2 all of the above is working properly, except:

1) Rocketbar does not appear in task manager as shown in the spec sheet
3) Swiping down from the top or of the screen while Rocketbar is active does not call the task manager as shown in the spec sheet


Flame 2.2 (319mb)

Environmental Variables:
Device: Flame Master 
Build ID: 20140915040203
Gaia: 855be6ade407c26e0596e7306a44deebc3f60933
Gecko: f27ff178807d
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [needs-verification] → [QAnalyst-Triage?][failed-verification]
Needinfo UX team to see if 1) and 3) have been removed due to design change, or if they require bugs. Per comment 17.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
Kevin - Can you add bug dependencies here that we've determined to FL blockers?
Flags: needinfo?(ktucker)
I added the bug dependencies except for bug 1067649. We need info the owner asking for a blocking decision. I will add it to the list if determined to be a blocker.
Depends on: 1059470, 1064975, 1067573
Flags: needinfo?(ktucker)
Flagging Francis on comment #17 Rocketbar questions.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(fdjabri)
(In reply to Derek Harris [:DerekH] from comment #18)
> Needinfo UX team to see if 1) and 3) have been removed due to design change,
> or if they require bugs. Per comment 17.

Hi Derek, the spec sheet that you're referring to is out of date. The latest browser/task manager specs for 2.1 are at:

https://mozilla.box.com/s/lbw2wzw3p4jvxs24k4sg

Note, however, that the specs for task manager show a desired design which the developers were not able to complete in time. Therefore, we are falling back on the existing 2.0 task manager design for 2.1. But in any case points 1) and 3) that you refer to above do not apply.
Flags: needinfo?(fdjabri)
Derek, could you please verify this issue again based on comment 22 and the fact that all bugs in comment 17 appear to be resolved.
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(dharris)
After reviewing the bugs that were recently closed as fixed from comment 17, and seeing that the 2.0 task manager is being used for 2.1 per comment 22, I am able to verify this bug as fixed on both Flame 2.1, and Flame 2.2

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140930000203
Gaia: a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko: cde28bd9a285
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140930040206
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: 7c24470b6b3a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(dharris) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
Flags: in-moztrap?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.