Closed Bug 1059303 Opened 6 years ago Closed 3 years ago

Keyboard dictionary suggestions not being shown in search field input in the search activity

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

34 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: aaronmt, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot.png
Testing Nightly (08/27) on my Nexus 5 (4.4.4), using stock Google Keyboard. Typically, I would see dictionary suggestions on input, but the three bar segments above the keyboard (see screenshot).

I have not changed any input settings.
I can confirm that I get dictionary suggestions on data:text/html<input/> in the browser fine, so this is a problem with the search activity specific.
To match fennec's behavior for keyboard input in its search bar, we hide keyboard dictionary suggestions (related bug 1049282).

I believe this is related to whether voice input is enabled. When voice input is enabled, there are blank suggestions as shown in your screenshot. When disabled, the UI works as intended.  (Voice input can be toggled with Settings > Language & input > Google voice typing.)

To move forward, we'll need to decide whether to completely hide the keyboard suggestion bar (as in Fennec) or to diverge and show suggestions. In any case, here are some related bugs that we've caused when modifying the keyboard:

  - Japanese input: Bug 1050614
  - Swipe input: Bug 1053772
IMO we should depart from the Fennec awesomebar behavior, because the awesomebar serves as both a URL input and a search input, whereas the search activity input mostly (only?) serves as a search input.
(In reply to Jim Chen [:jchen :nchen] from comment #3)
> IMO we should depart from the Fennec awesomebar behavior, because the
> awesomebar serves as both a URL input and a search input, whereas the search
> activity input mostly (only?) serves as a search input.

This is a good point - suggestions aren't very useful when typing a url, but they could be useful for search terms. I've actually found myself wanting autocomplete for a single word, but the search suggestions shown were for longer queries (I wish I could remember an example off the top of my head).

I definitely think voice input is valuable, so as long as we have the suggestions bar there for the micrphone, it seems like we might as well show suggestions, too. We also have bug 1048861 filed about voice integration.
A clean solution is to let the user decide with a preference. I really don't like dictionary suggestions, because I feel they're duplicative of what the search engine is sending us. But I understand that some people like them.

To support this, from looking at similar apps, it doesn't seem like there's a consensus on a "right" solution:

  - Bing: Shows suggestions
  - Chrome: Hide suggestions
  - Google Now: Hide suggestions
  - DuckDuckGo: Empty suggestion row with microphone (same as this bug)
In the compose window in Twitter for Android they have both a microphone input button and dictionary suggestions in the same bar above the keyboard.
(In reply to Aaron Train [:aaronmt] from comment #6)
> In the compose window in Twitter for Android they have both a microphone
> input button and dictionary suggestions in the same bar above the keyboard.

That's how our search bar would look if we removed this attribute from the search input's editText:

        android:inputType="textNoSuggestions"


(http://i.imgur.com/3Amn4r7.png)
This is an ex-Search Activity now (bug 1221344).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.