[Settings] CMAS Emergency alert cannot be toggled if cell broadcast is off

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:+, b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1][2.1-flame-test-run-3] , URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8480065 [details]
Emergencylogcat

Description:
In the SIM settings for the messages app, if the switch for cell broadcast is toggled off, user is unable to toggle Emergency alert because the selection is greyed out.  

Repro Steps:
1) Update a Flame to Build: 20140827040203
2) Go to messaging app > tap the "…" button at the top right of the screen> go to settings 
3) Under SIM settings go to the SIM 1 or SIM 2 option, which ever is enabled 
4) Toggle off the Cell broadcast button , then attempt to toggle the Emergency alert button


Actual:
Emergency Alert cannot be toggled and is greyed out when cell broadcast is off

Expected:
user is able to toggle the button by the option Emergency Alert, even if Cell Broadcast is toggled off

Environmental Variables:
Device: Flame Master (319MB)
Build ID: 20140827040203
Gaia: 6e804a42ab90f4251c7fe8c68731dc1c6abd8006
Gecko: 0753f7b93ab7
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14427/
See attached: video clip, logcat
https://www.youtube.com/watch?v=EaLuP7q3zfI&feature=youtu.be
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.1(512mb) , and Open C 2.1

Emergency Alert cannot be toggled and is greyed out when cell broadcast is off


Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140827040203
Gaia: 6e804a42ab90f4251c7fe8c68731dc1c6abd8006
Gecko: 0753f7b93ab7
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140827040203
Gaia: 6e804a42ab90f4251c7fe8c68731dc1c6abd8006
Gecko: 0753f7b93ab7
Version: 34.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Issue does NOT occur in Flame 2.0 (319mb), Open C 2.0, Flame 1.4 (319mb), and Open C 1.4

This feature did not exist in 2.0 and 1.4


Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140827000204
Gaia: d72f8ad53448aed577c01ff6e11d958463f261e7
Gecko: 2a18149b3ae8
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140827000204
Gaia: d72f8ad53448aed577c01ff6e11d958463f261e7
Gecko: 2a18149b3ae8
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
BuildID: 20140827003002
Gaia: 05653cb12d324649687dad3eeb2ea373a2ad84d4
Gecko: 7ad0648b8447
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
BuildID: 20140827003002
Gaia: 05653cb12d324649687dad3eeb2ea373a2ad84d4
Gecko: 7ad0648b8447
Version: 30.0 (1.4)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Eric, can you please look at this issue and weigh in on whether or not this should be a blocker?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(echang)
Flags: needinfo?(ktucker)
I think it's part of UX spec, cc Jenny and Arthur for more explanation.
Component: Gaia::SMS → Gaia::Settings
Flags: needinfo?(jelee)
Flags: needinfo?(arthur.chen)
Summary: [Messages] CMAS Emergency alert cannot be toggled if cell broadcast is off → [Settings] CMAS Emergency alert cannot be toggled if cell broadcast is off
CAMS can only be enabled when cell broadcast is on. The behavior was implemented based on the UX spec. I'll leave the final decision to Jenny.
Flags: needinfo?(arthur.chen)
I believe this is the spec, turning CMAS on is just adding a channel to cell broadcast.  
https://bugzilla.mozilla.org/show_bug.cgi?id=1032651#c6

(In reply to KTucker [:KTucker] from comment #2)
> Eric, can you please look at this issue and weigh in on whether or not this
> should be a blocker?
Flags: needinfo?(echang)

Comment 6

4 years ago
Created attachment 8480444 [details]
[2.1 Settings] Message Settings v1.3.pdf

Hi, please referred to the spec update that addresses the issue described here. Thanks!
Flags: needinfo?(jelee)
Eric - I think Kevin was trying to understand if you think it's a blocker or not. Can you make a blocking triage call on this bug from a feature QA perspective?
Flags: needinfo?(echang)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
This is the desired behavior from spec, we don't need to set blocker on this bug. The pdf needs update.
The comment in 1032651 is more accurate.
https://bugzilla.mozilla.org/show_bug.cgi?id=1032651#c6

(In reply to Jason Smith [:jsmith] from comment #7)
> Eric - I think Kevin was trying to understand if you think it's a blocker or
> not. Can you make a blocking triage call on this bug from a feature QA
> perspective?

(In reply to [:RJ] from comment #0)
> Actual:
> Emergency Alert cannot be toggled and is greyed out when cell broadcast is
> off
> 
> Expected:
> user is able to toggle the button by the option Emergency Alert, even if
> Cell Broadcast is toggled off
Flags: needinfo?(echang)
[Blocking Requested - why for this release]: spec changed.

Checked with Jenny again, this design is changed, so CMAS can be turn on when CB is off.

(In reply to Eric Chang [:ericcc] [:echang] from comment #8)
> This is the desired behavior from spec, we don't need to set blocker on this
> bug. The pdf needs update.
> The comment in 1032651 is more accurate.
> https://bugzilla.mozilla.org/show_bug.cgi?id=1032651#c6
> 
> (In reply to Jason Smith [:jsmith] from comment #7)
> > Eric - I think Kevin was trying to understand if you think it's a blocker or
> > not. Can you make a blocking triage call on this bug from a feature QA
> > perspective?
> 
> (In reply to [:RJ] from comment #0)
> > Actual:
> > Emergency Alert cannot be toggled and is greyed out when cell broadcast is
> > off
> > 
> > Expected:
> > user is able to toggle the button by the option Emergency Alert, even if
> > Cell Broadcast is toggled off
blocking-b2g: --- → 2.1?
I'll start to work on this item with Arthur's help. Just took it.
Assignee: nobody → ejchen
(In reply to Eric Chang [:ericcc] [:echang] from comment #9)
> [Blocking Requested - why for this release]: spec changed.
> 
> Checked with Jenny again, this design is changed, so CMAS can be turn on
> when CB is off.
> 

Is it a partner request? We checked specifically this case in the past and it was decided the opposite...

Comment 12

4 years ago
Triage: late spec change, not a blocker.
blocking-b2g: 2.1? → ---
From what I understood recently, this is quite necessary in some countries where we get a lot of "normal" CB for no reason (so the user want to turn it off) but still we'd like CMAS alerts to show up.

Would be nice to have it uplifted in v2.1 then.
Target Milestone: --- → 2.1 S6 (10oct)
Created attachment 8493609 [details] [review]
WIP patch

WIP patch and I am still working on it.
Moved to 2.2
Target Milestone: 2.1 S6 (10oct) → ---
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-1] → [2.1-flame-test-run-1][2.1-flame-test-run-3]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
Duplicate of this bug: 1114916
blocking-b2g: --- → 2.2?

Comment 17

4 years ago
Triage: This is new feature does not block. Put on tracking tag to have higher priority to work on afterwards.
blocking-b2g: 2.2? → backlog
tracking-b2g: --- → +
I'll focus on other bugs first :)
Assignee: ejchen → nobody
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
See Also: → bug 1218241

Comment 19

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.