Closed Bug 1059488 Opened 6 years ago Closed 6 years ago

[MobileID] Country code manual selection dialog seems broken

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: martijn.martijn, Assigned: ferjm)

References

Details

(Whiteboard: ft:Loop [blocking][platform])

Attachments

(1 file)

Steps to reproduce:
- Tap on "UI tests - Privileged App" App
- Tap on MobileIdentity
- Tap on "Force selection" button
You get to see the Mobile ID selector dialog
- Tap on the country code drop down list

Expected result:
A dialog should appear with all the country codes that you can choose from

Actual result:
- Nothing happens

Perhaps regression from bug 1046736?
QA Wanted for branch checks.
Keywords: qawanted
Component: Gaia → Gaia::System
I was able to get this bug but only if the first time I go into the country code selector, it works but If I back out to the menu for Force Selection and go back into the country code selector, it no longer works.

This bug repro's on: Flame 2.1, OpenC 2.1

Actual Results: Country Code selector stops responding.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master
BuildID: 20140827125050
Gaia: 6e804a42ab90f4251c7fe8c68731dc1c6abd8006
Gecko: d3f9fd13aefc
Version: 34.0a1 (Master) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140826125726
Gaia: ea93363a8c424d65a9ad91438ce6961377a20f98
Gecko: f9bfe115fee5
Version: 34.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL

*** NOTE: Flame 2.0 and Flame 1.4 don't seem to contain the Mobile Identity option in the UI Privileged Apps app. Unable to test on these.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA-Wanted triage analysis - not a regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Cody Roesch [:croesch] from comment #2)
> *** NOTE: Flame 2.0 and Flame 1.4 don't seem to contain the Mobile Identity
> option in the UI Privileged Apps app. Unable to test on these.

It was added in bug 1044060. Perhaps it should be backported to 2.0, since the mobile ID api works there too?

(In reply to Cody Roesch [:croesch] from comment #2)
> I was able to get this bug but only if the first time I go into the country
> code selector, it works but If I back out to the menu for Force Selection
> and go back into the country code selector, it no longer works.

Yeah, I see this too. Looks like a stacking issue or something where the country code selector dialog is stacked behind for some reason?
Flags: needinfo?(ferjmoreno)
Blocks: mobileid
Flags: needinfo?(ferjmoreno)
Assignee: nobody → ferjmoreno
No longer blocks: 1044060
[Blocking Requested - why for this release]: "Force selection" flow broken in Mobile ID API, the user can not finish the registration
blocking-b2g: --- → 2.0?
Whiteboard: ft:Loop [blocking][platform]
Summary: Country code manual selection dialog seems broken → [MobileID] Country code manual selection dialog seems broken
We were not cleaning the panel properly.
Attachment #8482769 - Flags: review?(alive)
blocking-b2g: 2.0? → 2.0+
OS: Mac OS X → Gonk (Firefox OS)
Priority: -- → P1
Hardware: x86 → ARM
Comment on attachment 8482769 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23634

Could you add an unit test if that is testable? Ask review again if you think it's necessary.
Attachment #8482769 - Flags: review?(alive) → review+
Whiteboard: ft:Loop [blocking][platform] → ft:Loop [blocking][platform][patch available]
Thanks Alive! I added the test and I'm waiting for the try build before merging.
https://github.com/mozilla-b2g/gaia/commit/7be8751d15967603fcf53bfb88f570b196780cc0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8482769 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23634

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1046736 took the issue to the light, but it didn't introduced the real problem.
[User impact] if declined: The user won't be able to use the mobile id flow twice if the country code selector is required.
[Testing completed]: Local tests and added a unit test.
[Risk to taking this patch] (and alternatives if risky): No risk.
[String changes made]: None
Attachment #8482769 - Flags: approval-gaia-v2.0?
Flags: in-testsuite+
Whiteboard: ft:Loop [blocking][platform][patch available] → ft:Loop [blocking][platform]
Target Milestone: --- → 2.1 S4 (12sep)
Attachment #8482769 - Flags: approval-gaia-v2.1?
Attachment #8482769 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attachment #8482769 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Verified the issue is fixed on 2.2, 2.1 and 2.0
A dialog appears with all country codes where the user can select from

Device: Flame 2.2 Master

BuildID: 20141118082629
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 084441e904d1
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1

BuildID: 20141117200726
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 45849b862a7f
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20141118044626
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: bde95439014c
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.