Closed Bug 1059713 Opened 7 years ago Closed 7 years ago

[Settings] The string in the alert msg should be changed from "SD Card" to "Internal storage".

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 wontfix, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- wontfix
b2g-v2.2 --- verified

People

(Reporter: eva.chen.fx, Assigned: mancas)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

Repro frequency: 100%

1. Tap on 'Settings' and tap 'Media storage'.
2. Under the 'Internal Storage' section and tap the 'Format internal storage' button.
3. The alert message displays.
4. <ISSUE> The string in the alert message should be changed from "SD Card" to "Internal storage".
------------------------------------------------------
* Enviromental Variables:
Device  : Flatfish 2.1 Master
B2G     : 2.1.0.0-prerelease
Gaia    : b5aed82b1d8750a53848479b6400902d920d1475
          Merge: 553f796 7a06c70
          Author: Cristian Rodriguez <crdlc@tid.es>
          Date:   Thu Aug 28 08:21:36 2014 +0200
Gecko   : 64c4bef1c1234d2fdd60974ed30d1034ec570c34
BuildID : 20140821013807
Version : 34.0a1


Actual results:

Alert message displays:
"Format SD card
This will erase all data stored on your SD card, such as music and photos."

* See attached: bug_format internal storage.jpg


Expected results:

The string in alert message should be changed from "SD card" to "internal storage".
Blocks: flatfish
Whiteboard: [Flatfish][TCP]
Blocks: 943825
No longer blocks: flatfish
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Flatfish][TCP]
Stephany, should that be considered as a UX blocker or we can land 2.1 as-is?

(Reminder, string freeze for 2.1 is 09/12/14, no string change accepted beyond this date.)
Flags: needinfo?(swilkes)
Summary: [Flatfish][Settings] The string in the alert msg should be changed from "SD Card" to "Internal storage". → [Settings] The string in the alert msg should be changed from "SD Card" to "Internal storage".
What's the basis for the string change (i.e. is it in a spec, etc.)? I only ask because "internal storage" is a much longer string and may cause truncation issues. 

This is also not a blocker, and I'm aware of string freeze. :)
(In reply to Stephany Wilkes from comment #2)
> What's the basis for the string change (i.e. is it in a spec, etc.)? I only
> ask because "internal storage" is a much longer string and may cause
> truncation issues. 
> 
> This is also not a blocker, and I'm aware of string freeze. :)

I don't think we will hit truncations here, the strings we are talking about have plenty of space (The ones in the pop-up displayed after taping on "Format internal storage" button).

Current strings:
format-sdcard-title=Format SD card
format-sdcard-message=This will erase all data stored on your SD card, such as music and photos.

Adding those:
format-internal-title=Format internal storage
format-internal-message=This will erase all data stored on your internal storage, such as music and photos.

If it's not a blocker for you, I'm totally fine getting it fixed it on 2.2+.
About the specs, looks like this particular case is not handled by https://bug922927.bugzilla.mozilla.org/attachment.cgi?id=8473426

(Yeah, I know you're fully aware about the string freeze, that was not a reminder for you :))
2.2 sounds great. Thank you for all the clarification! :)
Flags: needinfo?(swilkes)
Assignee: nobody → b.mcb
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

I think the string "format-sdcard-internal" is missing in the properties file.

Also, I'd name it "format-internal-title"
Attachment #8486258 - Flags: feedback-
Removing late-l10n as we won't land on 2.1, as per #c4
Keywords: late-l10n
(In reply to Théo Chevalier [:tchevalier] from comment #6)
> Comment on attachment 8486258 [details] [review]
> Sd card format dialog has been updated
> 
> I think the string "format-sdcard-internal" is missing in the properties
> file.
> 
> Also, I'd name it "format-internal-title"

The string isn't missing in the file, take a look:
https://github.com/mozilla-b2g/gaia/pull/23842/files#diff-d32b8deaad757f82f46fa1f7d2c9b528R968

I haven't added a new entry in order to reuse the existing one
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

Please check my comments in github, thanks!
Attachment #8486258 - Flags: review?(arthur.chen)
(In reply to Manuel Casas Barrado [:mancas] from comment #8)
> The string isn't missing in the file, take a look:
> https://github.com/mozilla-b2g/gaia/pull/23842/files#diff-
> d32b8deaad757f82f46fa1f7d2c9b528R968
> 
> I haven't added a new entry in order to reuse the existing one

Indeed, I missed that. However, I still think we can't reuse this one, because it's a string used for a button, and we'll reuse it in a title.

(See https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_best_practices#Don%27t_reuse_strings_in_different_contexts for reference)
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

Hey Arthur! I've taken care of your comments on github. Take a look when you want.

Thanks!
Attachment #8486258 - Flags: review?(arthur.chen)
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

Per comment 10, we need a separate string for the title. Please add it, thanks!
Attachment #8486258 - Flags: review?(arthur.chen)
We already have a separate string for the title. See this line:

https://github.com/mozilla-b2g/gaia/pull/23842/files#diff-d32b8deaad757f82f46fa1f7d2c9b528R976

Thanks!
Flags: needinfo?(arthur.chen)
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

LGTM, thanks!
Attachment #8486258 - Flags: review+
Flags: needinfo?(arthur.chen)
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/df7c9bb74e575fe5fc2250a437c9a8a8b24b30be
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
Verified fix on Flatfish TCP build.

OS version:2.2.0.0-prerelease
BuildID: 20140919012952
Gaia: c56af629a7629fa6aed4c0550fe4f1f59760bd40
Gecko:cce3dffb0034fbfb461f2907960ce07dcb10db48
Version: 35.0a1
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1093525
[Blocking Requested - why for this release]:

Since bug 1093525 is a 2.1 blocking issue, we should uplift the fixed patch here for v2.1. (https://bugzilla.mozilla.org/show_bug.cgi?id=1093525#c8)
blocking-b2g: --- → 2.1?
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8486258 [details] [review]
Sd card format dialog has been updated

[Approval Request Comment] 
[Bug caused by] (feature/regressing bug #): bug 1059713 
[User impact] if declined: Incorrect message(title/dialog) while a user formats internal storage.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: 2 new strings ID.
Attachment #8486258 - Flags: approval-gaia-v2.1?(fabrice)
I'm not sure the blocking decision in bug 1059713 has taken into account this will break the string freeze more than 3 months past deadline and even after the partner started picking up the final translations for its builds.


Looping in L10n Drivers, because late l10n.
(In reply to Théo Chevalier [:tchevalier] from comment #20)
> Looping in L10n Drivers, because late l10n.

The decision is up to release drivers, but it's been stated (comment 4) that this doesn't belong to 2.1. Especially considering it's been 3 months since the fix landed.

This is an important and prominent piece of UI, I don't think that exposing it in English would make any user or partner happy.
Adding Release Management here, since this breaks 2.1 string freeze and doesn't seem to make much sense to do so at this point.
Flags: needinfo?(bbajaj)
(In reply to Delphine Lebédel [:delphine - please need info] from comment #22)
> Adding Release Management here, since this breaks 2.1 string freeze and
> doesn't seem to make much sense to do so at this point.

I agree but I want Steph's comment #2 to be reconsidered by UX once again as on thinking more here we are giving the users a completely different information than expected :(

I've also requested QA to help confirm if this is anew regression in 2.1 or not which could also put in weight here on no-blocking this.
Flags: needinfo?(bbajaj) → needinfo?(swilkes)
Attachment #8486258 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1?(release-mgmt)
If it helps, here's a comparison of the current situation on latest 2.0, 2.1 and 2.2 builds.
These flags came in while I was on PTO. I am confused as to what the screenshots are showing: what exactly is the UX issue at this date? Is it that the labels on the screen don't match the labels on the buttons that led to the screen?
(In reply to Stephany Wilkes from comment #25)
> These flags came in while I was on PTO. I am confused as to what the
> screenshots are showing: what exactly is the UX issue at this date? Is it
> that the labels on the screen don't match the labels on the buttons that led
> to the screen?

Yes
That's fairly simple, then. The resulting label should match the label that users saw. If the button says "SD Card," then the confirmation text should also say "SD Card." If the button says "internal storage" then the confirmation text should match. Re-flag me if anything more specific is needed.
Flags: needinfo?(swilkes)
Ok, then we could just replace "Format internal storage" on 2.1 with "Format SD card", as it is on 2.0. That's still wrong, but it's consistent and avoid breaking 2.1 string freeze. What do you think?
(In reply to Théo Chevalier [:tchevalier] from comment #28)
> Ok, then we could just replace "Format internal storage" on 2.1 with "Format
> SD card", as it is on 2.0. That's still wrong, but it's consistent and avoid
> breaking 2.1 string freeze. What do you think?

Hi theo,

if by doing so we will be just be reverting to the old string id for 2.1 without breaking the string freeze I support this option. I understand, technically we will be wrong but atleast we will not be regressing from 2.0 and maintain the status-quo here.

Can we get a patch for that please?
Hi Bhavana,

Let me try to clarify :) The idea is indeed not to modify the l10n file at all, only reusing this string that we already have: https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/locales/settings.en-US.properties#L968

It's the l10n file we currently have on 2.1, so we already have the string "Format SD card" localized (it's used for the button to format SD card). I propose we replace the string "Format internal storage" with this one. Of course, "Format internal storage" won't be used anymore, but we will keep it in the .properties to avoid breaking string freeze (removing a string is also breaking the string freeze)

And indeed, that would be exactly what we have on 2.0.

Let me know if you have any question.

To fix it, it should be trivial here: https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/js/media_storage.js#L162 (But I don't have time this week, so anyone can provide a fix)
(In reply to Théo Chevalier [:tchevalier] from comment #30)
> Hi Bhavana,
> 
> Let me try to clarify :) The idea is indeed not to modify the l10n file at
> all, only reusing this string that we already have:
> https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/locales/settings.
> en-US.properties#L968
> 
> It's the l10n file we currently have on 2.1, so we already have the string
> "Format SD card" localized (it's used for the button to format SD card). I
> propose we replace the string "Format internal storage" with this one. Of
> course, "Format internal storage" won't be used anymore, but we will keep it
> in the .properties to avoid breaking string freeze (removing a string is
> also breaking the string freeze)
> 
> And indeed, that would be exactly what we have on 2.0.
> 
> Let me know if you have any question.
> 
> To fix it, it should be trivial here:
> https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/js/media_storage.
> js#L162 (But I don't have time this week, so anyone can provide a fix)

Ian/arthur, I think this is the best we can do in 2.1 for now, can you please provide a solution per theo's recommendation to land a 2.1 specific patch or have any other ideas here ?
Flags: needinfo?(iliu)
Flags: needinfo?(arthur.chen)
I understand we cannot break string freeze. And we can reuse these localized string which are existed to combine a completed title/sentence for a user. I think we can correct the title. But how can we combine them for revising sentence.   

Target:
format-internal-title=Format internal storage (will be okay)
format-internal-message=This will erase all data stored on your internal storage, such as music and photos.(?)
https://github.com/mozilla-b2g/gaia/pull/23842/files#diff-d32b8deaad757f82f46fa1f7d2c9b528R977
Flags: needinfo?(theo.chevalier11)
Flags: needinfo?(iliu)
Flags: needinfo?(arthur.chen)
We have to deal with what we have here and can't change anything: https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/locales/settings.en-US.properties#L938

So yes, we could fix the title by reusing the same string as in the button, but we won't be able to fix this one in any way:
format-sdcard-message=This will erase all data stored on your SD card, such as music and photos.

So, we have to get rid of "internal storage" wording on 2.1.

I suggest:

For the button: format-sdcard-external-0=Format SD card
For the confirmation title: format-sdcard-title=Format SD card
For the confirmation message: format-sdcard-message=This will erase all data stored on your SD card, such as music and photos.
Flags: needinfo?(theo.chevalier11)
Also removing late-l10n since 2.1 will remain string frozen.
Keywords: late-l10n
Duplicate of this bug: 1114503
This issue dose NOT exist on Flame 2.2:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
(In reply to Théo Chevalier [:tchevalier] from comment #33)
> We have to deal with what we have here and can't change anything:
> https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/settings/locales/settings.
> en-US.properties#L938
> 
> So yes, we could fix the title by reusing the same string as in the button,
> but we won't be able to fix this one in any way:
> format-sdcard-message=This will erase all data stored on your SD card, such
> as music and photos.
> 
> So, we have to get rid of "internal storage" wording on 2.1.
> 
> I suggest:
> 
> For the button: format-sdcard-external-0=Format SD card
> For the confirmation title: format-sdcard-title=Format SD card
> For the confirmation message: format-sdcard-message=This will erase all data
> stored on your SD card, such as music and photos.

Since string freeze and no way to fix the string inconsistent problem(button/dialog-title/dialog-description), we make a decision to work around the string of the button. That will make a correct string to be wrong. Although it will make the three strings to be consistent. In my mind, that is making another string issue there. People might confuse that button 'Format SD card' is located in an internal storage section immediately. Furthermore, we have to add some unreasonable code to change string mapping. This is not make senses for me. And might have some regression if we are not careful.

I would like to confirm the change with UX again.

For the button: Format internal storage(O) --> Format SD card(X)
Flags: needinfo?(swilkes)
Sorry to be late to this. I’m on PTO in Mexico with slow-to-no Internet depending on the moment.

If we can’t fix this for 2.1, we must fix it for 2.2 (though from comment #36 it sounds like it may be already, which is good). It does not make sense that “internal storage” and “SD card” are referred to both synonymously and as different things in the same UI. I can’t confirm the change, then, unless I'm confirming it because we have no choice and are now forced to have bad UX due to string freeze. We should be doing what Theo suggests in comment #33 to consider this truly fixed.
Flags: needinfo?(swilkes)
Since string freeze in v2.1, we cannot find out a good way to fix the string inconsistent problem truly. And I considerate that we might make other regression if we do some workaround in the script. I would like to suggest won't fix in v2.1.
blocking-b2g: 2.1+ → ---
Attachment #8486258 - Flags: approval-gaia-v2.1?(release-mgmt)
It's fixed in 2.2 and due to string freeze and no good solution in 2.1, won't fix in 2.1.
You need to log in before you can comment on or make changes to this bug.