Open Links In New Windows In [Background | Foreground] Pref

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
17 years ago
8 years ago

People

(Reporter: Brett Denny, Unassigned)

Tracking

Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Created with bug 56690 (Open Links in New Background Window) in mind, but as an
alternate option to bug 67571 (Add Open Links In New Background Window to
Context Menu).  If there isn't going to be a context menu item for opening new
windows/tabs in the background since the menus are so cluttered anyway, there
should at least be an item in the prefs that lets the user decide which the
default action is for opening links in new windows is - either in the foreground
or background.  If I am simply "mouse browsing" and opening a large number of
extra windows, a modified click (as suggested in bug 67571) would be rather
un-user-friendly.  Perhaps I'm the only one who finds this, but after using
Multizilla (which includes this in the context menu), now that I at least have
the option to open background windows, I haven't found the need to open new
windows/tabs in the foreground *at all*.

Comment 1

17 years ago
-> UI Design?
Assignee: sgehani → mpt
Component: Preferences → User Interface Design
QA Contact: sairuh → zach

Comment 2

17 years ago
I agree there should be a pref for background loading. I would like
to see its default set for "Open in New Tab" (because the added tab
makes clearly visible that the page is being opened in the background)
and unset for "Open in New Window" (because unless there is a currently
visible taskbar it might not be obvious that another page is loading).

Comment 3

17 years ago
Tabs:

Edit->Preferences...->Navigator->Tabbed Browsing->Load Links in the Background

Tabs are what they seem to be trying to move toward anyway (easy fix, rather
wontfix, of bug 49141 :-). As for new windows in the BG, that doesn't sound very
XPish. I seem to remember it as part of JS and the new pop-under trend, but I'm
probably wrong about XP. If new windows were made with JS...

note that by xp i mean cross-platform, exactly the opposite of Windows™ XP™®©.

Comment 4

17 years ago
Adding depend on bug 56690, as the summary of that bug is more general. Note
that while a preference has been discussed in that bug, I think this should stay
as a seperate bug.

-> enhancement, confirming, all, all
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Depends on: 56690
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: [RFE] Open Links In New Windows/Tabs In [Background | Foreground] Pref → [RFE] Open Links In New Windows In [Background | Foreground] Pref

Updated

16 years ago
Keywords: mozilla1.2

Updated

16 years ago
Blocks: 161466

Comment 5

16 years ago
*** Bug 161043 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
.
Assignee: mpt → blaker
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → paw
Summary: [RFE] Open Links In New Windows In [Background | Foreground] Pref → Open Links In New Windows In [Background | Foreground] Pref

Comment 7

15 years ago
See also bug 209341, same bug for Firebird.
Product: Core → Mozilla Application Suite
Assignee: bross2 → guifeatures
QA Contact: pawyskoczka
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

10 years ago
Flags: blocking-seamonkey2.0a1?

Comment 9

10 years ago
Won't block alpha, and as per bug 56690, would probably depend on a core fix.
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1-

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 10

8 years ago
With all the world moving to tabs, and not seeing window stacking to be really fixed, I guess we just should admit we won't be able to fix this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.