Closed Bug 1059853 Opened 8 years ago Closed 8 years ago

Check for Add-on Updates via Add-ons Manager does NOT work, reports "No updates found" when there are newer versions at AMO

Categories

(addons.mozilla.org Graveyard :: API, defect)

All
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1058643

People

(Reporter: dj.4bug, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

On checking to see if there are newer versions I am told "No updates found"
when there ARE newer versions at addons.mozilla.org (AMO).


STR

1. Create a new profile.

2. Install an Add-on that is recent but NOT the very latest version.

e.g. Use 
https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/versions/
to install Version 1.2.4beta6 Released August 20, 2014
of Classic Theme Restorer.

3. in "about:addons", "Extensions" Tab, use the 'cog wheel' to "Check for Updates".

Expected results:

The Add-on (AKA Extension) should update.
In this case, Classic Theme Restorer should update to 1.2.4beta7 (or newer).


Actual results:

The Add-on Manager says "No updates found".


I think this issue started about 26 or 27 August 2014.
I have tested with both Aurora and Release.
I think the issue is 'infrastructure' at AMO rather then code changes in Firefox.

I have filed this bug in "Add-ons Manager" but I still think the issue
is related to 'infrastructure' at AMO - please adjust (if you can confirm the issue).

In the STR I deliberately used Classic Theme Restorer because
other Add-ons, that I use (e.g. NoScript and RequestPolicy), could
introduce 'changes to how I communicate with AMO' and so make the
situation harder to debug.

Also, this is NOT a duplicate of bug 703897 - that bug is about Plugins.
This bug is about Add-ons (AKA Extensions).


BACKGROUND
I normally browse using several Aurora profiles (Fx 33.0a2).
Some are used exclusively for particular tasks, e.g. a profile ONLY for web email.
I also have some profiles for use with Release (Fx 31).

All profiles have NoScript, RequestPolicy and Classic Theme Restorer.
Some profiles have other Add-ons (Extensions) in addition to these 3.
I use the "rc" (AKA Dev) versions of NoScript.
I use the "Beta" (AKA Dev) versions of Classic Theme Restorer (and I colour
the 'Active Tab' using a 'special colour' - to remind me which profile
I am using).

So I expect to update Add-ons often. I check daily.
I always 'find new versions' at least once a week, sometimes several versions in 24 hours.

In the past, when there have been 'issues with AMO', I have 'collected direct from NoScript' using:

"Recent all builds from noscript.net"
http://noscript.net/feed?c=200&t=a

This feed shows the 200 most recent versions.
If you change "c=200" to "c=2000" you will see all the versions back to March 2007.


Note:
I can 'help myself to versions via the versions page at AMO' (or the feed)
and INSTALL newer versions.

The issue is the WRONG "No updates found" message when there are newer versions.

DJ-Leith
"Screenshot-Fx31-CTR-1-2-4beta6-WRONG-at-2014-08-28.png"

One additional point,
When I tried the same STR as in comment # 0 but used an 'older version of CRT'

i.e.
Version 1.2.4beta4 Released August 18, 2014.
The "Add-ons Manager" did update BUT only to
Version 1.2.4beta6 Released August 20, 2014

The latest version is "Version 1.2.4beta7" Released August 26, 2014.

So, maybe a 'database at AMO' is giving 'old results'?
Are the 'old results' being cached at AMO?

DJ-Leith
I think that this is intentional. When you have a beta version of an add-on installed updating will give you the newest beta version.
Component: Add-ons Manager → API
Product: Toolkit → addons.mozilla.org
(In reply to Dave Townsend [:mossop] from comment #2)
> I think that this is intentional. When you have a beta version of an
> add-on installed updating will give you the newest beta version.

Yes, if you are on 'beta' you stay on 'beta'.
If you are on 'release' you stay on 'release' for Add-ons.

However, the issue is that
(from comment # 1)
> The latest version is "Version 1.2.4beta7" Released August 26, 2014.

and the screenshot shows
https://bug1059853.bugzilla.mozilla.org/attachment.cgi?id=8480667
that, apparently and WRONG, that "Version 1.2.4beta6" is the latest version:
the "No updates found" message, *this* bug.

"Version 1.2.4beta7" (Released August 26, 2014) has been on AMO for
two days.

Since comment # 2,
I have again checked several profiles including the test one that I screenshotted.

All are NOT finding any recent updates.
Some I have deliberately NOT manually updated (as described in comment # 0)
and so they SHOULD 'find and update' both
CTR to "Version 1.2.4beta7" Released August 26, 2014 and
NoScript to NoScript 2.6.8.40rc1 (27 August 2014 23:28).

I have, of course, manually updated the profile I use for general browsing
(so I can collect the XPI files from AMO, they ARE there!).

Can someone try the STR and confirm (or deny) this bug.

The issue, I think, is at AMO.
However, hypothetically, the issue could be some 'caching' nearer to me
in the UK.

DJ-Leith
Changed the Summary to:

"Check for Add-on Updates via Add-ons Manager does NOT work,
reports "No updates found" when there are newer versions at AMO"

See also,

The "Classic Theme Restorer - Discussion Thread (v2)"
http://forums.mozillazine.org/viewtopic.php?f=48&t=2827985&start=1200

where Aris said:
> AMO servers are very unstable for about three weeks now.
> Problems occur with add-ons auto and manual update through add-ons manager,
> with uploading add-ons to AMO, add-on validation, visiting some AMO pages
> and reviewing add-ons. Mozilla is working on fixing that, but till then
> users will have to visit CTRs add-ons page and install new (beta)
> versions manually.

See also,
Thread at mozillazine called "Firefox 31 Addons Not Updating".
Started "August 26th, 2014, 5:00 am"
http://forums.mozillazine.org/viewtopic.php?f=38&t=2863565


Similar bug, in bugzilla, is bug 1058643

DJ-Leith
Summary: Check for Add-on Updates via Add-ons Manager does NOT work → Check for Add-on Updates via Add-ons Manager does NOT work, reports "No updates found" when there are newer versions at AMO
Closing this as duplicate of bug 1058643, which seems to be exactly the same issue.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058643
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.