Closed Bug 1060217 Opened 5 years ago Closed 5 years ago

[Messages][SMS] Unable to dismiss the data change request, after switching to SIM2 then SIM1 again

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 affected)

VERIFIED DUPLICATE of bug 1065128
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: echang, Assigned: bevis)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file v2.1_DATA_CHANGE.log
### STR
1. Have 2 SIM in phone.
2. Send MMS out from SIM1 -> okay.
3. Send MMS out from SIM2.
4. Data connection changed request, and tap okay.
5. Spinning for 5 minutes and got error, unable to send MMS
https://bugzilla.mozilla.org/show_bug.cgi?id=1060185

6. Send MMS out from SIM1.
7. Data connection changed request, and tap okay.

### Actual 
Unable to dismiss the request page, it keeps coming back

### Version
Gaia      007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko     https://hg.mozilla.org/mozilla-central/rev/d697d649c765
BuildID   20140828160238
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
From the log, Gaia keep requesting to send MMS via non-active SIM:
"Gecko   : -@- MmsService: RIL service is not active to send MMS."
NI Steve for help to check if there is anything abnormal in gaia-side.
Component: RIL → Gaia::SMS
Flags: needinfo?(schung)
QA Whiteboard: [COM=Gaia::SMS]
After quick debug I think the reason for this bug and bug 1060217 somewhere in bug 1058585.
(In reply to Oleg Zasypkin [:azasypkin] from comment #3)
> After quick debug I think the reason for this bug and bug 1060217 somewhere
> in bug 1058585.

Thanks for the clarification!
Flags: needinfo?(schung)
QA Wanted for branch checks.
Keywords: qawanted
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Worked fine for me in v2.0 during my 3-week trip.
Keywords: regression
Triage: Failure in mayor functionality, we can not send MMS and it's a regression
blocking-b2g: 2.1? → 2.1+
Keywords: qawanted
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140807155618
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: bd44d84142e8
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140807180713
Gaia: c45627132ae7f00026e361a14d5d084a1236af24
Gecko: 18f408a5984e
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = Repro
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: 18f408a5984e
Broken Gaia / Working Gecko = No repro
Gaia: c45627132ae7f00026e361a14d5d084a1236af24
Gecko: bd44d84142e8
Gecko pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bd44d84142e8&tochange=18f408a5984e


B2G Inbound
Last working
BuildID: 20140807030215
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: 82b971fde3d2
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140807034015
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: 0c0a98b643b5
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = Repro
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: 0c0a98b643b5
Broken Gaia / Working Gecko = No repro
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: 82b971fde3d2
Gecko pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=82b971fde3d2&tochange=0c0a98b643b5
QA Whiteboard: [COM=Gaia::SMS] → [QAnalyst-Triage?][COM=Gaia::SMS]
Flags: needinfo?(jmitchell)
Broken by  Bug 1048723 ? Can you take a look Jessica ?
Blocks: 1048723
QA Whiteboard: [QAnalyst-Triage?][COM=Gaia::SMS] → [QAnalyst-Triage+][COM=Gaia::SMS]
Flags: needinfo?(jmitchell) → needinfo?(jjong)
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::SMS] → [QAnalyst-Triage+][lead-review+][COM=Gaia::SMS]
Mmm, bug 1048723 caused a regression that was fixed by bug 1058585. But even with the fix, I can reproduce this on master. From my observations, data calls were disconnected properly, and was switched to SIM 2 successfully, but the message kept popping out. Still need gaia's help to investigate the root cause. Thanks.
Flags: needinfo?(jjong) → needinfo?(schung)
Maybe Bevis can help too, in the absence of Steve this week.

(My development Flame's second SIM slot is broken so I can't help much right now...)
Flags: needinfo?(btseng)
After further investigation, I found that the problem is because 'dom.mms.defaultServiceId', which is listened by MmsService, was not fired correctly (or not fired at all). That's why there was a mismatch is service ids [1].

'dom.mms.defaultServiceId' is fired by settings.js when it observes a 'ril.mms.defaultServiceId' change [2], however, when user selects to switch the default service id, no 'ril.mms.defaultServiceId' change is observed by settings.js. I tried to listen in gecko, and was able to observe the change, so I think the problem is in settings.js.


By the way, I was able to reproduce this by reverting the patches in bug 1048723 and 1058585, so it's not related.

[1] http://dxr.mozilla.org/mozilla-central/source/dom/mobilemessage/gonk/MmsService.js#2324
[2] http://dxr.mozilla.org/mozilla-central/source/b2g/chrome/content/settings.js#128
Moving to RIL component, even if the code in settings.js is not _really_ in the RIL code it's still related.

Thanks for your investigation Jessica!
Component: Gaia::SMS → RIL
Thanks for narrow down the problem.
I'll take it first to figure out why the logic of mapping settings to pref is broken in settings.js.
Is there any change recently in SettingsManager?
Assignee: nobody → btseng
Flags: needinfo?(schung)
Flags: needinfo?(btseng)
I was not able to reproduce this symptom in today's build in v2.1 & m-c.
set qawanted again to double confirm.
If yes, then please bisect to see what change might possibly fix it.

Thanks!
Keywords: qawanted
I cannot reproduce that with recent new builds.
Gaia-Rev        b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/d614ae398c03
Build-ID        20140923155123
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Status: NEW → UNCONFIRMED
Ever confirmed: false
Eric, in comment 16, Bevis would like a regression window to know what fixed this. Can you please look if it's possible to have one?
Flags: needinfo?(echang)
Bug 1065128 seems to be what fixed this issue.

B2g-inbound Regression Window

Last Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140915131232
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 3d4b867d6bc7
Version: 35.0a1 (2.2) 
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140915134152
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: d4b6ecaee33c
Version: 35.0a1 (2.2) 
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Last Broken gaia / First Working gecko - Issue does NOT occur
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: d4b6ecaee33c

First Working gaia / Last Broken gekko - Issue DOES occur
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 3d4b867d6bc7

Gaia Pushlog:  http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=3d4b867d6bc7&tochange=d4b6ecaee33c
QA Whiteboard: [QAnalyst-Triage+][lead-review+][COM=Gaia::SMS] → [QAnalyst-Triage?][lead-review+][COM=Gaia::SMS]
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring → jmercado
"Bug 1065128 seems to be what fixed this issue."
QA Whiteboard: [QAnalyst-Triage?][lead-review+][COM=Gaia::SMS] → [QAnalyst-Triage+][lead-review+][COM=Gaia::SMS]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Thanks for the help ^^
(In reply to Jayme Mercado [:JMercado] from comment #19)
Flags: needinfo?(echang)
Great, thanks !
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065128
Just to verify this
Gaia-Rev        778ebac47554e1c4b7e9a952d73e850f58123914
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/aa98eb8873a2
Build-ID        20141005160206
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141005.194124
FW-Date         Sun Oct  5 19:41:35 EDT 2014
Bootloader      L1TC00011840
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.