Closed Bug 1060736 Opened 5 years ago Closed 5 years ago

H.264 videos (youtube, etc) play as black with sound on Lenovo W520 (OMTC issue)

Categories

(Core :: Graphics, defect, major)

33 Branch
x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox33 --- fixed
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: jesup, Assigned: bas.schouten, NeedInfo)

References

Details

(Keywords: regression)

Attachments

(2 files)

On Youtube, and also other sites like http://haignet.co.uk/html5-video-element-test.htm, h.264 videos render as black-with-sound unless I disable media.windows-media-foundation.use-dxva (or media.windows-media-foundation.enabled).

This happens on Nightly/34 and Aurora/33; it does not happen on Beta/32.

I see this on a Lenovo W520 Win7 with older intel drivers (which are blacklisted for direct2d I believe - see mattwoodrow).  Perhaps that was uplifted to Aurora?

However, I also see this on a Win8.1 desktop with an Nvidia 760GT card with I'd presume recent drivers (modulo it's an old card).

I also see black video on Linux m-c, but that may very well be a red herring or different issue.
(In reply to Randell Jesup [:jesup] from comment #0)
> I see this on a Lenovo W520 Win7 with older intel drivers (which are
> blacklisted for direct2d I believe - see mattwoodrow).  Perhaps that was
> uplifted to Aurora?

If it's bug 1018278, that is on aurora.
Can you check the graphics section of about:support on the machines that this works on/doesn't work on. Maybe DXVA is broken when we don't have direct2d enabled?
I am having the same experience on OS X, and it has previously been reported for Linux (bug #1056343) as well as Windows (bug #1057695).  There are similar reports on mobile (see comments in bug #1044063).
Attached file gfx
I am seeing similar problems on Linux Nightly.  I haven't tried to find a workaround
Note that my linux runs are not e10s... (nor windows)
(In reply to Randell Jesup [:jesup] from comment #0)
> On Youtube, and also other sites like
> http://haignet.co.uk/html5-video-element-test.htm, h.264 videos render as
> black-with-sound unless I disable media.windows-media-foundation.use-dxva
> (or media.windows-media-foundation.enabled).
> 
> This happens on Nightly/34 and Aurora/33; it does not happen on Beta/32.

If you can find the time, it would be very helpful if you could narrow down the regression range and figure out exactly which Nightly build it regressed in.
Flags: needinfo?(rjesup)
I just recently discovered this may be rooted in a conflict with Flashblock: http://forums.mozillazine.org/viewtopic.php?f=23&t=2862257.  At least, installing the updated version of Flashblock (linked from the comments on that post) in my copy of Nightly resolved the problem.
(In reply to Eric A. Meyer from comment #7)
> I just recently discovered this may be rooted in a conflict with Flashblock:
> http://forums.mozillazine.org/viewtopic.php?f=23&t=2862257.  At least,
> installing the updated version of Flashblock (linked from the comments on
> that post) in my copy of Nightly resolved the problem.

This is not caused by that problem: I disabled flashblock, restarted, undid the config value, and had the same problem.  Also note that my issues were playing HTML5 videos (youtube or elsewhere).
Flags: needinfo?(rjesup)
the dxva hack (or foundation) no longer work, on any of nightly, aurora, or beta on my W520 win7 machine
Hardware: x86_64 → x86
Summary: H.264 videos (youtube, etc) play as black with sound unless I turn off dxva (or wmf support entirely) → H.264 videos (youtube, etc) play as black with sound (optimus?) on Lenovo W520
Could this be related to bug 1063048 and its duplicate bug 1062452? It was an Intel blacklist change that recently hit all the branches for the 32 chemspill.
disabling dxva stopped working as a workaround on the 8/27 nightly build
Regression range for the main failure is 5/20 to 5/21 nightly (5/20 works, 5/21 works only with dxva disabled)
Range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9f34f73ebe&tochange=9d8d16695f6a

And it contains " 718a9852b60d	Bas Schouten — Bug 899785: Switch on OMTC and async video on windows. r=BenWa"

I bet that's it. Try disabling OMTC to confirm?
jesup: Can you test with OMTC disabled, and if the bug goes away with OMTC disabled, we should assign this to Bas or someone in GFX to fix.
Flags: needinfo?(rjesup)
OMTC disabled makes no difference (in any build)
Flags: needinfo?(rjesup)
Correction: turning off OMTC does make it work - but you need to quit and restart
Ok, since it's clearly OMTC -> Bas
Assignee: nobody → bas
Component: Video/Audio → Graphics
Summary: H.264 videos (youtube, etc) play as black with sound (optimus?) on Lenovo W520 → H.264 videos (youtube, etc) play as black with sound on Lenovo W520 (OMTC issue)
Blacklisting should take care of this for 33,34, do we need to also worry about if this is pointing to a real problem?
Attachment #8496888 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/a96a47727207
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Bas, Nical, can one of you fill the uplift request? We need that in 33. Thanks!
Flags: needinfo?(nical.bugzilla)
Flags: needinfo?(bas)
Comment on attachment 8496888 [details] [diff] [review]
Disable all acceleration on older drivers for HD 3000

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: video rendering issues.
[Describe test coverage new/current, TBPL]:
[Risks and why]: none, driver blocklisting patch.
[String/UUID change made/needed]:
Attachment #8496888 - Flags: approval-mozilla-beta?
Attachment #8496888 - Flags: approval-mozilla-aurora?
Flags: needinfo?(nical.bugzilla)
Attachment #8496888 - Flags: approval-mozilla-beta?
Attachment #8496888 - Flags: approval-mozilla-beta+
Attachment #8496888 - Flags: approval-mozilla-aurora?
Attachment #8496888 - Flags: approval-mozilla-aurora+
I cannot reproduce this issue on Windows 7 with Nightly 2014-08-29 nor Nightly 2014-09-23.
Jesup, could you please take a look on your machine at latest 33.0b, 34.0a2 and 35.0a1 to verify this fix? Thanks in advance.
Flags: needinfo?(rjesup)
Blocks: 1295899
You need to log in before you can comment on or make changes to this bug.