Closed Bug 1061072 Opened 7 years ago Closed 7 years ago

[Contacts] Back 'X' is missing from Set ICE page (Single select mode)

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: ericcc, Assigned: jorgep)

References

Details

(Whiteboard: [p=5])

Attachments

(4 files)

### STR 
1. Have some contacts in list.
2. Try to set an ICE


### Actual
The page shown where user selects a contact for ICE looks like a normal contact list view, which can lead to circular activity 
The 'X' is missing from the top left
Spec and screenshow -> Screenshot from 2014-09-01 13:24:16.png

### Version
Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
[Blocking Requested - why for this release]: Back button missing, not spec.
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Gaia::Contacts]
Whiteboard: [p=5]
Target Milestone: --- → 2.1 S4 (12sep)
triage: major issue on new feature
blocking-b2g: 2.1? → 2.1+
Duplicate of this bug: 1062146
Assignee: nobody → jpruden92
Status: NEW → ASSIGNED
Hello Francisco,

What do you think about this solution?

https://github.com/jpruden92/gaia/tree/bug1061072-contacts

Thanks!
Flags: needinfo?(francisco)
Hei Jorge,

not kind on that solution, since we will adding a new header element.

We already can make the header setup in the way that we have, hidding the add contact and settings and showing an X.

That's happening for example when we come from an activity. Would like to explore if we reuse that option. The same way that we change the list clikc handler for doing different staff, would like to explore if we can do the same with the header.

What do you think?
Flags: needinfo?(francisco) → needinfo?(jpruden92)
I've been working on a quick patch following my previous comment. I'm still waiting for bug 1061421 to be merged since it contains nice modificiations for ice_settings.js

Here is a branch:
https://github.com/arcturus/gaia/tree/ice-select-x

Contains two patches, last patch, the specific one for this issue will be:
https://github.com/arcturus/gaia/commit/48ff179c120e4913205d99296952de568b25b47e

Still need to polish and add test, do you like the idea?
Working in it ;-)
Flags: needinfo?(jpruden92)
Target Milestone: 2.1 S4 (12sep) → 2.1 S5 (26sep)
Attached file 24094.html
Hello Francisco,

Here is the patch and the tests. Can you review them?

Thanks!
Attachment #8489962 - Flags: review?(francisco)
Comment on attachment 8489962 [details]
24094.html

Perfect work here!

Thanks a lot for the integration test!
Attachment #8489962 - Flags: review?(francisco) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/1647d85185b2068a7e2c1befb1714f1709a728f7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8482092 [details]
Screenshot from 2014-09-01 13:24:16.png

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature ICE contacts
[User impact] if declined:
UX failure, since user cannot cancel selecting a contact
[Testing completed]:
Added integration tests
[Risk to taking this patch] (and alternatives if risky):
Low, we are just exposing private methods in the list to show the cancel button
[String changes made]:
Attachment #8482092 - Flags: approval-gaia-v2.1?(fabrice)
Duplicate of this bug: 1068416
Tested and working
2.2
Flame
Gecko: 725423c
Gaia: 7426a62
Pending 2.1
Attachment #8482092 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Tested and working
Flame
2.1
User
Gecko-bdd77c4
Gaia-b3f9b97
Thanks Loli.

Gaia-Rev        b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/d614ae398c03
Build-ID        20140923155123
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Status: RESOLVED → VERIFIED
This issue still reproduces on Flame 2.1 & 2.2. Filed a new bug 1081678
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][failed-verification][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: VERIFIED → RESOLVED
Closed: 7 years ago7 years ago
QA Whiteboard: [COM=Gaia::Contacts][failed-verification][QAnalyst-Triage?] → [COM=Gaia::Contacts][failed-verification][QAnalyst-Triage+]
Depends on: 1081678
Flags: needinfo?(ktucker)
QA Contact: lolimartinezcr
Attached video VIDEO0043.mp4
This issue has been successfully verified on Flame 2.1 new versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141119001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2

See video:VIDEO0043.mp4
This bug has been verified as "Pass" on latest Nightly build of Flame v2.1
STR:
1. Create some contacts.
2. Tap the "gear" icon.
3. In contact settings page, choose the "Set ICE Contacts" item.
4. Enable "ICE Contact1" and "ICE Contact2".
5. Choose Select a contact.

Actual result:
There is a "X" icon at top-left on the Contacts list page.
See video:"Verify.3GP"

Device Info:
Flame 2.1(pass):
Build ID               20150615001205
Gaia Revision          f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gaia Date              2015-06-08 09:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/7d767fc15126
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150615.040550
Firmware Date          Mon Jun 15 04:06:02 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Contacts][failed-verification][QAnalyst-Triage+] → [COM=Gaia::Contacts][failed-verification][QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.