[Bluetooth] Separate BluetoothInterface from actual implementation

RESOLVED FIXED in 2.1 S4 (12sep)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: tzimmermann, Assigned: tzimmermann)

Tracking

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

BluetoothInterface.{cpp,h} currently implement Bluedroid support. We want to have support for multiple backends, especially a Bluetooth daemon. So the interface and the current Bluedroid code have to be separated from each other.
No functional changes. This patch just moves code around.
Attachment #8483467 - Flags: review?(shuang)
Again, no functional changes. This patch also cleans up indention errors that were accidentally introduced by the first patch.
Attachment #8483469 - Flags: review?(shuang)
Depends on: 1061126
Comment on attachment 8483469 [details] [diff] [review]
[02] Bug 1061489: Distribute Bluetooth HAL implementation among multiple files

Review of attachment 8483469 [details] [diff] [review]:
-----------------------------------------------------------------

Can we rename Bluetooth*Manager to Blutooth*HALInterface.cpp? And then add additional patches on topic of them. Otherwise, it will be better to keep git history.
Attachment #8483469 - Flags: review?(shuang)
(In reply to Shawn Huang [:shawnjohnjr] from comment #3)
> Comment on attachment 8483469 [details] [diff] [review]
> [02] Bug 1061489: Distribute Bluetooth HAL implementation among multiple
> files
> 
> Review of attachment 8483469 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Can we rename Bluetooth*Manager to Blutooth*HALInterface.cpp? And then add
> additional patches on topic of them. Otherwise, it will be better to keep
> git history.

I don't get the point, because those are two different things. The interfaces are really just interfaces. The managers instead maintain state.

For the daemon, I only want to re-implement the interfaces, but not the managers.
BTW My plan is to later add a |BluetoothInterface| for BlueZ 4 as well. At that point, most manager classes can be merged with their base class, so the current multitude of Bluetooth*Manager classes will go away.
Hi Shawn,

What's the status here? I'm not sure what to make of your last comment.
Flags: needinfo?(shuang)
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #4)
> (In reply to Shawn Huang [:shawnjohnjr] from comment #3)
> > Comment on attachment 8483469 [details] [diff] [review]
> > [02] Bug 1061489: Distribute Bluetooth HAL implementation among multiple
> > files
> > 
> > Review of attachment 8483469 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > Can we rename Bluetooth*Manager to Blutooth*HALInterface.cpp? And then add
> > additional patches on topic of them. Otherwise, it will be better to keep
> > git history.
> 
> I don't get the point, because those are two different things. The
> interfaces are really just interfaces. The managers instead maintain state.
> 
> For the daemon, I only want to re-implement the interfaces, but not the
> managers.

Sorry, it seems to me I lost my mind. I'm wrong.
sorry had to back this out since this caused a bustage like https://tbpl.mozilla.org/php/getParsedLog.php?id=47859290&tree=B2g-Inbound
(In reply to Carsten Book [:Tomcat] from comment #9)
> sorry had to back this out since this caused a bustage like
> https://tbpl.mozilla.org/php/getParsedLog.php?id=47859290&tree=B2g-Inbound

This caused by non-clean build environment. Comment 10 had already added CLOBBER change.
You need to log in before you can comment on or make changes to this bug.