Closed Bug 1061690 Opened 6 years ago Closed 6 years ago

System dialogs are truncated if closed while the keyboard is being shown

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: martijn.martijn, Assigned: ferjm)

References

Details

Attachments

(2 files)

In the latest mozilla-central build on the Flame, I get a truncated Mobile ID dialog, see screenshot.

Str:
- git clone https://github.com/mozilla-b2g/firefoxos-loop-client.git
- Install loop client, using about:app-manager, then run it
- Tap on 'Use Phone number' -> the Mobile ID dialog appears

Expected result:
- 'Share' button at the bottom of the screen and all of text of Mobile ID dialog visible

Actual result:
- 'Share button' at the middle of the screen, the "Or add your phone number" text not visible.
Blocks: mobileid
Assignee: nobody → ferjmoreno
This happens with all system dialogs
Summary: [MobileID] Mobile ID dialog is truncated → System dialogs are truncated if closed while the keyboard is being shown
[Blocking Requested - why for this release]: This is quite a bad UX as it requires the user to restart the device to recover the system dialogs correct layout. If this happens it makes impossible for the user to log in with FxA or Mobile ID until the reboot is done.
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1068569
Adding qawanted for branch checks to ensure the fix is uplifted to all affected branches.
Keywords: qawanted
Comment on attachment 8491473 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24179

r=me
Attachment #8491473 - Flags: review?(alive) → review+
Thanks Alive!
https://github.com/mozilla-b2g/gaia/commit/3d0667a13fe3dfdfb854fd563452a7385ce1e00a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
QA Contact: aalldredge
This issue occurs in 2.1 Flame and 2.1 Open_C.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140922053548
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Open_C 2.1
BuildID: 20140922081042
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: c61d4add4ba5
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
Half the screen is unused.

-----------------------------------------------------
This issue does not occur on 2.2 Flame, 2.0 Flame, or 2.0 Flame(Base).

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140922040649
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.0
BuildID: 20140920152249
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.0
BuildID: 20140904160718 (Base)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
The whole screen is used.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Fernando: 2.1 was also affected and needs your patch uplifted to that branch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(ferjmoreno)
QA Contact: aalldredge
Comment on attachment 8491473 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24179

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): System dialogs.
[User impact] if declined: This is quite a bad UX as it requires the user to restart the device to recover the system dialogs correct layout. If this happens it makes impossible for the user to log in with FxA or Mobile ID or to enter the SIM PIN until the reboot is done.
[Testing completed]: Manual tests
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: None
Attachment #8491473 - Flags: approval-gaia-v2.1?
Attachment #8491473 - Flags: approval-gaia-v2.0?
Flags: needinfo?(ferjmoreno)
Bhavana,

Please see approval/blocking requests above
Flags: needinfo?(bbajaj)
Attachment #8491473 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Comment on attachment 8491473 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24179

The issue is not happening on 2.0, so I am removing the approval request. Sorry for the noise.
Attachment #8491473 - Flags: approval-gaia-v2.0?
Flags: needinfo?(bbajaj)
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #13)
> Comment on attachment 8491473 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24179
> 
> The issue is not happening on 2.0, so I am removing the approval request.
> Sorry for the noise.

Okay, I'll also remove 2.0? but do you need 2.1?
blocking-b2g: 2.0? → ---
Flags: needinfo?(ferjmoreno)
Oh right. I forgot the 2.0? blocking flag, sorry about that.

It already landed on 2.1 via approval, so I guess we don't need the blocking flag.

Thanks Andrew.
Flags: needinfo?(ferjmoreno)
This issue is verified fixed on Flame 2.1 and 2.2.

Result: "Mobile identity" dialog is displayed properly.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141118001204
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141118040205
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.