After minimizing MobileID dialog with VKB open, reopening it, shows partly duplicated mobileID dialog

RESOLVED DUPLICATE of bug 1061690

Status

RESOLVED DUPLICATE of bug 1061690
4 years ago
4 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8490669 [details]
screenshot3 of bug

Tested on the latest mozilla-central build on Flame.

Str:
- Open UI Tests - Privileged App
- Tap on "Force selection"
- Tap on the input, the virtual keyboard (VKB) comes up
- Tap on the FirefoxOS minimize button to get to the homescreen again
- Open UI Tests - Privileged App again
- Tap on "Force selection"

Expected result:
- Normal mobileID dialog

Actual result:
- See screenshot
QA Wanted for branch checks.
Component: General → Gaia
Keywords: qawanted
Between original STR step 1 and step 2 there should be an extra step which is to enter MobileIdentity page - I couldn't execute step 2 because this step is missing. Additionally, phone's Data connection needs to be enabled.

Issue is reproducible on Flame 2.2 master, Flame 2.1, and Open C 2.2.

Observed behavior: After following STR, the Mobile ID page doesn't show up correctly, as shown in comment 0's attachment. User can get out of this weird graphical state by tapping on the 'X' on upper left to close this dialog and re-enter.

Device: Flame 2.2 Master
BuildID: 20140917114258
Gaia: 72262d054ffa5d0d2b5a0033f713149281511aea
Gecko: d2c01d77b9d0
Version: 35.0a1 (2.2 Master)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1
BuildID: 20140917121558
Gaia: ad374f4b2a07cb5711679322a815f9feadb5cf64
Gecko: b4d5f9314661
Version: 34.0a2 (2.1)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Open_C 2.2 Master
BuildID: 20140917114258
Gaia: 72262d054ffa5d0d2b5a0033f713149281511aea
Gecko: d2c01d77b9d0
Version: 35.0a1 (2.2 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

---------------

This issue is NOT reproducible on Flame 2.0. After following STR, the Mobile ID page shows up correctly.

Device: Flame 2.0
BuildID: 20140917073857
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: e02fe140c0d5
Version: 32.0 (2.0)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
[Blocking Requested - why for this release]: regression and bad user UX
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: pcheng
moving to Gaia::UI Tests component
Component: Gaia → Gaia::UI Tests

Comment 5

4 years ago
This component is for functional tests, not the app.
Component: Gaia::UI Tests → Gaia
See Also: → bug 1044060
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061690
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.