Closed Bug 106189 Opened 19 years ago Closed 15 years ago

Only one From/Reply-To address shown, even if msg has multiple addresses

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmorzins, Assigned: wolfiR)

References

Details

(Keywords: fixed-seamonkey1.1a, fixed1.8.1)

Attachments

(3 files)

RFC 822 and 2822 are quite explicit on the point that the From: and Reply-To:
fields of email messages are allowed to contain multiple addresses, rather than
just one.  Mozilla's back end implements this correctly; when replying to a
message that has multiple originator addresses, the To: field is filled with all
of the addresses.

The font end, though, only displays the last From address or the last Reply-To
address.  This is obviously not a major bug, but it would be good for the the
front end to let the user know that there are multiple From addresses.  That way
they'll be less surprised when they reply to a message and find multiple To
fields in their reply.


I'll attach a sample message.  Good luck on getting the sample message into an
IMAP server; mozilla can open message/rfc822 (*.eml) files from disk, but
displays the with formatting that is different from the formatting it uses when
displaying messages from the server.
Bug 106189 and bug 106456 are duplicates of each other.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: only one From address shown, even if msg has multiple addresses → Only one From/Reply-To address shown, even if msg has multiple addresses
*** Bug 106456 has been marked as a duplicate of this bug. ***
Bug 106456 was reassigned to mscott, so this one should go to him as well.

To reproduce, you do not really need to put the sample message into the IMAP
server - just send a message to yourself with several Reply-To fields and look
at it in Sent (or even in Drafts if you do not want to send it anywhere).
Assignee: sspitzer → mscott
In http://bugzilla.mozilla.org/show_bug.cgi?id=140333#4 I commented about more
or less the same bug with a real message:

>Testing your idea, I found something funny (Mozilla 1.0RC2)
>
>Fragment of MIME headers (names hidden):
>
>Reply-To: jetspeed-user@jakarta.apache.org
>Delivered-To: mailing list jetspeed-user@jakarta.apache.org
>Received: (qmail 84073 invoked from network); 4 Jul 2001 05:54:15 -0000
>Message-ID: <02b901c1044d$a2ebf490$353cf835@blah.company1.com>
>Reply-To: "Guy One" <guy_one@company1.com>
>From: "Guy One" <guy_one@blah.company1.com>
>To: <jetspeed-user@jakarta.apache.org>, <guy_two@company2.com>,
>   <guy_three@company3.com>
>
>Reply: goes to jetspeed-users (only first encountered Reply-To: header)
>Reply-All: goes to all of the To: people, not the From: one
>
>Is it a bug? None of the buttons would send to the "Guy One".

This is a case of multiple Reply-To:, where only the first one is honored, and 
the From: seems to be masked because the Reply-To: is present. This results in 
one person being left out of the discussion in both Reply and Reply-All cases.

In response to comment 5, the "real world" message presented is improperly 
formatted.  RFC 2822 is very clear that no more than one Reply-To header is 
permitted in a message, and I don't fault mozilla for choosing just one of the 
Reply-To headers.

However, the single Reply-To header is permitted to contain multiple addresses 
in it, and this bug is that mozilla's front end only shows one of the 
addresses.  (The back end still knows that the addresses are there, and all the 
multiple addresses will get used when the message is replied-to.)
Sorry. It looks like I was "lucky", and randomly picked up an example that showed
this improper formatting. It is about one year old, and I have not had success in
finding another one showing this behaviour.

It looks like a bug in ezmlm (or in Apache's former setup).

So, sorry about the noise :-)
I just found this and have to say it is more than surprising that only one
address is shown. This is a great confusion for the user. Upgrading to normal,
maybe major would also be OK.

pi
Severity: minor → normal
Hardware: PC → All
Product: Browser → Seamonkey
*** Bug 245921 has been marked as a duplicate of this bug. ***
(In reply to comment #7)
> Sorry. It looks like I was "lucky", and randomly picked up an example that showed
> this improper formatting. It is about one year old, and I have not had success in
> finding another one showing this behaviour.


I have seen this happen often with email sent to the OpenOffice mailing lists-
multiple reply-to headers, and Thunderbird (1.0 on Linux) only addressing the
reply to one of them, even when selecting "reply to all".

Confirmed to exist on Thunderbird 1.0 (20041206) and Mozilla 1.8a6.  The header
display in Mozilla mail only shows one email address out of multiple ones comma
separated in a single Reply-To field.
(In reply to comment #8)
> I just found this and have to say it is more than surprising that only one
> address is shown. This is a great confusion for the user. Upgrading to normal,
> maybe major would also be OK.
> 
> pi

I just ran into this bug and found it extremely confusing.  I replied to a
message and found a To: address that didn't appear anywhere in the displayed
message headers.  I think there is also a small potential for abuse of this bug,
as you could trick someone who was in a rush into sending a reply somewhere they
didn't intend.
*** Bug 307401 has been marked as a duplicate of this bug. ***
I just ran into this with mozilla 1.7.12 with a header like this:
Reply-To: isoc-ny-icann@yahoogroups.com, discuss@isoc-ny.org


This bug was opened in 2001.  Why is it still NEW?
reassing to an existing account
Assignee: mscott → mscott
Attachment #213875 - Flags: review?(mnyromyr)
I'm not sure if sr is needed. If so, could you please also give sr, David?
Attachment #213876 - Flags: review?(bienvenu)
Attachment #213876 - Flags: superreview+
Attachment #213876 - Flags: review?(bienvenu)
Attachment #213876 - Flags: review+
Attachment #213875 - Flags: superreview?(bienvenu)
Attachment #213875 - Flags: review?(mnyromyr)
Attachment #213875 - Flags: review+
Assignee: mscott → mozilla
Attachment #213875 - Flags: superreview?(bienvenu) → superreview+
checked in both patches to trunk
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Attachment #213875 - Flags: approval-seamonkey1.1a?
Comment on attachment 213876 [details] [diff] [review]
reply-to patch for TB

small change/risk -> should be in TB2
Attachment #213876 - Flags: approval-branch-1.8.1?(bienvenu)
Comment on attachment 213875 [details] [diff] [review]
reply-to patch for SM

a=me for SM1.1a
Does this fix (and TB's) depend on the fix to bug 308988 being in the branch? That's waiting on approval too.
Attachment #213875 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+
No, this is a trivial fix that should have gone in years ago.
(In reply to comment #20)
> (From update of attachment 213875 [details] [diff] [review] [edit])
> a=me for SM1.1a
> Does this fix (and TB's) depend on the fix to bug 308988 being in the branch?
> That's waiting on approval too.

They are independent but the later checked in patch has to be rediffed for checkin.

Whiteboard: fixed-seamonkey1.1
Note that the fix for the From header case was implemented in bug 308988.
Whiteboard: fixed-seamonkey1.1
Attachment #213876 - Flags: approval-branch-1.8.1?(bienvenu) → approval-branch-1.8.1+
checked in for TB2
Keywords: fixed1.8.1
*** Bug 357249 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.