Closed Bug 1061904 Opened 5 years ago Closed 5 years ago

[e10s] Fix e10s tests for Web Audio Editor

Categories

(DevTools Graveyard :: Web Audio Editor, defect)

x86
macOS
defect
Not set

Tracking

(e10s+)

RESOLVED DUPLICATE of bug 1072141
Tracking Status
e10s + ---

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

From bug 1034212#c8

Failing logs:
19979 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-param-flags.js | Got an error: target.window is null
19984 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-param-flags.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
20065 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-params-01.js | Got an error: target.window is null
20067 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-params-01.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
20130 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-params-02.js | Got an error: target.window is null
20136 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-params-02.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
20202 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-set-param.js | Got an error: target.window is null
20205 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-set-param.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
20277 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-type.js | Got an error: target.window is null
20279 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-get-type.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
20348 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-is-source.js | Got an error: target.window is null
20362 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_audionode-actor-is-source.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
20428 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | Got an error: target.window is null
20430 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
20492 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_first-run.js | Got an error: target.window is null
20494 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_first-run.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
20569 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-click.js | Got an error: target.window is null
20586 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-click.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_complex-context.html
20688 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-markers.js | Got an error: target.window is null
20782 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-markers.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
20882 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-01.js | Got an error: target.window is null
20976 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-01.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
21078 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-02.js | Got an error: target.window is null
21096 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-02.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_complex-context.html
21431 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-03.js | Got an error: target.window is null
21654 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-03.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_connect-toggle.html
21754 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-04.js | Got an error: target.window is null
21858 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-render-04.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_connect-multi-param.html
21966 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-selected.js | Got an error: target.window is null
22086 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-selected.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
22192 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-zoom.js | Got an error: target.window is null
22196 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_graph-zoom.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
22505 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_inspector-toggle.js | Got an error: target.window is null
22701 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_inspector-toggle.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
22839 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_inspector.js | Got an error: target.window is null
22841 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_inspector.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
22903 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-change-params.js | Got an error: target.window is null
22905 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-change-params.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_change-param.html
22967 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | Got an error: target.window is null
22969 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-media-nodes.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_media-node-creation.html
23054 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-params-objects.js | Got an error: target.window is null
23065 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-params-objects.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_buffer-and-array.html
23128 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-params.js | Got an error: target.window is null
23130 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view-params.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-node-creation.html
23192 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view.js | Got an error: target.window is null
23194 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_properties-view.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
23256 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-01.js | Got an error: target.window is null
23258 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-01.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
23325 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-02.js | Got an error: target.window is null
23344 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-02.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
23406 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-03.js | Got an error: target.window is null
23408 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_wa_reset-03.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_simple-context.html
23470 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_webaudio-actor-change-params-01.js | Got an error: target.window is null
23472 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_webaudio-actor-change-params-01.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_change-param.html
23534 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_webaudio-actor-change-params-02.js | Got an error: target.window is null
23548 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webaudioeditor/test/browser_webaudio-actor-change-params-02.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
bgrins: Is there any documented way/preferred way of using Holly to test patches? When working on this previously, I didn't get a lot of promising leads from asking around, although these failures weren't occuring then (but make sense now)
Flags: needinfo?(bgrinstead)
Assignee: nobody → jsantell
(In reply to Jordan Santell [:jsantell] [@jsantell] [PTO until September 4th] from comment #1)
> bgrins: Is there any documented way/preferred way of using Holly to test
> patches? When working on this previously, I didn't get a lot of promising
> leads from asking around, although these failures weren't occuring then (but
> make sense now)

Going to forward this question onto Jim, as he is who I heard about the Holly tests from in the first place (at https://bugzilla.mozilla.org/show_bug.cgi?id=875871#c18).

I do know that with these particular issues you can just run locally with mach mochitest-devtools --e10s browser/devtools/webaudioeditor and you should see the errors.
Flags: needinfo?(bgrinstead) → needinfo?(jmathies)
Flags: needinfo?(jmathies)
I'd suggest you use try, just add a patch like that to your queue. Will that work?
(In reply to Jim Mathies [:jimm] from comment #4)
> I'd suggest you use try, just add a patch like that to your queue. Will that
> work?

Seems like that will work great, thanks!
WAE tests don't use debuggee anyway, so this is pretty straight forward.

https://tbpl.mozilla.org/?tree=Try&rev=56efe8834633
Attachment #8485277 - Flags: review?(bgrinstead)
Comment on attachment 8485277 [details] [diff] [review]
1061904-wae-e10s-fix.patch

Review of attachment 8485277 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great as long as the try push is OK
Attachment #8485277 - Flags: review?(bgrinstead) → review+
Status: NEW → ASSIGNED
> +        "--quiet", "--log-raw=%(raw_log_file)s", "--e10",

Shouldn't that be:
+        "--quiet", "--log-raw=%(raw_log_file)s", "--e10s",

?
need to land bug 1057042 first as this will result in some merging conflicts
Depends on: 1057042
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072141
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.