browser/webaudioeditor tests fail in e10s

RESOLVED FIXED in Firefox 35

Status

()

Firefox
Developer Tools: Web Audio Editor
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 35
Points:
2
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 8494327 [details] [diff] [review]
0001-Bug-XXXXXXX-get-browser-devtools-webaudioeditor-test.patch

Most of the necessary changes are shallow and very similar to bug 1065355 (and hence requesting review from Patrick again!)

Note however there is also a change to toolkit/devtools/server/actors/webaudio.js, which moves the null-ing of this.tabActor to after this.tabActor is passed to off().  With these changes the tests all pass locally for me with e10s enabled.
Attachment #8494327 - Flags: review?(pbrosset)
Comment on attachment 8494327 [details] [diff] [review]
0001-Bug-XXXXXXX-get-browser-devtools-webaudioeditor-test.patch

Review of attachment 8494327 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, that does look exactly like bug 1065355 and since no test actually use debuggee, it's the perfect fix for this.
Thanks!
Attachment #8494327 - Flags: review?(pbrosset) → review+
(Assignee)

Comment 2

3 years ago
You're welcome :)

https://hg.mozilla.org/integration/fx-team/rev/6d9fb906e5b9
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Points: --- → 2
Flags: qe-verify-
Flags: firefox-backlog+
sorry had to backout this change for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=48757407&tree=Fx-Team

Updated

3 years ago
Iteration: --- → 35.2
Created attachment 8494507 [details] [diff] [review]
fix_browser_audionode-actor-get-param-flags-js.patch

The tests in browser/devtools/webaudioeditor/test/browser_audionode-actor-get-param-flags.js were not running at all. This was because:
- An attempt was made to yield inside an Array.forEach (not valid... prevents the JS engine from entering the loop).
- nodes[i].getParamFlag(param) should have been nodes[i].getParamFlags(param) (the error was not visible because the browser never entered the loop).

Spoke with markh who seems happy for me to add it to this bug.
Attachment #8494507 - Flags: review?(pbrosset)
Looks like the same fixes (as debuggee is never used) as bug 1061904, so closing that one (was waiting for refactoring bug 1057042 to land, but that just landed)
Duplicate of this bug: 1061904
(Assignee)

Comment 7

3 years ago
Comment on attachment 8494507 [details] [diff] [review]
fix_browser_audionode-actor-get-param-flags-js.patch

Sorry to mess you around Mike, but if it's OK, can you please put this new patch into a different bug, as I'm going to reland the larger patch.
Attachment #8494507 - Attachment is obsolete: true
Attachment #8494507 - Flags: review?(pbrosset)
(Assignee)

Comment 8

3 years ago
Relanded with the tests I mysteriously missed fixed in the same way, so carrying r= forward.  Try at https://tbpl.mozilla.org/?tree=Try&rev=1f6e18d9d4c8
https://hg.mozilla.org/mozilla-central/rev/b9f4aa97c721
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
You need to log in before you can comment on or make changes to this bug.