[SHB] System Sleep Dialog button overlaid by the SHB

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Eli, Assigned: Eli)

Tracking

({polish})

unspecified
2.1 S4 (12sep)
ARM
Gonk (Firefox OS)
polish
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Assignee)

Description

4 years ago
Created attachment 8483068 [details]
Sleep menu dialog overlaid by SHB

+++ This bug was initially created as a clone of Bug #1058675 +++

STR:

1. Enable the Software Home button in settings > developer
1. Hold the power button to prompt the system sleep dialog

Expected:
  The cancel button which closes this menu should be visible above the SHB.
Actual:
  SHB overlaps the button.

See attachment.
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.1+
(Assignee)

Comment 1

4 years ago
Created attachment 8483124 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23651

This change is made in a shared file, which I know is something we generally don't want to do, but this file is currently ONLY used by the system. If you feel this should be put into a general system CSS file, please let me know and I'll change.
Attachment #8483124 - Flags: review?(etienne)
Comment on attachment 8483124 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23651

Can we move this to apps/system/style/sleep_menu/sleep_menu.css and match on #sleep-menu-container?
Attachment #8483124 - Flags: review?(etienne)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8483124 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23651

Sure thing, PR updated.
Attachment #8483124 - Flags: review?(etienne)
(Assignee)

Comment 4

4 years ago
Etienne, I modified the PR again to see if I could take care of two issues with this. In bug 1055198, the "Share With" dialog is overlaid by the SHB. This is very similar to this issue with the sleep menu; one is an "action" dialog, the other is an "object" dialog. If we generalize this into the system-only action_menu_extended.css which specifically overrides styles for action and object dialogs, it would take care of both issues, which I have changed my PR to do. Thoughts?
Flags: needinfo?(etienne)
(Assignee)

Updated

4 years ago
Keywords: polish
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8483124 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23651

Sounds good!
Attachment #8483124 - Flags: review?(etienne) → review+
Flags: needinfo?(etienne)
(Assignee)

Comment 6

4 years ago
Thanks, Etienne!
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Blocks: 1059967
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1062722
Master: https://github.com/mozilla-b2g/gaia/commit/37a49a76233fe88bf63d577de5b0bc57668da849
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8483124 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23651

Requesting uplift for v2.1 polish.

[Bug caused by] (feature/regressing bug #): bug 1036339
[User impact] if declined: User will be unable to see and use the cancel button on the system sleep dialog
[Testing completed]: yes, manual and automated
[Risk to taking this patch] (and alternatives if risky): low, only dialogs that are of "action" and "object" types within the system app are affected. The only side affect could be differences in height calculations, again polish.
[String changes made]: n/a
Attachment #8483124 - Flags: approval-gaia-v2.1?
Hi Eli, Quick question, do I need to open bugs for each of these, or this is a general fix that resolved all? Thanks
https://bug1062722.bugzilla.mozilla.org/attachment.cgi?id=8483991
https://bug1062722.bugzilla.mozilla.org/attachment.cgi?id=8484000
https://bug1062722.bugzilla.mozilla.org/attachment.cgi?id=8484003
Flags: needinfo?(eperelman)
(Assignee)

Comment 11

4 years ago
Unfortunately not all of these issues are resolved with the same bugs:

Attachments 1 and 3 (bluetooth transfer) were resolved by bug 1058675.

I believe the remote debugging was resolved with this one. There are other bugs that resolved other SHB clippings.
Flags: needinfo?(eperelman)
Thanks, I found another one from Contacts when trying to add a photo to a contact, there is no related bug(bit.ly/1u5bMIM), I will open one.
Attachment #8483124 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Gaia-Rev        778ebac47554e1c4b7e9a952d73e850f58123914
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/aa98eb8873a2
Build-ID        20141005160206
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141005.194124
FW-Date         Sun Oct  5 19:41:35 EDT 2014
Bootloader      L1TC00011840
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::System]
Issue verified as fixed on Flame 2.1 & Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

With Software Home Button enabled no part of the sleep dialog screen is not covered by the SHB
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::System][QAnalyst-Triage?] → [COM=Gaia::System][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Flags: in-testsuite?
(Assignee)

Comment 16

4 years ago
Created attachment 8505046 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25152

Additional PR to add an integration test for feature patch.
Attachment #8505046 - Flags: review?(kgrandon)
Comment on attachment 8505046 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25152

Nice work!
Attachment #8505046 - Flags: review?(kgrandon) → review+
Test is now in master: https://github.com/mozilla-b2g/gaia/commit/71d06fdefc7c412af01e110078403e112e1d4181
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.