Closed Bug 1062017 Opened 5 years ago Closed 5 years ago

ParseStartAndEndTimestamps in WebMContainerParser returning invalid times for audio

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1061007

People

(Reporter: cajbir, Unassigned)

References

(Blocks 1 open bug, )

Details

I noticed this when running with mediasource:5 logging. Occasionally the start and end times reported during ParseStartAndEndTimestamps are large double values:

-1938024576[7fcb8b4455c0]: SourceBuffer(7fcb5609e060)::AppendData: Segment start=11606444744.652138 end=11606444746.199139

Found while doing playback of http://www.youtube.com/watch?v=3V7wWemZ_cs
Is this with bug 1061007 applied?  That should fix this.
(In reply to Matthew Gregan [:kinetik] from comment #1)
> Is this with bug 1061007 applied?  That should fix this.

Applying the patches in that bug did not fix it for me.
With inbound + this assert:

   double start, end;
   if (mParser->ParseStartAndEndTimestamps(aData, aLength, start, end)) {
+    MOZ_ASSERT(start < 7200 || end < 7200); // XXX hack to catch bug 1062017
     if (start <= mLastParsedTimestamp || mLastParsedTimestamp - start > 0.1) {

I hit the assert almost immediately with large bogus values.  With the patches in bug 1061007 applied, I don't hit the assert at all during playback of the linked video.

Can you please catch this in a debugger and paste the first 16 bytes from aData and the current state of mParser->mParser?
(In reply to Matthew Gregan [:kinetik] from comment #3)
> With inbound + this assert:
> 

I'll test again now that you've landed them. Possibly I made an error because I couldn't apply clean as mentioned in bug 1061007 comment 7.
Confirm fixed by bug 1061007.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061007
You need to log in before you can comment on or make changes to this bug.