Handle SourceBuffer appends that are not aligned on a random access point

RESOLVED FIXED in mozilla35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kinetik, Assigned: kinetik)

Tracking

(Blocks 1 bug)

Trunk
mozilla35
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

Assignee

Description

5 years ago
ContainerParser currently assumes that each append starts on a random access point (e.g. init segment or cluster) and contains a complete chunk.  That's not something that the spec requires so ContainerParser must be extended to handle non-aligned appends.

This is important right now because YouTube use this to append ~64kB chunks as a way of controlling the streaming rate of XmlHttpRequests.
Assignee

Comment 1

5 years ago
Posted patch wip (obsolete) — Splinter Review
Assignee

Comment 2

5 years ago
Attachment #8482014 - Attachment is obsolete: true
Attachment #8482184 - Flags: review?(cajbir.bugzilla)
Assignee

Comment 3

5 years ago
Same as before, but with cruft excluded.
Attachment #8482184 - Attachment is obsolete: true
Attachment #8482184 - Flags: review?(cajbir.bugzilla)
Assignee

Updated

5 years ago
Attachment #8482186 - Flags: review?(cajbir.bugzilla)
Assignee

Comment 4

5 years ago
Comment on attachment 8482186 [details] [diff] [review]
Handle unaligned appends by retaining WebM parser state across calls.  r=cajbir

Still has cruft.
Attachment #8482186 - Attachment is obsolete: true
Attachment #8482186 - Flags: review?(cajbir.bugzilla)

Updated

5 years ago
Attachment #8482188 - Flags: review?(cajbir.bugzilla) → review+
Assignee

Comment 6

5 years ago
Attachment #8482449 - Flags: review?(cajbir.bugzilla)

Comment 7

5 years ago
(In reply to Matthew Gregan [:kinetik] from comment #6)
> Created attachment 8482449 [details] [diff] [review]
> Only start new decoder on media segment boundary.

What does this patch apply on top of? I get conflicts with SourceBuffer.cpp in ParseStartAndEndTimestamps.

Updated

5 years ago
Attachment #8482449 - Flags: review?(cajbir.bugzilla) → review+

Updated

5 years ago
Duplicate of this bug: 1062017
https://hg.mozilla.org/mozilla-central/rev/478f4c80061a
https://hg.mozilla.org/mozilla-central/rev/57db771b7b9d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35

Updated

5 years ago
Blocks: 1041374

Updated

5 years ago
Blocks: 1040552

Updated

5 years ago
Depends on: 1067785
See Also: → 1124050
You need to log in before you can comment on or make changes to this bug.