The default bug view has changed. See this FAQ.

incorrect try submission summary email

RESOLVED FIXED

Status

Release Engineering
Tools
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: keeler, Assigned: poiru)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

I just pushed to try ( https://tbpl.mozilla.org/?tree=Try&rev=9166806dc1d3 ) and received a "thanks for your try submission" email. Unfortunately, it didn't have the correct summary. It should have said something like this:

Summary:
 * try: -b do -p macosx64,win32,linux32_gecko -u xpcshell -t none
 * bug 1057123 - mozilla::pkix: certificates with Key Usage asserting the keyCertSign bit may act as end-entities

Instead, it said:

Summary:
  * rm chromium debug utils 4 1 try: -b do -p all -u all -t none
  * Merge inbound to m-c. a=merge
  * Backed out changeset d5cd910dda69 (bug 1033098) for OSX assertions.
  * Bug 1061618 - Extend MOZ_UPDATER ifdef to fix blank pages on about:preferences. r=Gijs
  * Bug 1050214 - Add shuffle's masks constants to the SIMD object. r=bbouvier
  * Bug 1047101 - Provide a way to do data-driven tests with Marionette test runner. r=jgriffin
  * Bug 1032777 - Include base image version for Flame device. r=wlachance
  * Bug 992894 - Add xpcshell tests for the NativeFileWatcher. r=Yoric
  * Bug 992894 - Add a native file watcher component to notify about file/directory changes (Windows).
  * Bug 1061028 - IsInlineFrame() is a synonym for IsFrameOfType(nsIFrame::eLineParticipant) so it
  * Bug 1061027 - Remove bogus (and unnecessary) static_cast. r=roc
Those commits are from the previous push to try:
https://tbpl.mozilla.org/?tree=Try&rev=15f443714732
I think the initialization of the commit_titles etc. needs to be moved inside the loop here:

http://hg.mozilla.org/build/buildbotcustom/file/default/changes/hgpoller.py#l275

Updated

3 years ago
Blocks: 1048322
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1061359
(Assignee)

Comment 4

3 years ago
Created attachment 8483788 [details] [diff] [review]
Ignore commits from older pushes when gathering commit titles

This should (probably) do it.
Assignee: nobody → birunthan
Status: NEW → ASSIGNED
Attachment #8483788 - Flags: review?(catlee)
Will this fix the case in bug 1061359 where the additional commits mentioned in the email that shouldn't be there came from a *later* push?
Comment on attachment 8483788 [details] [diff] [review]
Ignore commits from older pushes when gathering commit titles

Review of attachment 8483788 [details] [diff] [review]:
-----------------------------------------------------------------

hm, I don't think this is right. We could legitimately be looking at multiple try pushes at once here, and so need to treat them separately.
Attachment #8483788 - Flags: review?(catlee) → review-

Updated

3 years ago
Duplicate of this bug: 1065112
FTR, the incorrect summary in my email came from newer pushes than mine.
Duplicate of this bug: 1064810

Updated

3 years ago
Duplicate of this bug: 1069052
(Assignee)

Comment 11

3 years ago
Created attachment 8492731 [details] [diff] [review]
Make commit titles push specific

(In reply to Cameron McCormack (:heycam) from comment #5)
> Will this fix the case in bug 1061359 where the additional commits mentioned
> in the email that shouldn't be there came from a *later* push?

This patch should handle that.
Attachment #8483788 - Attachment is obsolete: true
Attachment #8492731 - Flags: review?(catlee)

Updated

3 years ago
Duplicate of this bug: 1071304
:catlee, given the dev confusion caused by this bug since Bug 1048322 landed, and the many dupes generated, I'm starting to think we should backout 1048322 until we have the proper fix ready.

The idea is sound and a GOOD thing, but the current bugs make it more harmful than helpful imho. Agree/Disagree?
Flags: needinfo?(catlee)

Updated

3 years ago
Attachment #8492731 - Flags: review?(catlee) → review+
(In reply to Justin Wood (:Callek) from comment #13)
> :catlee, given the dev confusion caused by this bug since Bug 1048322
> landed, and the many dupes generated, I'm starting to think we should
> backout 1048322 until we have the proper fix ready.
> 
> The idea is sound and a GOOD thing, but the current bugs make it more
> harmful than helpful imho. Agree/Disagree?

I think the current patch should fix it. Let's see how that goes, and then re-evaluate then.
Flags: needinfo?(catlee)
(Assignee)

Comment 15

3 years ago
Comment on attachment 8492731 [details] [diff] [review]
Make commit titles push specific

https://hg.mozilla.org/build/buildbotcustom/rev/79649203c361
Attachment #8492731 - Flags: checked-in+
Merged to production, and deployed.
(Assignee)

Comment 17

3 years ago
This should be fixed now. Please reopen if the problem still exists.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.