The default bug view has changed. See this FAQ.

[tracker] windows build infrastructure issues

RESOLVED FIXED

Status

Release Engineering
Buildduty
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: arr, Assigned: jlund)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
This bug is to track the various issues/regressions impacting the windows 2008 build/try infrastructure.
(Reporter)

Updated

3 years ago
Depends on: 1062956
(Assignee)

Updated

3 years ago
Depends on: 1063018

Comment 1

3 years ago
Hypothesis is that most of these bugs relate back to interrupted VS 2013 installs. The install was a scheduled task that called a batch script this created a background process after the parent returned an error 0 exit which made it look like the install was down. However, several of the installs were running and then interrupted.  Leading to what looked like multiple version of 2013 being installed when in actuality the install was never complete so update 2 was never applied. This also explains why install processes were noted during some cases. Components by default are installed "on demand" when needed if they were skipped in the primary install this install process would account for the I/O spikes noted in some bugs as well as linking errors. This in turn why slave appeared to magically "fix" themselves since the VS components were installed during that "blip". There are still some unexplained I/O issues that occurred before and after the vs 2013 install. I believe those issues to be orthogonal in root but may have exacerbated the symptoms.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
No longer depends on: 1063018
You need to log in before you can comment on or make changes to this bug.