Touches the first row of the keyboard triggers click event on the underneath frame just resized

RESOLVED FIXED

Status

()

Core
Layout
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kthiessen, Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(b2g-v2.1 ?, b2g-v2.2 affected)

Details

(Whiteboard: DUPME)

(Reporter)

Description

4 years ago
Versions:
Gaia      52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko     https://hg.mozilla.org/mozilla-central/rev/5e9826980be5
BuildID   20140903072057
Version   35.0a1
ro.build.date   Fri Jun 27 15:57:58 CST 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   110

STR:
1. Open Firefox to https://twitter.com
2. Click 'Sign In'
3. Attempt to enter login and password

Expected:
1. Keyboard remains up while the text box is focussed.

Actual:
1. Keyboard disappears after one or two keystrokes, making login nearly impossible.
Rudy, you have a 2.1 build laying around? Don't have time today to dive into this.
Flags: needinfo?(rlu)
I've got several reports that are similar to this, and am thinking about this might be Gecko regression that caused the touch event passing through keyboard to the underlying web page.

I've heard that this would happen on facebook as well.

Mark this as regressionwindow-wanted to see if we could get QA's help.
blocking-b2g: --- → 2.2?
status-b2g-v2.2: --- → affected
Flags: needinfo?(rlu)
Keywords: regression, regressionwindow-wanted
status-b2g-v2.1: --- → ?
Duplicate of this bug: 1063320
I can reproduce this with Gaia v2.0 onto the Gecko master,

Gecko info
===============
Gecko     https://hg.mozilla.org/mozilla-central/rev/acbdce59da2f
BuildID   20140903160205
Version   35.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

So, I would suspect this is really a Gecko regression.
Yeah, whenever I touch the first role keyboard app reports lost of inputcontext.

(You can turn on keyboard console message by using App Manager and in the keyboard frame, do |app.console.LOG_LEVEL = 3|)

I can't inspect the Twitter frame so I can't tell if the frame receives a touch event. I am tempted to throw this to Core::Layout but I think we can put this bug under Keyboard for a few more day (so we don't lost track of it.)
Duplicate of this bug: 1062816
Right, by using Facebook app I can confirm Gecko is sending a click event to the underlining frame when we touching the first row.

STR:

1. Install Facebook app
2. Launch it.
3. Using App Manager to connect to it's debug console.
4. Use |window.addEventListener('click', console.log.bind(console));| to listen to the click event on the entire document.
5. Tap on the Password field.
6. Tap the "Q" key on the keyboard

Expected:

1. Typing q

Actual:

1. <li> on the Facebook page receives a click event.

click { target: <li>, buttons: 0, clientX: 12, clientY: 308, layerX: 12, layerY: 265 }

I am just going to throw it to Core::Layout so it could receive some attention in time. There is nothing Keyboard app can do for now.
Component: Gaia::Keyboard → Layout
Product: Firefox OS → Core
Update title to be more descriptive.

I am actually quite puzzled since we do resize the app frame after the keyboard is shown, so it shouldn't be really "underneath".
Summary: [Flame][v2.1] keyboard disappears during text input into Firefox → Touches the first row of the keyboard triggers click event on the underneath frame just resized

Comment 9

4 years ago
Regression range would be really useful here.
QA Contact: rpribble
I am able to reproduce this issue on the reporter's build with 100% repro rate, but am unable to reproduce it on today's Flame v2.2 build (0/10 repro rate).

----------------------------------------

The issue DOES reproduce on the reported Flame v2.2 build.
 
Device: Flame 2.2 Master
BuildID: 20140903072057
Gaia: 52670853c17fc0d3d33065c667c0ce124c93b98f
Gecko: 5e9826980be5
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Keyboard disappears after one or two keystrokes, making login nearly impossible.

----------------------------------------

The issue DOES NOT reproduce on today's Flame v2.2.

Device: Flame 2.2 Master
BuildID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Keyboard remains up while the text box is focussed.
Flags: needinfo?(jmitchell)
reporter - can you check and see if you can repro this in the latest build? possibly a resolved:works-for-me issue
Flags: needinfo?(jmitchell) → needinfo?(kthiessen)
Keywords: regressionwindow-wanted
(Reporter)

Comment 12

4 years ago
I will flash the latest build and report back sometime before EOD Pacific time today.
(Reporter)

Comment 13

4 years ago
Versions;
Gaia      5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko     https://hg.mozilla.org/mozilla-central/rev/dddbe46f3ceb
BuildID   20140905040204
Version   35.0a1
ro.build.date   Fri Jun 27 15:57:58 CST 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   110

With this version, I do not observe the bug,  Many thanks to :rpribble for fast and well-articulated response.

I will resolve this as WORKSFORME, but if this also fixes the issue for the Facebook app in comment 7 above, I would urge RESOLVED/FIXED.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(kthiessen)
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → ---
I am unable to reproduce this bug after updating to 20140907160202.
Resolution: WORKSFORME → FIXED
Whiteboard: DUPME
Duplicate of this bug: 1063777
You need to log in before you can comment on or make changes to this bug.