crash in java.lang.IllegalArgumentException: Wifi:Enable was not registered at org.mozilla.gecko.EventDispatcher.unregisterListener(EventDispatcher.java)

VERIFIED FIXED in Firefox 34

Status

()

defect
--
critical
VERIFIED FIXED
5 years ago
Last year

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({crash, topcrash})

35 Branch
Firefox 35
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 unaffected, firefox33 unaffected, firefox34+ verified, firefox35 verified, fennec34+)

Details

(crash signature)

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-77fef11d-cf73-410f-a963-41be42140904.
=============================================================

java.lang.IllegalArgumentException: Wifi:Enable was not registered
	at org.mozilla.gecko.EventDispatcher.unregisterListener(EventDispatcher.java:101)
	at org.mozilla.gecko.EventDispatcher.unregisterGeckoThreadListener(EventDispatcher.java:133)
	at org.mozilla.gecko.GeckoNetworkManager.destroy(GeckoNetworkManager.java:44)
	at org.mozilla.gecko.GeckoApp.onDestroy(GeckoApp.java:2080)
	at org.mozilla.gecko.BrowserApp.onDestroy(BrowserApp.java:1038)
	at android.app.Activity.performDestroy(Activity.java:5370)
	at android.app.Instrumentation.callActivityOnDestroy(Instrumentation.java:1124)
	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3324)
	at android.app.ActivityThread.handleDestroyActivity(ActivityThread.java:3355)
	at android.app.ActivityThread.access$1300(ActivityThread.java:140)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1290)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4921)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1027)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:794)
	at dalvik.system.NativeStart.main(Native Method)

Comment 1

5 years ago
I just did get that crash when I unplugged my USB OTG keyboard from my Nexus 10 tablet. bp-076a5822-d8b2-4c8e-8fdf-79b4e2140906
Just tagging this as a topcrash since it currently shows up as #1 in Nightly @ 12%
Keywords: topcrash
tracking-fennec: ? → 34+
Reporter

Updated

5 years ago
Status: NEW → ASSIGNED
Reporter

Comment 3

5 years ago
Seems like a sure way to reproduce this is in CyanogenMod's app switcher as comments suggest.

> crashes every time I switch away from nightly
> not playing nice with the current cyanogenmod nightly's "alt tab switcher"
I can reproduce this crash with the following steps:

1. enable "don't keep activities"
2. open firefox 
3. go to settings
4. tap the back button
5. go to settings again

firefox crashes: https://crash-stats.mozilla.com/report/index/11902a60-f90a-4f1b-bd59-a867f2140925
Assignee

Comment 5

5 years ago
Posted file newNull (obsolete) —
Assignee

Comment 6

5 years ago
Posted patch newNullSplinter Review
Assignee

Comment 7

5 years ago
Comment on attachment 8495479 [details] [diff] [review]
newNull

Argh. OSX is defeating me. We moved this registration to happen on creation/deletection of the singleton, but we never destroy the singleton. Now we do.
Attachment #8495479 - Flags: review?(mark.finkle)
Assignee

Updated

5 years ago
Attachment #8495478 - Attachment is obsolete: true
Comment on attachment 8495479 [details] [diff] [review]
newNull

># HG changeset patch
># Parent 20df6ea0e84bdf0037c84a03c44a3ec6a9886c6a
># User wesj <wjohnston@mozilla.com>
>
>diff --git a/mobile/android/base/GeckoNetworkManager.java b/mobile/android/base/GeckoNetworkManager.java

>+
> /* -*- Mode: Java; c-basic-offset: 4; tab-width: 4; indent-tabs-mode: nil; -*-

Is this new blank line needed? Or will it break the mode line?
Attachment #8495479 - Flags: review?(mark.finkle) → review+
Reporter

Updated

5 years ago
Attachment #8495479 - Attachment is patch: true
(In reply to Wesley Johnston (:wesj) from comment #7)
> Comment on attachment 8495479 [details] [diff] [review]
> newNull
> 
> Argh. OSX is defeating me. We moved this registration to happen on
> creation/deletection of the singleton, but we never destroy the singleton.
> Now we do.

Drive-by: do we recreate the singleton when the activity comes back?
Assignee

Comment 10

5 years ago
All calls go through getInstance() which recreates it. They are all on the UI thread.
https://hg.mozilla.org/mozilla-central/rev/eafd15b593cf
Assignee: nobody → wjohnston
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Wes - This needs an uplift to Fx34, where it's the #1 crasher.
Flags: needinfo?(wjohnston)
Assignee

Comment 14

5 years ago
Comment on attachment 8495479 [details] [diff] [review]
newNull

Approval Request Comment
[Feature/regressing bug #]: Wifi toggle on error pages
[User impact if declined]: Crash when switching between apps
[Describe test coverage new/current, TBPL]: I'm actually a little surprised tests didn't catch this, since they often open Settings and switch back and forth, but they don't have Dont keep Activities set. Hard to test.
[Risks and why]: Caused a regression in bug 1074189. Simple fix there. I think this is pretty low risk.
[String/UUID change made/needed]: none.
Attachment #8495479 - Flags: approval-mozilla-aurora?
Flags: needinfo?(wjohnston)
Comment on attachment 8495479 [details] [diff] [review]
newNull

Aurora+

wesj - Does this crash occur on 33 as well? If so, we can take the fix in beta 10 (go to build on Mon, Oct 6, 2014).
Attachment #8495479 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(wjohnston)
Assignee

Comment 16

5 years ago
This feature landed in 34. 33 should be fine :)
Flags: needinfo?(wjohnston)
Based on my steps from comment #4 I am not able to reproduce this crash on latest Nightly (01-10-2014) using Samsung Galaxy S5 (Android 4.4.2).
Verified as fixed using steps from comment #4.
Build: Firefox for Android 34 Beta 2
Device: Asus Transformer Pad TF300T (Android 4.2.1)
Status: RESOLVED → VERIFIED
Reporter

Updated

5 years ago
Duplicate of this bug: 1088952
Flags: qe-verify+
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.