If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in java.lang.NullPointerException: at org.mozilla.gecko.GeckoApplication.onActivityResume$642b2292(GeckoApplication.java)

VERIFIED FIXED in Firefox 34

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({crash})

35 Branch
Firefox 35
All
Android
crash
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox34+ verified, firefox35 verified, fennec34+)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-dca990ac-c5ea-4e3a-9811-924de2140928.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApplication.onActivityResume$642b2292(GeckoApplication.java:113)
	at org.mozilla.gecko.GeckoActivity.onResume(GeckoActivity.java:38)
	at org.mozilla.gecko.GeckoApp.onResume(GeckoApp.java:1853)
	at org.mozilla.gecko.BrowserApp.onResume(BrowserApp.java:755)
	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1192)
	at android.app.Activity.performResume(Activity.java:5310)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2802)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2841)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2276)
	at android.app.ActivityThread.handleRelaunchActivity(ActivityThread.java:3762)
	at android.app.ActivityThread.access$900(ActivityThread.java:144)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1211)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:136)
	at android.app.ActivityThread.main(ActivityThread.java:5146)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:732)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:566)
	at dalvik.system.NativeStart.main(Native Method)

Sudden surge of crashes with onActivityResume over the weekend
(Assignee)

Comment 1

3 years ago
Created attachment 8497071 [details] [diff] [review]
Patch

jchen tried to warn me here. I'm not sure why I didn't check this.
Attachment #8497071 - Flags: review?(mark.finkle)
Attachment #8497071 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 1074188
Blocks: 1061030
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/85ca6a8ab234
https://hg.mozilla.org/mozilla-central/rev/85ca6a8ab234
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
(Assignee)

Comment 5

3 years ago
Comment on attachment 8497071 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1063541
[User impact if declined]: Fixes a crash when switching back and forth between apps (in some cases)
[Describe test coverage new/current, TBPL]: Really hard to test (need to kill/restart activities) during tests.
[Risks and why]: Low risk. Makes this lazy loader work.
[String/UUID change made/needed]: none.
Attachment #8497071 - Flags: approval-mozilla-aurora?
status-firefox34: --- → affected
status-firefox35: affected → fixed
tracking-firefox34: --- → +
Comment on attachment 8497071 [details] [diff] [review]
Patch

Given that this is really hard to test and bug 1063541 will be uplifted shortly, let's take this on Aurora now. Aurora+
Attachment #8497071 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/33ccccf7550b
status-firefox34: affected → fixed
Duplicate of this bug: 1074187
tracking-fennec: ? → 34+
Assuming verified fixed since there have been 0 reports of this crash in the last week.
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.