Last Comment Bug 106387 - Tabs : <tab> does not observe disabled state
: Tabs : <tab> does not observe disabled state
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: ---
Assigned To: jag (Peter Annema)
:
: Neil Deakin
Mentors:
: 360233 368069 (view as bug list)
Depends on: 370742
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 20:00 PDT by Brian King [:kinger]
Modified: 2007-03-30 07:47 PDT (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to disable opening of tab if disabled (1.21 KB, patch)
2001-10-24 07:22 PDT, Andrew Simmonds
no flags Details | Diff | Splinter Review

Description Brian King [:kinger] 2001-10-23 20:00:08 PDT
Setting the disabled state (attribute) on a tab does not act as I would expect.

Current behaviour:
The tab text will dull, and the onfocus event will not be executed. However, it
will still switch to the tab and display the tabpanel contents.

Expected behaviour:
Dulling of text, non-execution of code and not allowing the tabpanel to be
displayed.

Assigning to hewitt as per hyatt's request.
Comment 1 Andrew Simmonds 2001-10-24 07:22:44 PDT
Created attachment 54861 [details] [diff] [review]
patch to disable opening of tab if disabled
Comment 2 Thomas 2004-10-23 06:19:21 PDT
question: how can one put a tab as disabled?
I only see close tab, close other tab, new tab, bookmark this group of tabs,
reload tab, reload all tabs.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Comment 3 Darin Fisher 2005-04-28 23:05:33 PDT
Thomas: XUL is intended as a toolkit for building applications, and those
applications may have other uses for tabs besides just what Mozilla browsers
expose ;-)

This patch looks pretty reasonable to me, but I'd need to further study other
bindings to ensure that this is implementing the disabled property in a
consistent manner.
Comment 4 Darin Fisher 2005-04-28 23:10:24 PDT
Reassigning to me so that this is at least on my radar.
Comment 5 neil@parkwaycc.co.uk 2005-04-29 08:59:08 PDT
The patch does nothing to address keyboard navigation between tabs.
Comment 6 Darin Fisher 2005-04-29 13:47:52 PDT
> The patch does nothing to address keyboard navigation between tabs.

Neil, thanks for the info.  Do you have time to revise the patch?
Comment 7 Darin Fisher 2006-02-24 16:49:39 PST
-> default owner
Comment 8 Brian King [:kinger] 2006-05-25 15:25:17 PDT
I'd say this patch has bit-rotted a bit. Anyone interested in me making another one?
Comment 9 Neil Deakin 2006-11-16 15:16:14 PST
*** Bug 360233 has been marked as a duplicate of this bug. ***
Comment 10 Pete Morgan 2007-01-06 00:18:53 PST
Can confirm this bug is still here FIVE YEARS after first report.

Tabs recieve focus whether they are disabled by property or attribute.

Maybe the next decade will bring a fix ;-)
Comment 11 Pete Morgan 2007-01-07 15:46:39 PST
Here are the other related bugs I found to the XUL tab.

https://bugzilla.mozilla.org/show_bug.cgi?id=366116
https://bugzilla.mozilla.org/show_bug.cgi?id=261826
https://bugzilla.mozilla.org/show_bug.cgi?id=307088

Affected are the hidden, disabled attributes/properties as well as the ordering of tabs.

Comment 12 Alex Vincent [:WeirdAl] 2007-01-25 15:39:20 PST
*** Bug 368069 has been marked as a duplicate of this bug. ***
Comment 13 Alex Vincent [:WeirdAl] 2007-01-25 15:46:04 PST
requesting blocking1.9; this bug is ancient, relatively easy to fix (good first bug), and useful for Gecko app developers and extension developers.
Comment 14 Neil Deakin 2007-02-19 05:47:16 PST
Fixed by bug 370742

Note You need to log in before you can comment on or make changes to this bug.