Closed Bug 1064386 Opened 9 years ago Closed 8 years ago

Find the optimal panel order position for Synced Tabs

Categories

(Firefox for Android Graveyard :: General, defect, P5)

35 Branch
All
Android
defect

Tracking

(fennec+)

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: aaronmt, Unassigned)

References

Details

(Keywords: uiwanted, ux-efficiency)

Currently it takes more effort to reach the new Synced Tabs panel than with the older tabs pane.

Old: Tabs button, 'Sync' pane (2 taps) 
New: (assuming sitting on Top-Sites), 3 swipes to reach the pane

We should not regress in the effort it takes to reach the same items.

Maybe 'Synced Tabs' should swap with 'Recent Tabs'. Can order be decided through use backed with telemetry data? Which the optimal position?
Pretty sure this is a special case of an over-arching UX issue that we've exacerbated by adding panels.

Fixing this for Synced Tabs (which, yes, fixes this tap-count regression) is only going to screw a different panel.

Say you're a Sync user, you use Top Sites, Recent Tabs, Reading List, occasionally access your history and bookmarks, use the Pocket panel, …

Even with Top Sites disabled, I have *seven* panels. Practically speaking that means I never see content that I want to see.

A 'pager' approach doesn't really scale -- you can't swipe more quickly to sling to the end, there's no spatial memory, and so you're limited to one panel you can see, and two you can get to quickly.

Compare and contrast to the Windows 8 tiles UI, where you can sling, scroll, and otherwise navigate a ribbon that's larger than your screen, but fixed in space.
Hardware: ARM → All
(In reply to Aaron Train [:aaronmt] from comment #0)
> Can order be decided
> through use backed with telemetry data? Which the optimal position?

I think the answer to this, btw, is "no".

We'd get the long tail effect: panels that are easier to reach will be used more often. Presumably lots of our users don't even realize they can swipe between panels.

We *could* get a measure of which features users were so annoyed about that they found the settings page and reordered panels (I think that hits UI telem), but I imagine that's way smaller than the set of users who either live with it or find a different browser.

How many users just say "I can't find my open tabs from my laptop; this browser is stupid, Firefox Sync sucks"? They don't show up in telemetry.
I just talked with Chenxia and the idea of surfacing Home Panel customization was brought up. 

If we can surface the customization entry of Home Panel on Home Page or prompt our users with a contextual hint to help them take better advantage of the panels, it would be a great improvement.

Ideally, that would also be the place to recommend addons that are made for home panels, for example Pocket feeds, RSS, etc. And I think Robin has been putting thoughts on that with the "Settings" project.
Yuan - We need some plan or vision for how to handle the ever growing list of panels.
Assignee: nobody → ywang
tracking-fennec: ? → +
See also bug 978306.
Depends on: 978306
filter on [mass-p5]
Priority: -- → P5
antlam, can you take a look at this?

Right now we just add the synced tabs panel to the left-most position on phones, and the right-most position on tablets. Do we want to change this before we ship this new panel? If not, we should just close this bug, and we can focus on the many-panel UX in another bug.
Assignee: ywang → nobody
Flags: needinfo?(alam)
I think the left-most position makes the most sense. Is there a reason why it's different for Tablets?
Flags: needinfo?(alam)
(In reply to Anthony Lam (:antlam) from comment #9)
> I think the left-most position makes the most sense. Is there a reason why
> it's different for Tablets?

The order has always been different on tablets, since we focus the left-most panel to start with, as opposed to the center. So we always have top-sites farthest to the left.
(In reply to :Margaret Leibovic from comment #10)
> (In reply to Anthony Lam (:antlam) from comment #9)
> > I think the left-most position makes the most sense. Is there a reason why
> > it's different for Tablets?
> 
> The order has always been different on tablets, since we focus the left-most
> panel to start with, as opposed to the center. So we always have top-sites
> farthest to the left.

Ah, I see. It makes sense to start unifying these default orders so it's less confusing. Unless there's a compelling reason why we shouldn't ?

Could we slip "Synced Tabs" in there (left most) for Tablets too? I can't remember when I first used these panels but I've customized mine to start from the second panel (History) while "Top sites" is the first one (on the leftest). It seems to work pretty well.
Friendly ping on the status here.. I think defaulting to have Synced Tabs Panel on the far left across Mobile and Tablet would close this bug.
Flags: needinfo?(margaret.leibovic)
(In reply to Anthony Lam (:antlam) from comment #12)
> Friendly ping on the status here.. I think defaulting to have Synced Tabs
> Panel on the far left across Mobile and Tablet would close this bug.

Currently on tablets we have "Top Sites" as the left-most panel, and it's also the default panel.

I think the reason for the difference between the tablet and phone configurations is that we wanted the default to be at the far left on tablets, so adding a new panel to the left of the default would defeat the purpose of that.

If we want to make "Synced Tabs" the left-most panel, we'll need to reconsider our approach to panel ordering on tablets.
Flags: needinfo?(margaret.leibovic)
(In reply to :Margaret Leibovic from comment #13)
> (In reply to Anthony Lam (:antlam) from comment #12)
> > Friendly ping on the status here.. I think defaulting to have Synced Tabs
> > Panel on the far left across Mobile and Tablet would close this bug.
> 
> Currently on tablets we have "Top Sites" as the left-most panel, and it's
> also the default panel.
> 
> I think the reason for the difference between the tablet and phone
> configurations is that we wanted the default to be at the far left on
> tablets, so adding a new panel to the left of the default would defeat the
> purpose of that.
> 
> If we want to make "Synced Tabs" the left-most panel, we'll need to
> reconsider our approach to panel ordering on tablets.

I think moving the "Synced Tabs" panel to the far right OR left requires us to reconsider the default order entirely. I've filed bug 1139672 for that.

By defaulting the "Synced Tabs" to the left, I want to at least keep that part consistent with Mobile. It's also worth mentioning that far right on a Nexus 7 (for example), is off screen in Portrait.
thoughts?
Flags: needinfo?(margaret.leibovic)
(In reply to Anthony Lam (:antlam) from comment #14)
> (In reply to :Margaret Leibovic from comment #13)
> > (In reply to Anthony Lam (:antlam) from comment #12)
> > > Friendly ping on the status here.. I think defaulting to have Synced Tabs
> > > Panel on the far left across Mobile and Tablet would close this bug.
> > 
> > Currently on tablets we have "Top Sites" as the left-most panel, and it's
> > also the default panel.
> > 
> > I think the reason for the difference between the tablet and phone
> > configurations is that we wanted the default to be at the far left on
> > tablets, so adding a new panel to the left of the default would defeat the
> > purpose of that.
> > 
> > If we want to make "Synced Tabs" the left-most panel, we'll need to
> > reconsider our approach to panel ordering on tablets.
> 
> I think moving the "Synced Tabs" panel to the far right OR left requires us
> to reconsider the default order entirely. I've filed bug 1139672 for that.
> 
> By defaulting the "Synced Tabs" to the left, I want to at least keep that
> part consistent with Mobile. It's also worth mentioning that far right on a
> Nexus 7 (for example), is off screen in Portrait.

I don't think that doing this half-way is really worth it, both from a UX and an engineering perspective. If we're going to change the placement of the Synced Tabs panel, I think we might as well just adjust the placement of all of them. We can figure that out in bug 1139672.
Flags: needinfo?(margaret.leibovic)
Accidentally ran into this bug. Anthony, now with "scrollable tabs" and the new tab order. Is this bug still relevant?
Flags: needinfo?(alam)
I think bug 1139672 covers this.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(alam)
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.