Closed Bug 1064401 Opened 7 years ago Closed 7 years ago

Disable overscrolling completely for 2.0

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0+
Tracking Status
firefox33 --- wontfix
firefox34 --- wontfix
firefox35 --- wontfix
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- wontfix
b2g-v2.2 --- wontfix

People

(Reporter: botond, Assigned: botond)

References

Details

Attachments

(3 files, 1 obsolete file)

Bug 1055361 disabled the original overscroll effect (zooming out) during panning for 2.0, leaving it in place during a fling.

Bug 1057578 introduced a new effect (stretching) for 2.1 for both panning and flinging.

To maintain a consistent user experience across releases, for 2.0 we would like to disable the zoom effect during flinging as well.
Attached patch Flip the pref in b2g.js (obsolete) — Splinter Review
Attachment #8485838 - Flags: review?(bugmail.mozilla)
This would be b2g32 only change - we do not want it in a later repo...
Attachment #8485838 - Flags: review?(bugmail.mozilla) → review+
Yeah, according to https://wiki.mozilla.org/Release_Management/B2G_Landing#Landing_Procedure_3 you need to request approval for b2g32 and then land on that branch directly.
Comment on attachment 8485838 [details] [diff] [review]
Flip the pref in b2g.js

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 1055361.

User impact if declined: 
  User sees different overscroll effect in 2.0 than 2.1,
  leading to an inconsistent user experience.

Testing completed: 
  Locally.

Risk to taking this patch (and alternatives if risky): 
  Low - we're just flipping a pref.

String or UUID changes made by this patch:
  None.
Attachment #8485838 - Flags: approval-mozilla-b2g32?
I just realized, overscrolling has an entry in the developer options, so the pref needs to be changed in additional places.
Attachment #8485838 - Attachment is obsolete: true
Attachment #8485838 - Flags: approval-mozilla-b2g32?
Attachment #8485890 - Flags: review?(bugmail.mozilla)
Attachment #8485891 - Flags: review?(bugmail.mozilla)
(In reply to Botond Ballo [:botond] from comment #5)
> I just realized, overscrolling has an entry in the developer options, so the
> pref needs to be changed in additional places.

This also raises the question of whether we want to, perhaps, remove the developer option from 2.0 altogether.
I'd leave it, we have a lot of developer options that are not for general consumption...
Attachment #8485890 - Flags: review?(bugmail.mozilla) → review+
Comment on attachment 8485891 [details] [diff] [review]
Flip the pref (gaia portion)

Review of attachment 8485891 [details] [diff] [review]:
-----------------------------------------------------------------

You'll need to make a PR against gaia 2.0 to get this landed.
Attachment #8485891 - Flags: review?(bugmail.mozilla) → review+
Comment on attachment 8485890 [details] [diff] [review]
Flip the pref (gecko portion)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 1055361.

User impact if declined: 
  User sees different overscroll effect in 2.0 than 2.1,
  leading to an inconsistent user experience.

Testing completed: 
  Locally.

Risk to taking this patch (and alternatives if risky): 
  Low - we're just flipping a pref.

String or UUID changes made by this patch:
  None.
Attachment #8485890 - Flags: approval-mozilla-b2g32?
Comment on attachment 8485891 [details] [diff] [review]
Flip the pref (gaia portion)

[Approval Request Comment]
See above. The two patches go together.
Attachment #8485891 - Flags: approval-mozilla-b2g32?
We should probably block to make sure we don't add something to the product then change it and also just to be 100% safe on the legal side.
blocking-b2g: --- → 2.0+
Comment on attachment 8485890 [details] [diff] [review]
Flip the pref (gecko portion)

Adding verifyme for QA to ensure overscrolling in 2.0 is disabled after this lands.
Attachment #8485890 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+
Attachment #8485891 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+
checkin-needed for gecko and gaia patches, for B2G 2.0 only - thanks!
Keywords: checkin-needed
(In reply to Botond Ballo [:botond] from comment #14)
> Pull request for the Gaia patch:

Sorry, here is the correct link: https://github.com/mozilla-b2g/gaia/pull/24009
Attached video video
This issue has been successfully verified on Flame 2.0 and woodduck 2.0
Verify steps:
1. Launch Browser and link any website (ex. www.nba.com).
2. Tap a news to read.
3. Zoom in the webpage.
4. Fling the webpage.
** The zoom effect during flinging is disabled.
See attachment: 1064401_video.MP4
Reproducing rate: 0/5
Flame2.0 build:
Gaia-Rev        1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/faa64077b0c2
Build-ID        20141119000207
Version         32.0

Woodduck 2.0 biuld:
Gaia-Rev        cc690f8016b672475dc186bc7fd58aef45e684b7
Gecko-Rev       03d3ab62d5b07b915434f2d1d68495ad5915ecd2
Build-ID        20141118184148
Version         32.0
Blocks: Woodduck
You need to log in before you can comment on or make changes to this bug.