Cannot add additional lwthemes to SeaMonkey (NB. I already have 30) and Thunderbird

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({regression})

Details

(URL)

Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32a1 ID:20140908103901 c-c:a8b23b49d30f m-c:2255d7d187b2

Cannot add lwthemes to SeaMonkey

Reproducible: Every time.

Steps to Reproduce:
1. Browse to https://addons.mozilla.org/themes/ or any of its subpages.
2. Hover the mouse over a lwtheme thumbnail.
-- The theme under the mouse is not displayed over the browser chrome (chrome background doesn't change)
-- No "Install" link in the thumbnail's bottom-left corner.
3. Click the thumbnail to go to the lwtheme's individual page.
4. Click the green button, "Add to SeaMonkey".
-- Nothing happens.

Actual results:
See above, lines starting --

Expected results:
- Thumbnails should temporarily clothe the chrome on mouseover
- They should have an install link at bottom left
- The green addon-install button should work.

Additional info:
1. I'm not sure in which Product/Component this bug belongs. CC-ing Unfocused for Add-ons Manager and Neil for SeaMonkey UI.
2. The bug appeared after I added arianny02 (created 2014-08-19) and before I came around to try and add littlepink (created 2014-09-01)
3. I was on holiday with no computer from 2014-08-25 to 2014-08-31.
4. I already have 30 lwthemes installed. Before this bug started, I could add additional ones at the expense of losing the least recently used ones which were in excess of 30.
5. Lightweight Theme Manager extension is installed but the problem happens even in Safe Mode.
The build used in comment #0 was from https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-central-linux64/?C=M;O=D but the following (latest) "official" L64 nightly from ftp.m.o. also has the bug:

Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32a1 ID:20140903003005 c-c:4f47656aa273 m-c:e58842c764dd

Comment 2

3 years ago
Evaluating the following bookmark

javascript:void(document.getElementByClassName("install")[0].dispatchEvent(new Event("InstallBrowserTheme",{bubbles:true})))

(barring typos) does cause the theme to be installed.

There are also three errors in the Error Console that might be related.

NS_ERROR_FAILURE
z.button is undefined
$(...).installButton is not a function

(The source is minified so there's no point trying to link to it.)
(In reply to neil@parkwaycc.co.uk from comment #2)
> Evaluating the following bookmark
> 
> javascript:void(document.getElementByClassName("install")[0].
> dispatchEvent(new Event("InstallBrowserTheme",{bubbles:true})))
> 
> (barring typos) does cause the theme to be installed.
> 
> There are also three errors in the Error Console that might be related.
> 
> NS_ERROR_FAILURE
> z.button is undefined
> $(...).installButton is not a function
> 
> (The source is minified so there's no point trying to link to it.)

Clicking that bookmarklet on a lightweight-theme page (e.g. https://addons.mozilla.org/en-us/seamonkey/addon/littlepink/ ) does nothing for me, even when the current complete theme is Default, and that whether or not in Safe Mode. I'm pasting the bookmarklet here from my Bookmarks Manager for comparison, using the clipboard:

javascript:void(document.getElementByClassName("install")[0].dispatchEvent(new%20Event("InstallBrowserTheme",{bubbles:true})))

Current browser build:
Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32a1 ID:20140913003005 c-c:b3e999a72882 m-c:59d4326311e0
downloaded today from ftp.mozilla.org



Related with bug 1055371 ?

Comment 4

3 years ago
Thunderbird Daily also has this problem:
http://forums.mozillazine.org/viewtopic.php?f=29&t=2871053

With the same error messages:

Error: TypeError: z.button is undefined
Source file: https://addons.mozilla.org/en-US/thunderbird/addons/buttons.js?b=f67ccea-541b4367
Line: 14
 ----------
Error: TypeError: $(...).installButton is not a function
Source file: https://addons.cdn.mozilla.net/static/js/common-min.js?build=f67ccea-541b4367
Line: 4
 ----------
Error: NS_ERROR_FAILURE: 
Source file: https://addons.cdn.mozilla.net/static/js/common-min.js?build=f67ccea-541b4367
Line: 4

Updated

3 years ago
Summary: Cannot add additional lwthemes to SeaMonkey (NB. I already have 30) → Cannot add additional lwthemes to SeaMonkey (NB. I already have 30) and Thunderbird

Comment 5

3 years ago
I've narrowed the regression range down slightly to
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dc23164ba2a2&tochange=150cdebe837f
Unfortunately comm-central was busted for most of that range.

Comment 6

3 years ago
It turns out there's more than one bug.

The first one is in the above regression. Trying to access navigator.mozApps throws NS_ERROR_FACTORY_NOT_REGISTERED. This is because AppsServiceChild.jsm is trying to access Webapps.jsm which hasn't been loaded because nobody told us how. This fixes my August 01 build. However, trunk is still busted because of another error which unhelpfully is just NS_ERROR_FAILURE.

CCing some people who might know about about navigator.mozApps.

Comment 7

3 years ago
Just importing Webapps.jsm somewhere seems to fix Aurora builds, but I don't know whether that's the right fix.
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 9

3 years ago
(In reply to comment #6)
> The first one is in the above regression. Trying to access navigator.mozApps
> throws NS_ERROR_FACTORY_NOT_REGISTERED. This is because AppsServiceChild.jsm
> is trying to access Webapps.jsm which hasn't been loaded because nobody told
> us how. This fixes my August 01 build. However, trunk is still busted
> because of another error which unhelpfully is just NS_ERROR_FAILURE.
The unhelpful change in error code is down to the switch to webidl.

Trunk might be more sensitive to the time at which you load Webapps.jsm; I can't remember whether I tried accessing navigator.mozApps both before and after loading Webapps.jsm on aurora but that doesn't work on trunk.

Firefox loads Webapps.jsm indirectly though WebappManager.jsm which itself is loaded lazily by the browser glue via a final ui startup lazy module getter.
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33a1 ID:20141015003005 c-c:06b9b65bc279 m-c:62f0b771583c

The problem has disappeared.

The "+ Add" button has reappeared on mouseover on the AMO thumbnails, and clicking "Add to SeaMonkey" on the page for any particular lwtheme adds it again to the browser collection, and enables it either immediately (if the current complete theme is explicitly or implicitly SeaMonkey Default) or at next restart (if another complete theme is active).

Temporarily wearing a lightweight theme before installing it (by appropriate mouse placement) is also back.
This looks as if it is down to a change on the AMO site (presumably to stop accessing navigator.mozApps) - I visited the AMO site offline to verify that I was using a build affected by the bug, and then I went online and reloaded the page and it started working.

Updated

3 years ago
See Also: → bug 1070496
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME

Comment 12

3 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #10)

> Temporarily wearing a lightweight theme before installing it (by appropriate
> mouse placement) is also back.
This bit isn't working for me.
(In reply to Philip Chee from comment #12)
> (In reply to Tony Mechelynck [:tonymec] from comment #10)
> 
> > Temporarily wearing a lightweight theme before installing it (by appropriate
> > mouse placement) is also back.
> This bit isn't working for me.

Strange… For me it works with any underlying complete theme; I've tested it most on Default and EarlyBlue.

I have the "Lightweight Theme Manager" extension installed, but I don't expect it to make a difference in this respect. Also, I am on Linux64 but isn't the addons manager platform-agnostic (XUL or something)?

Sometimes I have to wait a substantial amount of time (minutes) after hovering the mouse over a lightweight theme thumbnail, before it appears in the chrome. Moving the mouse on and off the thumbnail (while watching the mouse pointer alternate between "pointing hand" and "NW arrow" shapes) helps.
Philip: see also bug 1008178 about intermittent failure to wear a Persona/lwtheme on mouseover
Keywords: regressionwindow-wanted
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.