Closed Bug 1065541 Opened 7 years ago Closed 7 years ago

UI flashes "Unknown revision id" when initially loading page & message isn't accurate for when no params set

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wlach, Assigned: KWierso)

References

Details

Attachments

(1 file)

After bug 1048043 landed, I now see an "Unknown revision id" flash on my screen when initially loading treeherder. That's a bit disconcerting to me.
Or for that matter it stays on permanently if I load this url:

https://treeherder.allizom.org/ui/#/jobs?repo=gaia-v1_4
OS: Linux → All
Priority: -- → P2
Hardware: x86_64 → All
(In reply to William Lachance (:wlach) from comment #1)
> Or for that matter it stays on permanently if I load this url:
> 
> https://treeherder.allizom.org/ui/#/jobs?repo=gaia-v1_4

And also for:
https://treeherder.allizom.org/ui/#/jobs?repo=build-system

The two issues here:
1) The message is shown before the page has completed loading.
2) The message is shown even if no revision param was specified, and the wording is inaccurate for anything other than the &revision=foo pages. This overlaps with bug 1042751 - since we *do* want to show something if there are no result sets shown - just not this specific message. So let's just have two separate messages depending on whether a revision param was specified.
This changes the unknown revision ID error message so it only appears if the page is not loading jobs and a revision was specified in the location search parameters.

It also adds two other error messages for some other failure cases.

When no revision is specified and no resultsets are returned for a given (known) repository, the error message will say that no commit information could be loaded for that repository (and give a link to the repository's URL as specified in the repository model in treeherder-service).

When no revision is specified and no resultsets are returned for a given (unknown) repository, the error message will say that Treeherder doesn't know about that repository, and includes a link to file a Treeherder bug to get the repository added to the model if it really should exist.
Attachment #8487495 - Flags: review?(cdawson)
Attachment #8487495 - Flags: feedback?(emorley)
(In reply to Wes Kocher (:KWierso) from comment #4)
> This kinda resolves bug 1042751.

I'll morph that bug to be about figuring out why and fixing the fact that the repo should be showing results.
Assignee: nobody → kwierso
Status: NEW → ASSIGNED
Summary: UI flashes "Unknown revision id" when initially loading page → UI flashes "Unknown revision id" when initially loading page & message isn't accurate for when no params set
Comment on attachment 8487495 [details] [review]
Fix and add various failure messages

The wording of the explanations looks good, thank you :-)
I'll leave the implementation review to Cameron.
Attachment #8487495 - Flags: feedback?(emorley) → feedback+
Attachment #8487495 - Flags: review?(cdawson) → review+
Commits pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/08cc4f1a6603b5fbf353091d6045166144f732e5
Bug 1065541 - Fix the unknown revision ID message and add a few other messages for various failure cases

https://github.com/mozilla/treeherder-ui/commit/34a8c4a6e00ec0b68d0535495f19504ab3d10305
Merge pull request #165 from KWierso/1065541

Bug 1065541 - Fix the unknown revision ID message along with a few other related fixes.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 1066324
Blocks: 1046226
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/3bef4a3584f86dfe94082e78641e37f0b6e8aafa
Bug 1065541 - Fix the unknown revision ID message and add a few other messages for various failure cases

https://github.com/mozilla/treeherder/commit/55c68ca8ec0c620ce142cee969115d5a4914845f
Merge pull request #165 from KWierso/1065541

Bug 1065541 - Fix the unknown revision ID message along with a few other related fixes.
Duplicate of this bug: 1068810
You need to log in before you can comment on or make changes to this bug.