Closed Bug 1065678 Opened 7 years ago Closed 7 years ago

Need a way to sync fixture changes between repo and production

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: emorley)

References

Details

For bug 1065659, bug 1051508, bug 1051508 and others, we've done one or both of:
1) Made a change using Django admin in production
2) Made a change to the relevant fixture in https://github.com/mozilla/treeherder-service/tree/master/treeherder/model/fixtures

The problem is that:
1) The file in the repo doesn't now entirely match that in production - so even a |vagrant destroy && vagrant up| won't get a local environment that has the same fixtures as production.
2) Dev/staging are now significantly out of sync, since we've typically only updated the repo file and production DB.
3) People with an existing vagrant environment may not realise it's out of sync.

At the least we need to be able to generate a report that can diff the repo fixtures against production (and dev/staging) so we know what to update.

However ideally we want to do one of:
a) manage this via the repo (ie change the file in the repo and have the DB changed when it is deployed to prod). Though this would presumably mean we would have to make parts of the Django admin read-only, which may not be ideal.
b) Be able to export the current production fixtures from the DB and check that into the repo (eg: this would allow us to extract the descriptions added by bug 1051508 more easily).
Depends on: 1065784
Depends on: 1065754
Fixed by the patch in bug 1065754.
For dev/staging, making sure they match production is a bigger task, so breaking that out to another bug.
Assignee: nobody → emorley
Priority: -- → P2
Summary: Need a way to report fixture discrepancies/sync changes between repo and dev/staging/prod → Need a way to sync fixture changes between repo and production
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.