Task Manager stop working after some time of use

VERIFIED DUPLICATE of bug 1066607

Status

defect
--
blocker
VERIFIED DUPLICATE of bug 1066607
5 years ago
4 years ago

People

(Reporter: zrzut01, Unassigned)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [hamachi] [systemsfe])

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

1. Open https://bugzilla.mozilla.org/show_bug.cgi?id=1064816 page


Actual results:

After press and hold Home button to get into Task Manager only 'X' (as shown on attached screenshot) button of task manager appears.


Expected results:

It should be possible to get into Task Manager from everywhere.
Found on:

Alcatel One Touch Fire production (got from T-mobile Poland)
B2G version: 2.2.0.0-prerelease master
Platform version: 35.0a1
Build Identifier: 20140910160202 
Git commit info: 2014-09-10 19:50:09 7f21bdda
Component: General → Gaia::System::Window Mgmt
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [hamachi]
Need to backout something or fix this rather fast. Phone becomes rather unusable when this happens.
Severity: normal → blocker
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking-b2g: --- → 2.2?
QA Wanted - Can this be reproduced on Flame?
Keywords: qawanted
This was happening to me earlier today on Flame [2.2], but there was another update few hours ago,
and so far haven't seen the issue again.
Happened again.

And looks like loading the bug page mentioned in the description works as an STR.
(In reply to Jason Smith [:jsmith] from comment #5)
> QA Wanted - Can this be reproduced on Flame?

I'm unable to reproduce this issue following STR on either 319MB Flame or 512MB Flame, using 9/11 nightly user build or latest tinderbox eng build. Also tried on KK base with 9/11 tinderbox eng build with no repro. Total repro rate: 0/50. Task Manager shows up as expected in all attempts.

(nightly user build)
Device: Flame (319MB)
BuildID: 20140911040205
Gaia: 7f21bdda274f0329393ef0e5a9374c06255c6f57
Gecko: bc7deafdac4b
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

(tinderbox eng build)
Device: Flame (512MB/319MB)
BuildID: 20140912061053
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: 59d4326311e0
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

(tinderbox eng build)
Device: Flame (319MB)
BuildID: 20140911061437
Gaia: 7f21bdda274f0329393ef0e5a9374c06255c6f57
Gecko: 86c56f5b2e84
Version: 35.0a1 (2.2 Master)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Leaving qawated tag for others to try.
Issue still occurs on devices:

Alcatel One Touch Fire production (got from T-mobile Poland)
B2G version: 2.2.0.0-prerelease master
Platform version: 35.0a1
Build Identifier: 20140912040204
Git commit info: 2014-09-11 18:42:44 6cb5e010

Foxconn InFcocus F1 tablet (Tablet Contribution Programme)
B2G version: 2.2.0.0-prerelease master
Firmware revision: flatfish_20140913-0124
Platform version: 35.0a1
Build Identifier: 20140913013447
Git commit info: 2014-09-12 16:28:06 4c99aedd
This occurs relatively often, but looks like STR isn't very reliable, at least on Flame.
This bug does NOT repro on Flame kk build: Flame 2.2 KK

Actual Result: Long holding the home button does not produce any anomalies in the card view screen.

Repro Rate: 0/12 attempts

Environmental Variables:
Device: Flame Master
BuildID: 20140915091417
Gaia: 855be6ade407c26e0596e7306a44deebc3f60933
Gecko: d08c31df0c1a
Version: 35.0a1 (Master) 
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
I got this yesterday once, using the latest Nightly builds. So certainly still there.
Olli,
   I tested today on the latest 9/17 Flame 2.2 Jelly Bean Nightly build and I'm unable to reproduce. I tried to mimic the setup in the screenshot as it looks like there are headphones in with music playing and wifi is disabled. 
While card view definitely has bugs with it that I'm seeing, I cannot get this bug to occur.

Can you try something for me?
1. Reboot the flame device.
2. Launch the webpage in the browser listed in comment 0.
3. Hold down the home button to go into card view.
<Does this bug occur?> 

I'm just trying to find out if it's this simple to get and nothing else needs to take place for this bug to occur. From the STR it seems it should be this simple.

Any additional information about the flame setup that might help me would be greatly appreciated.
Thanks!

My build used while testing

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140917040204
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 8252eae8278c
Version: 35.0a1 (Master) 
Firmware Version: L1TC00011230
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(bugs)
I can't reproduce this reliably as I said in comment 10.
But this does happen occasionally, and when it happens, one pretty much has to reboot the phone
to get it working again. I know, this is not too useful for figuring out what goes wrong.

Hopefully someone who is hacking the window management could take a look at this.
Flags: needinfo?(bugs)
QA-Wanted team has been unable to repro this issue on Flame - recommend pursuing this issue on other reported devices do to extremely low Flame repro rate / unreliable steps.

Feel free to re-add tag if more information becomes available that helps to repro on Flame.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
It is not extremely low-repro, but sure, no reliable STR.
After flash device with my own build can't reproduce the issue with use of STR from Description. 

Alcatel One Touch Fire production (got from T-mobile Poland)
B2G version: 2.2.0.0-prerelease master
Platform version: 35.0a1
Build Identifier: 20140916142307 
Git commit info: 2014-09-16 09:11:51 c4510528

Will test again after FOTA update will be available because now it has been put on hold because of critical bug.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Triage: Moving to system frontend.
Whiteboard: [hamachi] → [hamachi] [systemsfe]
Maybe E/GeckoConsole(  138): [JavaScript Error: "TypeError: undefined is not a valid URL." {file: "app://system.gaiamobile.org/js/cards_helper.js" line: 61}] ?
blocking-b2g: 2.2? → 2.2+
Etienne, can you take a look?
Flags: needinfo?(etienne)
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(etienne)
Resolution: --- → DUPLICATE
Duplicate of bug: 1066607
Target Milestone: --- → 2.1 S5 (26sep)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.