[Flame][KK] Cannot detect SD card

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
General
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: njpark, Assigned: dhylands)

Tracking

(Depends on: 1 bug, {regression, smoketest})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR:
Go to settings, enable USB storage
Plug the usb cable to computer

Expected:
Both the SD card and Internal SD are shown on computer
Actual:
Only the Internal SD card is shown,and there is no selectable list menu available before each SD card storage section in Settings -> Media Storage

Version info:
Base Image: v180
Gaia      d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d44dfce2e5b
BuildID   20140910165554
Version   34.0a2
ro.build.date   Wed Sep 10 20:15:02 EDT 2014
ro.bootloader   L1TC10011800
ro.build.version.incremental   eng.cltbld.20140910.201451
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]:
SD card is not detectable with the latest base image (v180)
blocking-b2g: --- → 2.1?

Updated

3 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 3 years ago
No longer depends on: 1066121
Resolution: --- → DUPLICATE
Duplicate of bug: 1058376
(Assignee)

Comment 3

3 years ago
I think that this isn't a dup. I've been able to reproduce. So I'm reopening.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

3 years ago
Component: Gaia::Settings → General
Target Milestone: --- → 2.1 S6 (10oct)
(Assignee)

Updated

3 years ago
Assignee: nobody → dhylands
[Blocking Requested - why for this release]:
Is a regression and fails smoke test case #6072
https://moztrap.mozilla.org/manage/case/6072/
blocking-b2g: --- → 2.1?
Keywords: regression, smoketest
Created attachment 8493982 [details]
logcat

Attaching logcat of issue occuring

Updated

3 years ago
blocking-b2g: 2.1? → 2.1+
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory-2]

Comment 6

3 years ago
This issue is caused by bug 1059484.
Status: NEW → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059484
(Assignee)

Comment 7

3 years ago
I'm pretty sure that this bug is NOT a dup of 1059844.
Un-duping for now since patch for 1059484 is in our build and we can still reproduce this issue.

Device: Flame 2.1 KK (319mb)
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

3 years ago
Target Milestone: 2.1 S6 (10oct) → 2.1 S5 (26sep)
(Assignee)

Comment 9

3 years ago
This looks like its an issue with the base image and/or a config issue.

I can reproduce with v180 and flame-kk.

I'm going to try and go back to flame-kk and 165 and see if it happens there.

From what I can see in logcat, the gecko side of things is working properly, and it's the kernel side of things that is falling down.
(Assignee)

Comment 10

3 years ago
OK- this looks like we've messed up our building of the kernel and/or root file system files.

If I flash either the v165 or v180 base image and shallow-flash gecko and gaia, then both the internal and external sdcards work properly.

If I full-flash gecko-gaia built using either 165 or 180 base, then things start to mis-behave.
(Assignee)

Comment 11

3 years ago
Homing in...

Looks like something in /system

If I do a full flash of my local build, then fastboot flash system.img from the base image, and then shallow flash just gecko, then UMS works properly.
(Assignee)

Comment 12

3 years ago
I've narrowed it down to vold.

If I do a full flash of my local build and then push vold fro mthe base image, then UMS works properly.
(Assignee)

Comment 13

3 years ago
It looks like our manifest is using an old version of vold, and we need to find out from the vendor what the correct branch to use is.
(Assignee)

Comment 14

3 years ago
frlee - we need to get our branches updated. The branch we have for platform/system/vold doesn't work properly (and since it doesn't work, there probably are others as well).

So we need to get the correct branches from the vendor for the v180 base image.
Flags: needinfo?(frlee)
(Assignee)

Comment 15

3 years ago
Created attachment 8495563 [details] [review]
Grab vold from backup-flame rather than the version that was built.

This is just temporary because this is a smoketest-blocker.

Once we get a version of vold we can build, then I'll back this out.
Attachment #8495563 - Flags: review?(mwu)

Comment 16

3 years ago
Comment on attachment 8495563 [details] [review]
Grab vold from backup-flame rather than the version that was built.

I think you used spaces instead of a tab.
Attachment #8495563 - Flags: review?(mwu) → review+
(Assignee)

Comment 17

3 years ago
Yeah - I saw that. I'll fix it before landing.
(Assignee)

Comment 18

3 years ago
https://github.com/mozilla-b2g/device-flame/commit/52c909e821d107d414f851e267dedcd7aae2cebf
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Depends on: 1073273

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][COM=Storage]
No-jun, check this is fixed against master?   also, still needs 2.1 uplifting.
Flags: needinfo?(npark)
Keywords: verifyme
(Reporter)

Comment 20

3 years ago
verified in tinderbox build, and now I can see all drives and all media files inside.
Flags: needinfo?(npark)
QA Whiteboard: [QAnalyst-Triage?][COM=Storage] → [QAnalyst-Triage+][COM=Storage]
Flags: needinfo?(dharris)
(Assignee)

Comment 21

3 years ago
Comment on attachment 8495563 [details] [review]
Grab vold from backup-flame rather than the version that was built.

Approval Request Comment
[Feature/regressing bug #]:v180 base image
[User impact if declined]:USB Mass Storage doesn't work properly
[Describe test coverage new/current, TBPL]: None
[Risks and why]: None
[String/UUID change made/needed]:None

The version of vold that we currently build from source only works properly under JB. This patch uses the vold that comes with the base image rather then the one we build from source (for KK builds only)
Attachment #8495563 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 22

3 years ago
Hmm. Yeah it looks like the manifest in aurora has been advanced to include this commit.

So it looks like the manifest for 2.1 isn't frozen:
https://github.com/mozilla-b2g/b2g-manifest/blob/v2.1/flame-kk.xml#L149

A number of other repositories are also not frozen (anything without a hash), so they'll be picking things up that weren't approved.
Whiteboard: [2.1-exploratory-2]
not sure if you still need info from me.
if you still need anything from T2M, please kindly ni wehuang@mozilla.com
Flags: needinfo?(frlee)
(Assignee)

Comment 24

3 years ago
We need the hashes/branches used to build the v180 base image.

Currently, what we have is incorrect - for example the vold that we build from source doesn't work, whereas the one that comes with the v180 base image does.
Flags: needinfo?(wehuang)
Verified as fixed on the Flame v2.1.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140929000203
Gaia: 063de64a4ffc606e931ed7b09e93282713c46eca
Gecko: 055d46b81ed1
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

SD card is detected.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Storage] → [QAnalyst-Triage?][COM=Storage]
status-b2g-v2.1: affected → verified
Flags: needinfo?(pbylenga)
Keywords: verifyme
i dont understand how this is verifeid, when the patch has not been uplifted to 2.1 yet  (no approval+ on the patch).  please watch and retest this when you see the status-b2g-2.1= "fixed".
status-b2g-v2.1: verified → affected
(Assignee)

Comment 27

3 years ago
(In reply to Tony Chung [:tchung] from comment #26)
> i dont understand how this is verifeid, when the patch has not been uplifted
> to 2.1 yet  (no approval+ on the patch).  please watch and retest this when
> you see the status-b2g-2.1= "fixed".

This is verifed because the 2.1 manifest has the following line in it:

> <project name="device-flame" path="device/t2m/flame" remote="b2g" revision="kitkat"/>

i.e. it tracks the latest of the kitkat branch for the device-flame repository, and isn't using a "frozen" hash.

For the record, the following repositories are not frozen in 2.1 (and not using a v2.1 branch)

> <project name="platform_build" path="build" remote="b2g" revision="b2g-4.4.2_r1">
>     <copyfile dest="Makefile" src="core/root.mk"/>
> </project>
> <project name="platform_prebuilts_qemu-kernel" path="prebuilts/qemu-kernel" remote="b2g" revision="b2g-4.4.2_r1"/>
> <project name="device-flame" path="device/t2m/flame" remote="b2g" revision="kitkat"/>
> <project name="codeaurora_kernel_msm" path="kernel" remote="b2g" revision="t2m-flame-3.4-kk"/>
> <project name="kernel_lk" path="bootable/bootloader/lk" remote="b2g" revision="foxfone-one-v1.4"/>
Flame v2.1 build's Gonk hash: 5883a99b6528ced9dafaed8d3ca2405fb285537e.
Can you confirm we have your patch in our test environment?
Flags: needinfo?(pbylenga) → needinfo?(dhylands)
fd2ace405952a06d16eb8a1334129007c3f179fa(In reply to Rachel Pribble [:rpribble] from comment #28)
> Flame v2.1 build's Gonk hash: 5883a99b6528ced9dafaed8d3ca2405fb285537e.

Previous listed is incorrectly listed as Flame v2.1 build's Gonk hash, but it is Flame v2.2 build's Gonk hash.
Restatement for verification:

Flame v2.1 build's Gonk hash: fd2ace405952a06d16eb8a1334129007c3f179fa
Flame v2.2 build's Gonk hash: 5883a99b6528ced9dafaed8d3ca2405fb285537e
(Assignee)

Comment 31

3 years ago
It's the device-flame hash that matters.
Flags: needinfo?(dhylands)
Flame v2.1 & v2.2 device-flame hash: 52c909e821d107d414f851e267dedcd7aae2cebf
(In reply to Rachel Pribble [:rpribble] from comment #32)
> Flame v2.1 & v2.2 device-flame hash: 52c909e821d107d414f851e267dedcd7aae2cebf

Rachel, are you confirming that you see this hash on your device that you verified against?  if so, then Dave's irc comment confirms you have the right build, and you can set the status-b2g-21: back to verified.

> dhylands: tchung: PBylenga: In particular the hash of 52c909e821d107d414f851e267dedcd7aae2cebf is the one that fixes the problem
Yes, that is correct. Changing back to verified again.
status-b2g-v2.1: affected → verified
Comment on attachment 8495563 [details] [review]
Grab vold from backup-flame rather than the version that was built.

Clearing the nom as this is verified on 2.1 as the change is on mozilla-aurora already
Attachment #8495563 - Flags: approval-mozilla-aurora?
Hi Dave:

Sorry for seeing this late, do you still need the branch information mentioned in comment#24? 
BTW last week we've released v188 SW to b2g-internal, FYI.
Flags: needinfo?(wehuang)
status-b2g-v2.2: --- → fixed
Verified Fixed on the latest Flame 2.2 build.
SD Card is detected properly, and visible when connected via USB.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
status-b2g-v2.2: fixed → verified
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][COM=Storage] → [QAnalyst-Triage+][COM=Storage]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.