Folderpane: Bold text and icons are gone

VERIFIED FIXED

Status

P1
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: mythdraug, Assigned: sspitzer)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Account names are no longer bold

Folders with new mail are not longer bold



Build: 2001102503  Win32

Comment 1

17 years ago
adding the fact that folder icons are gone.  Confirming.  My guess is that this
is related to everything that's making the product crash.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Summary: Folderpane: Bold text is gone → Folderpane: Bold text and icons are gone

Updated

17 years ago
QA Contact: esther → laurel

Comment 2

17 years ago
I love the trunk.

Comment 3

17 years ago
*** Bug 106753 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Man, did the Windows XP launch screw mozilla up <g>
Marking ALL
There are so many regressions today
OS: Windows 2000 → All
Hardware: PC → All
Keywords: regression
accepting, I'll investigate.
Status: NEW → ASSIGNED

Comment 6

17 years ago
It's like the mozilla apocalypse.  After this long period of stability, these
last two days will live on in infamy!
it doesn't look like we're even loading the folderPane.css stylesheet.

(that's why there isn't any bold or icons.)

if I append the contents of folderPane.css into outliner.css, it works.

investigating, this might be boris's changes.
boris, this goes away if I revert your checkin.
here's what I backed out locally:

cvs update -j1.135 -j1.134 mozilla/content/xml/document/src/nsXMLDocument.cpp
cvs update -j1.37 -j1.36 mozilla/content/xml/content/src/nsXMLProcessingInstruct
ion.cpp
cvs update -j3.94 -j3.93 mozilla/content/html/style/src/nsCSSLoader.cpp
cvs update -j3.14 -j3.13 mozilla/content/html/style/public/nsICSSLoader.h
cvs update -j1.5 -j1.4 mozilla/content/base/src/nsStyleLinkElement.h
cvs update -j1.12 -j1.11 mozilla/content/base/src/nsStyleLinkElement.cpp
cvs update -j3.7 -j3.6 mozilla/content/base/public/nsIStyleSheetLinkingElement.h
this is the minimal back out:

cvs update -j3.94 -j3.93 mozilla/content/html/style/src/nsCSSLoader.cpp
cvs update -j3.14 -j3.13 mozilla/content/html/style/public/nsICSSLoader.h
Created attachment 55172 [details] [diff] [review]
temporary fix, sorry hwaara
this is a great bug.

the special character in hwaara's name causes us to fail to convert the style 
sheet to UTF-8.

this is exposed by a recent check in by boris.

I'll open a new bug on boris, so he can fix the real problem (he's still 
thinking about it) and then he can restore hwaara's name.

sorry about that hwaara.
Um... correction.  :)  Convert _from_ UTF-8.

Basically, my change had one major impact on chrome sheets.  Instead of assuming
that the default encoding is ISO-8859-1, we now use the document encoding which
defaults to UTF-8 for XML documents using one-byte chars (ie all of our XUL). 
That stylesheet cannot be converted from UTF-8 to Unicode because of the å in
Håkan's name -- that char followed by "k" is apparently not a valid char
sequence in UTF-8, while it is in ISO-8859-1.

Further discussion in the new bug.
this is fixed, I changed the character in the file.

http://bugzilla.mozilla.org/show_bug.cgi?id=106843

tracks the real issue, once resolved, we'll add the character back.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
*** Bug 106871 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 106828 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

17 years ago
vrfy on 2001102603 win32
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
Thanks for verifying this, but we usually don't mark verified until it's been
checked on all platforms.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.